Browse Source

open-plc-utils: fix compilation with GCC10

Signed-off-by: Rosen Penev <rosenp@gmail.com>
lilik-openwrt-22.03
Rosen Penev 4 years ago
parent
commit
6617c64487
No known key found for this signature in database GPG Key ID: 36D31CFA845F0E3B
2 changed files with 12 additions and 1 deletions
  1. +1
    -1
      utils/open-plc-utils/Makefile
  2. +11
    -0
      utils/open-plc-utils/patches/010-gcc10.patch

+ 1
- 1
utils/open-plc-utils/Makefile View File

@ -8,7 +8,7 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=open-plc-utils
PKG_RELEASE:=2
PKG_RELEASE:=3
PKG_SOURCE_PROTO:=git
PKG_SOURCE_URL:=https://github.com/qca/open-plc-utils.git


+ 11
- 0
utils/open-plc-utils/patches/010-gcc10.patch View File

@ -0,0 +1,11 @@
--- a/plc/plc.h
+++ b/plc/plc.h
@@ -498,7 +498,7 @@ struct __packed plcproperty
uint8_t DATA_BUFFER [128];
}
-plcproperty;
+extern plcproperty;
#ifndef __GNUC__
#pragma pack (pop)

Loading…
Cancel
Save