Browse Source

gphoto2: add package 2.5.11

Source: OpenWrt repo, rev 32296
Signed-off-by: Leonardo Medici <leonardo_medici@me.com>
lilik-openwrt-22.03
doclm 7 years ago
parent
commit
63ef782425
3 changed files with 149 additions and 0 deletions
  1. +59
    -0
      multimedia/gphoto2/Makefile
  2. +46
    -0
      multimedia/gphoto2/patches/001-automake-compat.patch
  3. +44
    -0
      multimedia/gphoto2/patches/002-no-docs-test.patch

+ 59
- 0
multimedia/gphoto2/Makefile View File

@ -0,0 +1,59 @@
#
# Copyright (C) 2006-2012 OpenWrt.org
# Copyright (C) 2017 Leonardo Medici
#
# This is free software, licensed under the GNU General Public License v2.
# See /LICENSE for more information.
#
include $(TOPDIR)/rules.mk
PKG_NAME:=gphoto2
PKG_VERSION:=2.5.11
PKG_RELEASE:=1
PKG_MAINTAINER:=Leonardo Medici <leonardo_medici@me.com>
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
PKG_SOURCE_URL:=@SF/gphoto
PKG_MD5SUM:=a62a51474a681aca51b087905deb5e35
PKG_HASH:=392844d6a06512b0d85e7983a5a0c85c8039feb6ab3bc420674ffdbf7536f9e9
PKG_LICENSE:=GPL-2.0
PKG_LICENSE_FILES:=COPYING
PKG_FIXUP:=autoreconf
PKG_INSTALL:=1
include $(INCLUDE_DIR)/package.mk
define Package/gphoto2
SECTION:=multimedia
CATEGORY:=Multimedia
TITLE:=Gphoto Digital Camera Control
URL:=http://www.gphoto.org/
DEPENDS:=+libgphoto2 +libpopt +libpthread +libreadline +libncurses +libexif +libjpeg
endef
define Package/gphoto2/description
For downloading and controlling digital cameras
endef
CONFIGURE_ARGS += \
--without-aalib \
--without-libiconv-prefix \
--without-libintl-prefix \
CONFIGURE_VARS += \
LIBGPHOTO2_CFLAGS="$$$$CFLAGS -I$(STAGING_DIR)/usr/include/gphoto2 $$$$CPPFLAGS" \
LIBGPHOTO2_LIBS="$$$$LDFLAGS -lgphoto2 -lgphoto2_port -lltdl" \
LIBEXIF_CFLAGS="$$$$CFLAGS $$$$CPPFLAGS" \
LIBEXIF_LIBS="$$$$LDFLAGS -lexif" \
POPT_CFLAGS="$$$$CFLAGS $$$$CPPFLAGS" \
POPT_LIBS="$$$$LDFLAGS -lpopt" \
define Package/gphoto2/install
$(INSTALL_DIR) $(1)/usr/bin
$(CP) $(PKG_INSTALL_DIR)/usr/bin/$(PKG_NAME) $(1)/usr/bin/
endef
$(eval $(call BuildPackage,gphoto2))

+ 46
- 0
multimedia/gphoto2/patches/001-automake-compat.patch View File

@ -0,0 +1,46 @@
Index: gphoto2-2.5.11/Makefile.am
===================================================================
--- gphoto2-2.5.11.orig/Makefile.am
+++ gphoto2-2.5.11/Makefile.am
@@ -1,4 +1,4 @@
-SUBDIRS = gphoto-m4 contrib doc gphoto2 packaging po tests
+SUBDIRS = gphoto-m4 contrib doc gphoto2 packaging tests
ACLOCAL_AMFLAGS = -I auto-m4 -I gphoto-m4
EXTRA_DIST = README.md
Index: gphoto2-2.5.11/Makefile.in
===================================================================
--- gphoto2-2.5.11.orig/Makefile.in
+++ gphoto2-2.5.11/Makefile.in
@@ -390,7 +390,7 @@ target_alias = @target_alias@
top_build_prefix = @top_build_prefix@
top_builddir = @top_builddir@
top_srcdir = @top_srcdir@
-SUBDIRS = gphoto-m4 contrib doc gphoto2 packaging po tests
+SUBDIRS = gphoto-m4 contrib doc gphoto2 packaging tests
ACLOCAL_AMFLAGS = -I auto-m4 -I gphoto-m4
EXTRA_DIST = README.md
all: config.h
Index: gphoto2-2.5.11/configure.ac
===================================================================
--- gphoto2-2.5.11.orig/configure.ac
+++ gphoto2-2.5.11/configure.ac
@@ -59,10 +59,7 @@ dnl ------------------------------------
GP_GETTEXT_HACK([],[Lutz Müller and others],[${MAIL_GPHOTO_TRANSLATION}])
ALL_LINGUAS="az cs da de en_GB es eu fi fr hu id is it ja nl pa pl pt_BR ro ru rw sk sr sv uk vi zh_CN zh_TW"
AM_GNU_GETTEXT_VERSION([0.14.1])
-AM_GNU_GETTEXT([external])
-AM_PO_SUBDIRS()
AM_ICONV()
-GP_GETTEXT_FLAGS()
dnl We cannot use AC_DEFINE_UNQUOTED() for these definitions, as
dnl we require make to do insert the proper $(datadir) value
@@ -354,7 +351,6 @@ AC_SUBST([AM_LDFLAGS])
# Create output files
# ---------------------------------------------------------------------------
AC_CONFIG_FILES([
-po/Makefile.in
Makefile
gphoto2/Makefile
gphoto-m4/Makefile

+ 44
- 0
multimedia/gphoto2/patches/002-no-docs-test.patch View File

@ -0,0 +1,44 @@
Index: gphoto2-2.5.11/Makefile.am
===================================================================
--- gphoto2-2.5.11.orig/Makefile.am
+++ gphoto2-2.5.11/Makefile.am
@@ -1,4 +1,4 @@
-SUBDIRS = gphoto-m4 contrib doc gphoto2 packaging tests
+SUBDIRS = gphoto-m4 contrib gphoto2 packaging
ACLOCAL_AMFLAGS = -I auto-m4 -I gphoto-m4
EXTRA_DIST = README.md
Index: gphoto2-2.5.11/Makefile.in
===================================================================
--- gphoto2-2.5.11.orig/Makefile.in
+++ gphoto2-2.5.11/Makefile.in
@@ -390,7 +390,7 @@ target_alias = @target_alias@
top_build_prefix = @top_build_prefix@
top_builddir = @top_builddir@
top_srcdir = @top_srcdir@
-SUBDIRS = gphoto-m4 contrib doc gphoto2 packaging tests
+SUBDIRS = gphoto-m4 contrib gphoto2 packaging
ACLOCAL_AMFLAGS = -I auto-m4 -I gphoto-m4
EXTRA_DIST = README.md
all: config.h
Index: gphoto2-2.5.11/configure.ac
===================================================================
--- gphoto2-2.5.11.orig/configure.ac
+++ gphoto2-2.5.11/configure.ac
@@ -354,16 +354,10 @@ AC_CONFIG_FILES([
Makefile
gphoto2/Makefile
gphoto-m4/Makefile
-doc/Makefile
contrib/Makefile
packaging/Makefile
packaging/rpm/Makefile
packaging/rpm/package.spec
-tests/data/Makefile
-tests/staging/subdir1/Makefile
-tests/staging/subdir2/Makefile
-tests/staging/Makefile
-tests/Makefile
])
AC_OUTPUT()dnl

Loading…
Cancel
Save