Browse Source

Merge pull request #3837 from hauke/tor

tor: update to version 0.2.9.8
lilik-openwrt-22.03
Hauke Mehrtens 8 years ago
committed by GitHub
parent
commit
62679585f8
2 changed files with 62 additions and 14 deletions
  1. +51
    -7
      net/tor/Makefile
  2. +11
    -7
      net/tor/patches/001-torrc.patch

+ 51
- 7
net/tor/Makefile View File

@ -8,13 +8,13 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=tor
PKG_VERSION:=0.2.8.11
PKG_VERSION:=0.2.9.8
PKG_RELEASE:=1
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
PKG_SOURCE_URL:=https://dist.torproject.org/ \
https://archive.torproject.org/tor-package-archive
PKG_MD5SUM:=7adea0bfa17edafd4e09453f4f58a0dca737660e5358f9dafd52d55d55dc6ab3
PKG_MD5SUM:=fbdd33d3384574297b88744622382008d1e0f9ddd300d330746c464b7a7d746a
PKG_MAINTAINER:=Hauke Mehrtens <hauke@hauke-m.de>
PKG_LICENSE_FILES:=LICENSE
@ -48,6 +48,28 @@ $(call Package/tor/Default/description)
This package contains the tor daemon.
endef
define Package/tor-gencert
$(call Package/tor/Default)
TITLE:=Tor certificate generation
DEPENDS:=+tor
endef
define Package/tor-gencert/description
$(call Package/tor/Default/description)
Generate certs and keys for Tor directory authorities
endef
define Package/tor-resolve
$(call Package/tor/Default)
TITLE:=tor hostname resolve
DEPENDS:=+tor
endef
define Package/tor-resolve/description
$(call Package/tor/Default/description)
Resolve a hostname to an IP address via tor
endef
define Package/tor-geoip
$(call Package/tor/Default)
TITLE:=GeoIP db for tor
@ -61,22 +83,30 @@ endef
define Package/tor/conffiles
/etc/tor/torrc
/var/lib/tor/fingerprint
/var/lib/tor/keys/*
endef
CONFIGURE_ARGS += \
--with-libevent-dir="$(STAGING_DIR)/usr" \
--with-ssl-dir="$(STAGING_DIR)/usr" \
--with-openssl-dir="$(STAGING_DIR)/usr" \
--with-zlib-dir="$(STAGING_DIR)/usr" \
--disable-asciidoc \
--disable-seccomp
--disable-seccomp \
--disable-libscrypt \
--disable-unittests \
--disable-largefile \
--with-tor-user=tor \
--with-tor-group=tor
EXTRA_CFLAGS += -std=gnu99
ifneq ($(CONFIG_SSP_SUPPORT),y)
CONFIGURE_ARGS += \
--disable-gcc-hardening
MAKE_FLAGS += \
CFLAGS="$(TARGET_CFLAGS) -std=gnu99"
else
MAKE_FLAGS += \
CFLAGS="$(TARGET_CFLAGS) -fPIC -std=gnu99"
EXTRA_CFLAGS += -fPIC
endif
CONFIGURE_VARS += \
@ -85,16 +115,30 @@ CONFIGURE_VARS += \
define Package/tor/install
$(INSTALL_DIR) $(1)/usr/sbin
$(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/bin/tor $(1)/usr/sbin/
$(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/bin/torify $(1)/usr/sbin/
$(INSTALL_DIR) $(1)/etc/init.d
$(INSTALL_BIN) ./files/tor.init $(1)/etc/init.d/tor
$(INSTALL_DIR) $(1)/etc/tor
$(INSTALL_CONF) $(PKG_INSTALL_DIR)/etc/tor/torrc.sample $(1)/etc/tor/torrc
endef
define Package/tor-gencert/install
$(INSTALL_DIR) $(1)/usr/sbin
$(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/bin/tor-gencert $(1)/usr/sbin/
endef
define Package/tor-resolve/install
$(INSTALL_DIR) $(1)/usr/sbin
$(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/bin/tor-resolve $(1)/usr/sbin/
endef
define Package/tor-geoip/install
$(INSTALL_DIR) $(1)/usr/share/tor
$(CP) $(PKG_INSTALL_DIR)/usr/share/tor/geoip $(1)/usr/share/tor/
$(CP) $(PKG_INSTALL_DIR)/usr/share/tor/geoip6 $(1)/usr/share/tor/
endef
$(eval $(call BuildPackage,tor))
$(eval $(call BuildPackage,tor-gencert))
$(eval $(call BuildPackage,tor-resolve))
$(eval $(call BuildPackage,tor-geoip))

+ 11
- 7
net/tor/patches/001-torrc.patch View File

@ -1,11 +1,15 @@
--- a/src/config/torrc.sample.in
+++ b/src/config/torrc.sample.in
@@ -46,11 +46,11 @@
## Uncomment this to start the process in the background... or use
## --runasdaemon 1 on the command line. This is ignored on Windows;
## see the FAQ entry if you want Tor to run as an NT service.
-#RunAsDaemon 1
+RunAsDaemon 1
@@ -39,7 +39,7 @@
## Send every possible message to @LOCALSTATEDIR@/log/tor/debug.log
#Log debug file @LOCALSTATEDIR@/log/tor/debug.log
## Use the system log instead of Tor's logfiles
-#Log notice syslog
+Log notice syslog
## To send all messages to stderr:
#Log debug stderr
@@ -50,7 +50,7 @@
## The directory for keeping all the keys/etc. By default, we store
## things in $HOME/.tor on Unix, and in Application Data\tor on Windows.
@ -14,7 +18,7 @@
## The port on which Tor will listen for local connections from Tor
## controller applications, as documented in control-spec.txt.
@@ -202,3 +202,4 @@
@@ -204,3 +204,4 @@
## address manually to your friends, uncomment this line:
#PublishServerDescriptor 0


Loading…
Cancel
Save