mutt: bump versionlilik-openwrt-22.03
@ -1,27 +0,0 @@ | |||||
From b0e285a8c7faaec8807fdd677da6750f341f0109 Mon Sep 17 00:00:00 2001 | |||||
From: Phil Eichinger <phil@zankapfel.net> | |||||
Date: Thu, 19 Nov 2015 13:18:53 +0100 | |||||
Subject: [PATCH] no po and docs | |||||
[adapted old patch and converted to git patch] | |||||
Signed-off-by: Phil Eichinger <phil@zankapfel.net> | |||||
--- | |||||
Makefile.in | 2 +- | |||||
1 file changed, 1 insertion(+), 1 deletion(-) | |||||
diff --git a/Makefile.in b/Makefile.in | |||||
index 1909835..cfa7ca0 100644 | |||||
--- a/Makefile.in | |||||
+++ b/Makefile.in | |||||
@@ -470,7 +470,7 @@ get_cs_cmdline = $(call get_cs_compile,$ | |||||
AUTOMAKE_OPTIONS = 1.6 foreign | |||||
@BUILD_IMAP_TRUE@IMAP_SUBDIR = imap | |||||
@BUILD_IMAP_TRUE@IMAP_INCLUDES = -I$(top_srcdir)/imap | |||||
-SUBDIRS = m4 po intl doc contrib $(IMAP_SUBDIR) | |||||
+SUBDIRS = m4 intl contrib $(IMAP_SUBDIR) | |||||
bin_SCRIPTS = muttbug flea $(SMIMEAUX_TARGET) | |||||
@BUILD_HCACHE_TRUE@HCVERSION = hcversion.h | |||||
BUILT_SOURCES = keymap_defs.h patchlist.c reldate.h conststrings.c $(HCVERSION) | |||||
-- | |||||
2.1.4 | |||||
@ -0,0 +1,26 @@ | |||||
From 6dbfafd4b8bfc9f5e53db90c5279784c506a3253 Mon Sep 17 00:00:00 2001 | |||||
From: Phil Eichinger <phil@zankapfel.net> | |||||
Date: Tue, 17 Oct 2017 06:44:04 +0200 | |||||
Subject: [PATCH] no po | |||||
docs are disabled via ./configure --disable-doc now | |||||
--- | |||||
Makefile.am | 2 +- | |||||
1 file changed, 1 insertion(+), 1 deletion(-) | |||||
diff --git a/Makefile.am b/Makefile.am | |||||
index 4bc2db4..bb00927 100644 | |||||
--- a/Makefile.am | |||||
+++ b/Makefile.am | |||||
@@ -14,7 +14,7 @@ IMAP_SUBDIR = imap | |||||
IMAP_INCLUDES = -I$(top_srcdir)/imap | |||||
endif | |||||
-SUBDIRS = m4 po intl $(DOC_SUBDIR) contrib $(IMAP_SUBDIR) | |||||
+SUBDIRS = m4 intl $(DOC_SUBDIR) contrib $(IMAP_SUBDIR) | |||||
bin_SCRIPTS = muttbug flea $(SMIMEAUX_TARGET) | |||||
-- | |||||
2.11.0 | |||||
@ -1,31 +0,0 @@ | |||||
From: Antonio Radici <antonio@debian.org> | |||||
Date: Fri, 18 Sep 2015 11:48:47 +0200 | |||||
Subject: 771125-CVE-2014-9116-jessie | |||||
This patch solves the issue raised by CVE-2014-9116 in bug 771125. | |||||
We correctly redefine what are the whitespace characters as per RFC5322; by | |||||
doing so we prevent mutt_substrdup from being used in a way that could lead to | |||||
a segfault. | |||||
The lib.c part was written by Antonio Radici <antonio@debian.org> to prevent | |||||
crashes due to this kind of bugs from happening again. | |||||
Signed-off-by: Matteo F. Vescovi <mfv@debian.org> | |||||
--- | |||||
lib.c | 3 +++ | |||||
1 file changed, 3 insertions(+) | |||||
diff -rupN a/lib.c b/lib.c | |||||
--- a/lib.c | |||||
+++ b/lib.c | |||||
@@ -815,6 +815,9 @@ char *mutt_substrdup (const char *begin, | |||||
size_t len; | |||||
char *p; | |||||
+ if (end != NULL && end < begin) | |||||
+ return NULL; | |||||
+ | |||||
if (end) | |||||
len = end - begin; | |||||
else |