Browse Source

cyrus-sasl: Update to 2.1.27

Signed-off-by: W. Michael Petullo <mike@flyn.org>
lilik-openwrt-22.03
W. Michael Petullo 6 years ago
parent
commit
60c34288e4
2 changed files with 3 additions and 44 deletions
  1. +3
    -5
      libs/cyrus-sasl/Makefile
  2. +0
    -39
      libs/cyrus-sasl/patches/010-openssl-deprecated.patch

+ 3
- 5
libs/cyrus-sasl/Makefile View File

@ -8,16 +8,14 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=cyrus-sasl
PKG_VERSION_BASE:=2.1.27
PKG_VERSION:=$(PKG_VERSION_BASE)-rc8
PKG_RELEASE:=2
PKG_VERSION:=2.1.27
PKG_RELEASE:=1
PKG_MAINTAINER:=W. Michael Petullo <mike@flyn.org>
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
PKG_SOURCE_URL:=https://www.cyrusimap.org/releases/
PKG_HASH:=8d95201b4f2c2ec4c0ebafd01c00d7d1e0f2513352b3f850ae2723a90c6c6789
PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION_BASE)
PKG_HASH:=26866b1549b00ffd020f188a43c258017fa1c382b3ddadd8201536f72efb05d5
PKG_LICENSE:=BSD-4c BSD
PKG_LICENSE_FILES:=COPYING cmulocal/COPYING saslauthd/COPYING


+ 0
- 39
libs/cyrus-sasl/patches/010-openssl-deprecated.patch View File

@ -1,39 +0,0 @@
From d2a7592b9884049d3da384c5c37f77629ce9ac56 Mon Sep 17 00:00:00 2001
From: Rosen Penev <rosenp@gmail.com>
Date: Tue, 6 Nov 2018 18:58:30 -0800
Subject: [PATCH] openssl: Fix compilation without deprecated APIs
bn.h was missing. Including engine.h does not work if OpenSSL was built
without it. cyrus-sasl makes no use of it anyway.
---
common/crypto-compat.c | 1 -
common/crypto-compat.h | 1 +
2 files changed, 1 insertion(+), 1 deletion(-)
diff --git a/common/crypto-compat.c b/common/crypto-compat.c
index f4717b6..8195879 100644
--- a/common/crypto-compat.c
+++ b/common/crypto-compat.c
@@ -12,7 +12,6 @@
#if defined(HAVE_OPENSSL) && (OPENSSL_VERSION_NUMBER < 0x10100000L)
#include <string.h>
-#include <openssl/engine.h>
static void *OPENSSL_zalloc(size_t num)
{
diff --git a/common/crypto-compat.h b/common/crypto-compat.h
index 73424ad..d3ffdca 100644
--- a/common/crypto-compat.h
+++ b/common/crypto-compat.h
@@ -15,6 +15,7 @@
#include <openssl/dh.h>
#include <openssl/evp.h>
#include <openssl/hmac.h>
+#include <openssl/bn.h>
int RSA_set0_key(RSA *r, BIGNUM *n, BIGNUM *e, BIGNUM *d);
int RSA_set0_factors(RSA *r, BIGNUM *p, BIGNUM *q);
--
2.19.1

Loading…
Cancel
Save