DNS rebinding protection introduced a new option. Use it to disable it as OpenWrt does not need it. Adjusted Makefile to use the release instead of a git version. Also cleaned up and added LICENSE entries. Eliminated useless patches. The syslog one actually doesn't log much. No need to mask the os release anymore either. Added group entry to init script. Otherwise files end up being owned by user:root which is bogus. Signed-off-by: Rosen Penev <rosenp@gmail.com>lilik-openwrt-22.03
@ -1,26 +0,0 @@ | |||||
--- a/CMakeLists.txt | |||||
+++ b/CMakeLists.txt | |||||
@@ -42,8 +42,8 @@ set(TR_NAME ${PROJECT_NAME}) | |||||
# "Z" for unsupported trunk builds, | |||||
# "0" for stable, supported releases | |||||
# these should be the only two lines you need to change | |||||
-set(TR_USER_AGENT_PREFIX "2.92+") | |||||
-set(TR_PEER_ID_PREFIX "-TR292Z-") | |||||
+set(TR_USER_AGENT_PREFIX "2.92") | |||||
+set(TR_PEER_ID_PREFIX "-TR2920-") | |||||
string(REGEX MATCH "^([0-9]+)\\.([0-9]+).*" TR_VERSION "${TR_USER_AGENT_PREFIX}") | |||||
set(TR_VERSION_MAJOR "${CMAKE_MATCH_1}") | |||||
--- a/configure.ac | |||||
+++ b/configure.ac | |||||
@@ -3,8 +3,8 @@ dnl STATUS: "X" for prerelease beta buil | |||||
dnl "Z" for unsupported trunk builds, | |||||
dnl "0" for stable, supported releases | |||||
dnl these should be the only two lines you need to change | |||||
-m4_define([user_agent_prefix],[2.92+]) | |||||
-m4_define([peer_id_prefix],[-TR292Z-]) | |||||
+m4_define([user_agent_prefix],[2.92]) | |||||
+m4_define([peer_id_prefix],[-TR2920-]) | |||||
AC_INIT([transmission],[user_agent_prefix],[https://trac.transmissionbt.com/newticket]) | |||||
AC_SUBST(USERAGENT_PREFIX,[user_agent_prefix]) |
@ -1,30 +0,0 @@ | |||||
diff --git a/daemon/daemon.c b/daemon/daemon.c | |||||
index 7b2a3b425..5b19d105a 100644 | |||||
--- a/daemon/daemon.c | |||||
+++ b/daemon/daemon.c | |||||
@@ -715,12 +715,7 @@ static int daemon_start(void* raw_arg, bool foreground) | |||||
} | |||||
#ifdef HAVE_SYSLOG | |||||
- | |||||
- if (!foreground) | |||||
- { | |||||
- openlog(MY_NAME, LOG_CONS | LOG_PID, LOG_DAEMON); | |||||
- } | |||||
- | |||||
+ openlog(MY_NAME, LOG_CONS | LOG_PID, LOG_DAEMON); | |||||
#endif | |||||
/* Create new timer event to report daemon status */ | |||||
@@ -772,11 +767,8 @@ cleanup: | |||||
/* shutdown */ | |||||
#ifdef HAVE_SYSLOG | |||||
- if (!foreground) | |||||
- { | |||||
syslog(LOG_INFO, "%s", "Closing session"); | |||||
closelog(); | |||||
- } | |||||
#endif | |||||