Browse Source

nmap: fix compilation with libcxx 10

Seems nmap's time header logic is broken.

Signed-off-by: Rosen Penev <rosenp@gmail.com>
lilik-openwrt-22.03
Rosen Penev 4 years ago
committed by Nuno Goncalves
parent
commit
5f6f54b851
2 changed files with 21 additions and 1 deletions
  1. +1
    -1
      net/nmap/Makefile
  2. +20
    -0
      net/nmap/patches/030-libcxx.patch

+ 1
- 1
net/nmap/Makefile View File

@ -14,7 +14,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=nmap
PKG_VERSION:=7.80
PKG_RELEASE:=2
PKG_RELEASE:=3
PKG_MAINTAINER:=Nuno Goncalves <nunojpg@gmail.com>
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2


+ 20
- 0
net/nmap/patches/030-libcxx.patch View File

@ -0,0 +1,20 @@
--- a/nmap_error.cc
+++ b/nmap_error.cc
@@ -134,6 +134,7 @@
#include "NmapOps.h"
#include "xml.h"
+#include <ctime>
#include <errno.h>
#if TIME_WITH_SYS_TIME
# include <sys/time.h>
--- a/nping/EchoServer.cc
+++ b/nping/EchoServer.cc
@@ -137,6 +137,7 @@
#include "NpingOps.h"
#include "ProbeMode.h"
#include <signal.h>
+#include <ctime>
extern NpingOps o;
extern EchoServer es;

Loading…
Cancel
Save