Browse Source

grilo-plugins: update to 0.3.11

Backports patches from grilo-plugins master to support libdmapshare's
4.0 API.

Signed-off-by: W. Michael Petullo <mike@flyn.org>
lilik-openwrt-22.03
W. Michael Petullo 5 years ago
committed by Eneas U de Queiroz
parent
commit
5cfea02d62
4 changed files with 2776 additions and 4 deletions
  1. +3
    -4
      multimedia/grilo-plugins/Makefile
  2. +1250
    -0
      multimedia/grilo-plugins/patches/010-backport-fix-whitespace.patch
  3. +33
    -0
      multimedia/grilo-plugins/patches/020-backport-add-missing-calls-to-free.patch
  4. +1490
    -0
      multimedia/grilo-plugins/patches/030-backport-libdmapsharing4.patch

+ 3
- 4
multimedia/grilo-plugins/Makefile View File

@ -6,7 +6,7 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=grilo-plugins
PKG_VERSION:=0.3.10
PKG_VERSION:=0.3.11
PKG_RELEASE:=1
PKG_MAINTAINER:=W. Michael Petullo <mike@flyn.org>
@ -15,7 +15,7 @@ PKG_LICENSE_FILES:=COPYING
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
PKG_SOURCE_URL:=@GNOME/grilo-plugins/0.3/
PKG_HASH:=803b360fdb6d5fde1e647bdc40c16de3031b1a95b347b48b65fe4fc27a548d4a
PKG_HASH:=dde2e605b1994341c6bf012493e056b406b08571834dea3b3c671d5b8b1dcd73
PKG_BUILD_PARALLEL:=1
PKG_INSTALL:=1
@ -89,8 +89,7 @@ endef
$(eval $(call BuildPackage,grilo-plugins))
$(eval $(call BuildPlugin,dleyna,DLNA sharing,dleyna,,30))
# This is currently disabled because it won't work with libdmapsharing-4.0.so
#$(eval $(call BuildPlugin,dmap,DAAP and DPAP sharing,daap dpap,libdmapsharing,30))
$(eval $(call BuildPlugin,dmap,DAAP and DPAP sharing,daap dpap,libdmapsharing,30))
$(eval $(call BuildPlugin,gravatar,Gravatar provider,gravatar,,30))
$(eval $(call BuildPlugin,jamendo,Jamendo sharing,jamendo,,30))
$(eval $(call BuildPlugin,magnatune,Magnatune sharing,magnatune,,30))


+ 1250
- 0
multimedia/grilo-plugins/patches/010-backport-fix-whitespace.patch
File diff suppressed because it is too large
View File


+ 33
- 0
multimedia/grilo-plugins/patches/020-backport-add-missing-calls-to-free.patch View File

@ -0,0 +1,33 @@
diff --git a/src/dmap/grl-daap-db.c b/src/dmap/grl-daap-db.c
index c931d91..f460113 100644
--- a/src/dmap/grl-daap-db.c
+++ b/src/dmap/grl-daap-db.c
@@ -232,6 +232,11 @@ grl_daap_db_add (DMAPDb *_db, DMAPRecord *_record)
g_free (id_s);
g_object_unref (media);
+ g_free(album);
+ g_free(artist);
+ g_free(genre);
+ g_free(title);
+ g_free(url);
return --nextid;
}
diff --git a/src/dmap/grl-dpap-db.c b/src/dmap/grl-dpap-db.c
index 02ffd3a..8be278b 100644
--- a/src/dmap/grl-dpap-db.c
+++ b/src/dmap/grl-dpap-db.c
@@ -177,6 +177,12 @@ grl_dpap_db_add (DMAPDb *_db, DMAPRecord *_record)
g_free (id_s);
g_object_unref (media);
+ g_free(filename);
+ g_free(aspectratio);
+ g_free(format);
+ g_free(comments);
+ g_free(url);
+ g_byte_array_unref(thumbnail);
return --nextid;
}

+ 1490
- 0
multimedia/grilo-plugins/patches/030-backport-libdmapsharing4.patch
File diff suppressed because it is too large
View File


Loading…
Cancel
Save