Browse Source

Merge pull request #10173 from Ansuel/uwsgi-fix

uwsgi-cgi: adds patch to fix #10134
lilik-openwrt-22.03
Hannu Nyman 5 years ago
committed by GitHub
parent
commit
5c1c478b9a
No known key found for this signature in database GPG Key ID: 4AEE18F83AFDEB23
7 changed files with 144 additions and 34 deletions
  1. +12
    -4
      net/uwsgi-cgi/Makefile
  2. +23
    -0
      net/uwsgi-cgi/files-luci-support/luci-cgi_io.ini
  3. +31
    -0
      net/uwsgi-cgi/files-luci-support/luci-webui.ini
  4. +0
    -27
      net/uwsgi-cgi/files-luci-support/uwsgi.conf
  5. +10
    -0
      net/uwsgi-cgi/files/emperor.ini
  6. +3
    -3
      net/uwsgi-cgi/files/uwsgi.init
  7. +65
    -0
      net/uwsgi-cgi/patches/030-plugins-cgi_adds_dontresolve_option.patch

+ 12
- 4
net/uwsgi-cgi/Makefile View File

@ -2,7 +2,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=uwsgi-cgi
PKG_VERSION:=2.0.18
PKG_RELEASE:=2
PKG_RELEASE:=3
PKG_SOURCE_URL= \
https://projects.unbit.it/downloads \
@ -51,12 +51,20 @@ endef
define Package/uwsgi-cgi/install
$(INSTALL_DIR) $(1)/usr/sbin
$(INSTALL_BIN) $(PKG_BUILD_DIR)/uwsgi $(1)/usr/sbin/
$(INSTALL_DIR) $(1)/etc/init.d
$(INSTALL_BIN) ./files/uwsgi.init $(1)/etc/init.d/uwsgi
$(INSTALL_DIR) $(1)/etc/uwsgi
$(INSTALL_DATA) ./files/emperor.ini $(1)/etc/uwsgi/emperor.ini
$(INSTALL_DIR) $(1)/etc/uwsgi/vassals
endef
define Package/uwsgi-cgi-luci-support/install
$(INSTALL_DIR) $(1)/etc/init.d
$(INSTALL_BIN) ./files-luci-support/uwsgi.init $(1)/etc/init.d/uwsgi
$(INSTALL_BIN) ./files-luci-support/uwsgi.conf $(1)/etc/uwsgi.conf
$(INSTALL_DIR) $(1)/etc/uwsgi/vassals
$(INSTALL_DATA) ./files-luci-support/luci-webui.ini $(1)/etc/uwsgi/vassals/luci-webui.ini
$(INSTALL_DATA) ./files-luci-support/luci-cgi_io.ini $(1)/etc/uwsgi/vassals/luci-cgi_io.ini
endef
$(eval $(call BuildPackage,uwsgi-cgi))


+ 23
- 0
net/uwsgi-cgi/files-luci-support/luci-cgi_io.ini View File

@ -0,0 +1,23 @@
[uwsgi]
strict = true
socket = /var/run/luci-cgi_io.socket
cgi-mode = true
cgi = /www/
buffer-size = 10000
reload-mercy = 8
max-requests = 2000
limit-as = 200
reload-on-as = 256
reload-on-rss = 192
no-orphans = true
post-buffering = 8192
socket-timeout = 120
thunder-lock = true
#logger = syslog:uwsgi-luci-cgi_io
disable-logging = true
chmod-socket = 666
cgi-safe = /usr/libexec/cgi-io
cgi-dontresolve = true
cgi-close-stdin-on-eof = true
cheap = true
idle = 360

+ 31
- 0
net/uwsgi-cgi/files-luci-support/luci-webui.ini View File

@ -0,0 +1,31 @@
[uwsgi]
strict = true
socket = /var/run/luci-webui.socket
cgi-mode = true
cgi = /www/
chdir = /usr/lib/lua/luci/
buffer-size = 10000
reload-mercy = 8
max-requests = 2000
limit-as = 200
reload-on-as = 256
reload-on-rss = 192
no-orphans = true
vacuum = true
enable-threads = true
post-buffering = 8192
socket-timeout = 120
thunder-lock = true
#logger = syslog:uwsgi-luci
disable-logging = true
log-format = %(addr) %(method) %(uri) => generated %(rsize) bytes in %(msecs) msecs
threads = 3
processes = 3
chmod-socket = 666
cheap = true
cheaper-algo = spare
cheaper = 1
cheaper-initial = 2
cheaper-step = 1
master = true
idle = 360

+ 0
- 27
net/uwsgi-cgi/files-luci-support/uwsgi.conf View File

@ -1,27 +0,0 @@
[uwsgi]
strict = true
socket = /var/run/uwsgi.sock
cgi-mode = true
cgi = /www/
chdir = /usr/lib/lua/luci/
master = true
buffer-size = 10000
reload-mercy = 8
max-requests = 2000
limit-as = 200
reload-on-as = 256
reload-on-rss = 192
no-orphans = true
vacuum = true
enable-threads = true
post-buffering = 8192
socket-timeout = 120
thunder-lock = true
logger = syslog:uwsgi
disable-logging = true
log-format = %(addr) %(method) %(uri) => generated %(rsize) bytes in %(msecs) msecs
pidfile = /var/run/uwsgi.pid
die-on-term = true
threads = 3
processes = 3
chmod-socket = 666

+ 10
- 0
net/uwsgi-cgi/files/emperor.ini View File

@ -0,0 +1,10 @@
[uwsgi]
strict = true
pidfile = /var/run/uwsgi.pid
emperor = /etc/uwsgi/vassals/*.ini
logger = syslog:uwsgi-emperor
vacuum = true
emperor-on-demand-directory = /var/run/
emperor-required-heartbeat = 99
vassal-set = die-on-idle=true
#disable-logging = true

net/uwsgi-cgi/files-luci-support/uwsgi.init → net/uwsgi-cgi/files/uwsgi.init View File


+ 65
- 0
net/uwsgi-cgi/patches/030-plugins-cgi_adds_dontresolve_option.patch View File

@ -0,0 +1,65 @@
From f259999d824b921a8a443e73d8c2b9e2d2170413 Mon Sep 17 00:00:00 2001
From: Ansuel Smith <ansuelsmth@gmail.com>
Date: Tue, 8 Oct 2019 02:10:43 +0200
Subject: [PATCH] plugins/cgi: adds dontresolve option
This option permit to call the simbolic link instead of the file the simbolic link points.
All the security check are still done as the simbolic path is passed at the end after all the checks are passed. This is useful if some cgi app are used for multiple function based on the name they are called by.
Signed-off-by: Ansuel Smith <ansuelsmth@gmail.com>
---
plugins/cgi/cgi_plugin.c | 13 +++++++++++++
1 file changed, 13 insertions(+)
diff --git a/plugins/cgi/cgi_plugin.c b/plugins/cgi/cgi_plugin.c
index d032db17c..30e1cc528 100644
--- a/plugins/cgi/cgi_plugin.c
+++ b/plugins/cgi/cgi_plugin.c
@@ -15,6 +15,7 @@ struct uwsgi_cgi {
struct uwsgi_string_list *loadlib;
struct uwsgi_string_list *cgi_safe;
int optimize;
+ int dontresolve;
int from_docroot;
int has_mountpoints;
struct uwsgi_dyn_dict *default_cgi;
@@ -75,6 +76,8 @@ struct uwsgi_option uwsgi_cgi_options[] = {
{"cgi-safe", required_argument, 0, "skip security checks if the cgi file is under the specified path", uwsgi_opt_add_string_list, &uc.cgi_safe, 0},
+ {"cgi-dontresolve", no_argument, 0 , "call symbolic link directly instead of the real path", uwsgi_opt_true,&uc.dontresolve, 0},
+
{0, 0, 0, 0, 0, 0, 0},
};
@@ -475,6 +478,7 @@ static int uwsgi_cgi_request(struct wsgi_request *wsgi_req) {
char full_path[PATH_MAX];
char tmp_path[PATH_MAX];
+ char symbolic_path[PATH_MAX];
struct stat cgi_stat;
int need_free = 0;
int is_a_file = 0;
@@ -533,6 +537,10 @@ static int uwsgi_cgi_request(struct wsgi_request *wsgi_req) {
uwsgi_404(wsgi_req);
return UWSGI_OK;
}
+ if (uc.dontresolve) {
+ full_path_len = strlen(full_path);
+ memcpy(symbolic_path, full_path, full_path_len+1);
+ }
full_path_len = strlen(tmp_path);
// add +1 to copy the null byte
@@ -639,6 +647,11 @@ static int uwsgi_cgi_request(struct wsgi_request *wsgi_req) {
}
}
+ if (uc.dontresolve) {
+ full_path_len = strlen(symbolic_path);
+ memcpy(full_path, symbolic_path, full_path_len+1);
+ }
+
int ret = uwsgi_cgi_run(wsgi_req, docroot, docroot_len, full_path, helper, path_info, script_name, is_a_file, discard_base);
if (need_free) free(docroot);
return ret;

Loading…
Cancel
Save