Browse Source
pdns: fix compilation without deprecated OpenSSL APIs
The bn.h header is missing.
Signed-off-by: Rosen Penev <rosenp@gmail.com>
lilik-openwrt-22.03
Rosen Penev
5 years ago
No known key found for this signature in database
GPG Key ID: 36D31CFA845F0E3B
2 changed files with
21 additions and
1 deletions
-
net/pdns/Makefile
-
net/pdns/patches/200-openssl-deprecated.patch
|
@ -2,7 +2,7 @@ include $(TOPDIR)/rules.mk |
|
|
|
|
|
|
|
|
PKG_NAME:=pdns |
|
|
PKG_NAME:=pdns |
|
|
PKG_VERSION:=4.2.1 |
|
|
PKG_VERSION:=4.2.1 |
|
|
PKG_RELEASE:=1 |
|
|
|
|
|
|
|
|
PKG_RELEASE:=2 |
|
|
|
|
|
|
|
|
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2 |
|
|
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2 |
|
|
PKG_SOURCE_URL:=https://downloads.powerdns.com/releases/ |
|
|
PKG_SOURCE_URL:=https://downloads.powerdns.com/releases/ |
|
|
|
@ -0,0 +1,20 @@ |
|
|
|
|
|
--- a/pdns/opensslsigners.cc
|
|
|
|
|
|
+++ b/pdns/opensslsigners.cc
|
|
|
|
|
|
@@ -29,6 +29,7 @@
|
|
|
|
|
|
#if defined(HAVE_LIBCRYPTO_ED25519) || defined(HAVE_LIBCRYPTO_ED448) |
|
|
|
|
|
#include <openssl/evp.h> |
|
|
|
|
|
#endif |
|
|
|
|
|
+#include <openssl/bn.h>
|
|
|
|
|
|
#include <openssl/sha.h> |
|
|
|
|
|
#include <openssl/rand.h> |
|
|
|
|
|
#include <openssl/rsa.h> |
|
|
|
|
|
--- a/pdns/pkcs11signers.cc
|
|
|
|
|
|
+++ b/pdns/pkcs11signers.cc
|
|
|
|
|
|
@@ -15,6 +15,7 @@
|
|
|
|
|
|
#include "pdns/lock.hh" |
|
|
|
|
|
|
|
|
|
|
|
#ifdef HAVE_LIBCRYPTO_ECDSA |
|
|
|
|
|
+#include <openssl/bn.h>
|
|
|
|
|
|
#include <openssl/ec.h> |
|
|
|
|
|
#endif |
|
|
|
|
|
|