diff --git a/net/travelmate/Makefile b/net/travelmate/Makefile index fd7d2b85c..0fb886564 100644 --- a/net/travelmate/Makefile +++ b/net/travelmate/Makefile @@ -6,7 +6,7 @@ include $(TOPDIR)/rules.mk PKG_NAME:=travelmate -PKG_VERSION:=0.7.4 +PKG_VERSION:=0.7.5 PKG_RELEASE:=1 PKG_LICENSE:=GPL-3.0+ PKG_MAINTAINER:=Dirk Brenken diff --git a/net/travelmate/files/README.md b/net/travelmate/files/README.md index 3d3f82101..0e30dd3d9 100644 --- a/net/travelmate/files/README.md +++ b/net/travelmate/files/README.md @@ -24,8 +24,9 @@ To avoid these kind of deadlocks, travelmate set all station interfaces in an "a * download the package [here](https://downloads.lede-project.org/snapshots/packages/x86_64/packages) * install 'travelmate' (_opkg install travelmate_) * configure your network: - * automatic: use the LuCI frontend with automatic interface setup, that's the recommended way + * automatic: use the LuCI frontend with automatic STA interface setup, that's the recommended way * manual: see detailed configure steps below + * at least you need one AP and one STA interface configured ## LuCI travelmate companion package * download the package [here](https://downloads.lede-project.org/snapshots/packages/x86_64/luci) @@ -59,7 +60,7 @@ root@adb2go:~# /etc/init.d/travelmate status system : LEDE Reboot SNAPSHOT r4051-3ddc1914ba -## Setup +## Manual Setup **1. configure the travelmate wwan interface in /etc/config/network:**

 [...]
@@ -77,7 +78,7 @@ config zone
 [...]
 
-**3. add required ap and wwan stations to your wireless configuration in etc/config/wireless:** +**3. at least add one ap and (multiple) wwan stations to your wireless configuration in etc/config/wireless:**

 [...]
 config wifi-iface
diff --git a/net/travelmate/files/travelmate.sh b/net/travelmate/files/travelmate.sh
index 01da61703..5ae1a93ab 100755
--- a/net/travelmate/files/travelmate.sh
+++ b/net/travelmate/files/travelmate.sh
@@ -10,7 +10,7 @@
 #
 LC_ALL=C
 PATH="/usr/sbin:/usr/bin:/sbin:/bin"
-trm_ver="0.7.4"
+trm_ver="0.7.5"
 trm_sysver="$(ubus -S call system board | jsonfilter -e '@.release.description')"
 trm_enabled=0
 trm_debug=0
@@ -257,6 +257,7 @@ f_main()
         done
         if [ ! -s "${trm_rtfile}" ]
         then
+            trm_ifstatus="false"
             f_jsnupdate "n/a" "n/a" "n/a"
         fi
     else