Browse Source

glibs: revert "fix compilation with Alpine Linux"

This reverts commit 0ce744202a.

Broken everywhere else. A better solution will need to be found.

Signed-off-by: Rosen Penev <rosenp@gmail.com>
(cherry picked from commit 2784618ab5)
lilik-openwrt-22.03
Rosen Penev 2 years ago
parent
commit
584e13fae3
2 changed files with 1 additions and 22 deletions
  1. +1
    -2
      libs/glib2/Makefile
  2. +0
    -20
      libs/glib2/patches-host/001-musl-libintl.patch

+ 1
- 2
libs/glib2/Makefile View File

@ -27,8 +27,6 @@ HOST_BUILD_DEPENDS:=libiconv/host libffi/host pcre/host
PKG_CONFIG_DEPENDS:=CONFIG_BUILD_NLS
PKG_INSTALL:=1
HOST_PATCH_DIR:=./patches-host
include $(INCLUDE_DIR)/host-build.mk
include $(INCLUDE_DIR)/package.mk
include $(INCLUDE_DIR)/nls.mk
@ -46,6 +44,7 @@ define Package/glib2/description
The GLib library of C routines
endef
HOST_LDFLAGS += -Wl,-rpath,$(STAGING_DIR_HOSTPKG)/lib
TARGET_CFLAGS += -ffunction-sections -fdata-sections
TARGET_LDFLAGS += -Wl,--gc-sections $(if $(INTL_FULL),-lintl)


+ 0
- 20
libs/glib2/patches-host/001-musl-libintl.patch View File

@ -1,20 +0,0 @@
--- a/meson.build
+++ b/meson.build
@@ -2047,9 +2047,6 @@ endif
# FIXME: glib-gettext.m4 has much more checks to detect broken/uncompatible
# implementations. This could be extended if issues are found in some platforms.
libintl_deps = []
-if cc.has_function('ngettext', args : osx_ldflags)
- have_bind_textdomain_codeset = cc.has_function('bind_textdomain_codeset')
-else
# First just find the bare library.
libintl = cc.find_library('intl', required : false)
# The bare library probably won't link without help if it's static.
@@ -2081,7 +2078,6 @@ else
have_bind_textdomain_codeset = cc.has_function('bind_textdomain_codeset', args : osx_ldflags,
dependencies : libintl_deps)
endif
-endif
glib_conf.set('HAVE_BIND_TEXTDOMAIN_CODESET', have_bind_textdomain_codeset)

Loading…
Cancel
Save