Browse Source

ipsec-tools: compile with openssl 1.1, compile fix (#6141)

Added compatibility with openssl 1.1, and also fixed a compiler
warning about implicit declaration.

Signed-off-by: Eneas U de Queiroz <cote2004-github@yahoo.com>
lilik-openwrt-22.03
Eneas Queiroz 6 years ago
committed by Noah Meyerhans
parent
commit
57c8664b31
3 changed files with 1108 additions and 1 deletions
  1. +1
    -1
      net/ipsec-tools/Makefile
  2. +11
    -0
      net/ipsec-tools/patches/012-fix-implicit-int.patch
  3. +1096
    -0
      net/ipsec-tools/patches/015-openssl-1.1.patch

+ 1
- 1
net/ipsec-tools/Makefile View File

@ -11,7 +11,7 @@ include $(INCLUDE_DIR)/kernel.mk
PKG_NAME:=ipsec-tools
PKG_VERSION:=0.8.2
PKG_RELEASE:=7
PKG_RELEASE:=8
PKG_MAINTAINER:=Noah Meyerhans <frodo@morgul.net>, \
Vitaly Protsko <villy@sft.ru>
PKG_LICENSE := BSD-3-Clause


+ 11
- 0
net/ipsec-tools/patches/012-fix-implicit-int.patch View File

@ -0,0 +1,11 @@
--- a/src/racoon/isakmp_xauth.c
+++ b/src/racoon/isakmp_xauth.c
@@ -376,6 +376,7 @@ xauth_reply(iph1, port, id, res)
struct ph1handle *iph1;
int port;
int id;
+ int res;
{
struct xauth_state *xst = &iph1->mode_cfg->xauth;
char *usr = xst->authdata.generic.usr;

+ 1096
- 0
net/ipsec-tools/patches/015-openssl-1.1.patch
File diff suppressed because it is too large
View File


Loading…
Cancel
Save