Browse Source

libxml2: upgrade to 2.9.3

Beside some improvements, this also fixes several CVEs, for full
list see upstream changelog at:
https://mail.gnome.org/archives/xml/2015-November/msg00012.html

The patch needed for musl was accepted upstream, so we can remove it.

Signed-off-by: Michael Heimpold <mhei@heimpold.de>
lilik-openwrt-22.03
Michael Heimpold 9 years ago
parent
commit
55421fe27b
2 changed files with 4 additions and 46 deletions
  1. +4
    -4
      libs/libxml2/Makefile
  2. +0
    -42
      libs/libxml2/patches/0001-threads-use-forward-declarations-only-for-glibc-fixe.patch

+ 4
- 4
libs/libxml2/Makefile View File

@ -1,5 +1,5 @@
#
# Copyright (C) 2006-2014 OpenWrt.org
# Copyright (C) 2006-2015 OpenWrt.org
#
# This is free software, licensed under the GNU General Public License v2.
# See /LICENSE for more information.
@ -8,14 +8,14 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=libxml2
PKG_VERSION:=2.9.2
PKG_RELEASE:=3
PKG_VERSION:=2.9.3
PKG_RELEASE:=1
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
PKG_SOURCE_URL:=http://gd.tuwien.ac.at/languages/libxml/ \
http://xmlsoft.org/sources/ \
ftp://fr.rpmfind.net/pub/libxml/
PKG_MD5SUM:=9e6a9aca9d155737868b3dc5fd82f788
PKG_MD5SUM:=daece17e045f1c107610e137ab50c179
PKG_LICENSE:=MIT
PKG_LICENSE_FILES:=COPYING


+ 0
- 42
libs/libxml2/patches/0001-threads-use-forward-declarations-only-for-glibc-fixe.patch View File

@ -1,42 +0,0 @@
From e3e04d254fb6bac49a285775b729e28b0500476c Mon Sep 17 00:00:00 2001
From: Michael Heimpold <mhei@heimpold.de>
Date: Sun, 21 Dec 2014 01:03:49 +0100
Subject: [PATCH] threads: use forward declarations only for glibc (fixes
#704908)
The declarations of pthread functions, used to generate weak references
to them, fail to suppress macros. Thus, if any pthread function has
been provided as a macro, compiling threads.c will fail.
This breaks on musl libc, which defines pthread_equal as a macro (in
addition to providing the function, as required).
Prevent the declarations for e.g. musl libc by refining the condition.
The idea for this solution was borrowed from the alpine linux guys, see
http://git.alpinelinux.org/cgit/aports/tree/main/libxml2/libxml2-pthread.patch
Signed-off-by: Michael Heimpold <mhei@heimpold.de>
---
threads.c | 4 ++--
1 file changed, 2 insertions(+), 2 deletions(-)
--- a/threads.c
+++ b/threads.c
@@ -47,7 +47,7 @@
#ifdef HAVE_PTHREAD_H
static int libxml_is_threaded = -1;
-#ifdef __GNUC__
+#if defined(__GNUC__) && defined(__GLIBC__)
#ifdef linux
#if (__GNUC__ == 3 && __GNUC_MINOR__ >= 3) || (__GNUC__ > 3)
extern int pthread_once (pthread_once_t *__once_control,
@@ -89,7 +89,7 @@ extern int pthread_cond_signal ()
__attribute((weak));
#endif
#endif /* linux */
-#endif /* __GNUC__ */
+#endif /* defined(__GNUC__) && defined(__GLIBC__) */
#endif /* HAVE_PTHREAD_H */
/*

Loading…
Cancel
Save