Browse Source

flashrom: update to v0.9.9.1

Signed-off-by: Álvaro Fernández Rojas <noltari@gmail.com>
lilik-openwrt-22.03
Álvaro Fernández Rojas 7 years ago
parent
commit
54bb27c183
3 changed files with 8 additions and 10 deletions
  1. +4
    -4
      utils/flashrom/Makefile
  2. +1
    -1
      utils/flashrom/patches/0001-fix_internal_bitbang.patch
  3. +3
    -5
      utils/flashrom/patches/0002-fix-io-h-include.patch

+ 4
- 4
utils/flashrom/Makefile View File

@ -1,5 +1,5 @@
#
# Copyright (C) 2010-2016 OpenWrt.org
# Copyright (C) 2010-2017 OpenWrt.org
#
# This is free software, licensed under the GNU General Public License v2.
# See /LICENSE for more information.
@ -8,13 +8,13 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=flashrom
PKG_VERSION:=0.9.9
PKG_RELEASE:=2
PKG_VERSION:=0.9.9.1
PKG_RELEASE:=1
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
PKG_SOURCE_URL:=http://download.flashrom.org/releases
PKG_SOURCE_SUBDIR:=$(PKG_NAME)-$(PKG_VERSION)
PKG_HASH:=cb3156b0f63eb192024b76c0814135930297aac41f80761a5d293de769783c45
PKG_HASH:=0e145a5b9b18c98752acf0f8329a9a260ddf030abf687416daab9f05a0f508d0
PKG_MAINTAINER:=Álvaro Fernández Rojas <noltari@gmail.com>
PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(BUILD_VARIANT)/$(PKG_SOURCE_SUBDIR)


+ 1
- 1
utils/flashrom/patches/0001-fix_internal_bitbang.patch View File

@ -1,6 +1,6 @@
--- a/programmer.h
+++ b/programmer.h
@@ -557,7 +557,7 @@ enum spi_controller {
@@ -584,7 +584,7 @@ enum spi_controller {
#if CONFIG_DEDIPROG == 1
SPI_CONTROLLER_DEDIPROG,
#endif


+ 3
- 5
utils/flashrom/patches/0002-fix-io-h-include.patch View File

@ -1,12 +1,10 @@
diff -uprN a/linux_spi.c b/linux_spi.c
--- a/flash.h 2015-02-08 16:57:52.000000000 -0500
+++ b/flash.h 2016-01-08 20:09:51.599387507 -0500
--- a/flash.h
+++ b/flash.h
@@ -30,6 +30,7 @@
#include <stdio.h>
#include <stdint.h>
#include <stddef.h>
+#include <sys/io.h>
#include <stdarg.h>
#include <stdbool.h>
#if IS_WINDOWS
#include <windows.h>

Loading…
Cancel
Save