Browse Source

Merge pull request #112 from ukleinek/master

Move iodine to new packages.git, upgrade version to fix authorization bypass, grab maintainership
lilik-openwrt-22.03
sbyx 10 years ago
parent
commit
5493837cac
4 changed files with 125 additions and 0 deletions
  1. +73
    -0
      net/iodine/Makefile
  2. +5
    -0
      net/iodine/files/iodined.config
  3. +23
    -0
      net/iodine/files/iodined.init
  4. +24
    -0
      net/iodine/patches/010-cross-compile.patch

+ 73
- 0
net/iodine/Makefile View File

@ -0,0 +1,73 @@
#
# Copyright (C) 2006-2011 OpenWrt.org
#
# This is free software, licensed under the GNU General Public License v2.
# See /LICENSE for more information.
#
include $(TOPDIR)/rules.mk
PKG_NAME:=iodine
PKG_VERSION:=0.7.0
PKG_RELEASE:=1
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
PKG_SOURCE_URL:=http://code.kryo.se/iodine/
PKG_MD5SUM:=fdbf3b81cd69caf5230d76a8b039fd99
PKG_MAINTAINER:=Uwe Kleine-König <uwe+openwrt@kleine-koenig.org>
PKG_LICENSE:=ISC
PKG_LICENSE_FILES:=README
include $(INCLUDE_DIR)/package.mk
define Package/iodine/Default
SECTION:=net
CATEGORY:=Network
SUBMENU:=Firewall Tunnel
DEPENDS:= +kmod-tun +zlib
TITLE:=IP over DNS tunneling
URL:=http://code.kryo.se/iodine/
endef
define Package/iodine
$(call Package/iodine/Default)
TITLE+= client version
endef
define Package/iodine/description
iodine client version
endef
define Package/iodined
$(call Package/iodine/Default)
TITLE+= server version
endef
define Package/iodined/description
iodine server version
endef
define Build/Configure
endef
define Package/iodine/install
$(INSTALL_DIR) $(1)/usr/sbin
$(INSTALL_BIN) $(PKG_BUILD_DIR)/bin/iodine $(1)/usr/sbin
endef
define Package/iodined/install
$(INSTALL_DIR) $(1)/etc/init.d
$(INSTALL_BIN) ./files/iodined.init $(1)/etc/init.d/iodined
$(INSTALL_DIR) $(1)/etc/config
$(INSTALL_DATA) ./files/iodined.config $(1)/etc/config/iodined
$(INSTALL_DIR) $(1)/usr/sbin
$(INSTALL_BIN) $(PKG_BUILD_DIR)/bin/iodined $(1)/usr/sbin
endef
define Package/iodined/conffiles
/etc/config/iodined
endef
$(eval $(call BuildPackage,iodine))
$(eval $(call BuildPackage,iodined))

+ 5
- 0
net/iodine/files/iodined.config View File

@ -0,0 +1,5 @@
config iodined
option address ''
option password ''
option tunnelip '10.0.0.1'
option tld ''

+ 23
- 0
net/iodine/files/iodined.init View File

@ -0,0 +1,23 @@
#!/bin/sh /etc/rc.common
# Copyright (C) 2006-2011 OpenWrt.org
START=50
start_instance () {
local section="$1"
config_get address "$section" 'address'
config_get password "$section" 'password'
config_get tunnelip "$section" 'tunnelip'
config_get tld "$section" 'tld'
service_start /usr/sbin/iodined -l "$address" -P "$password" "$tunnelip" "$tld"
}
start() {
config_load 'iodined'
config_foreach start_instance 'iodined'
}
stop() {
service_stop /usr/sbin/iodined
}

+ 24
- 0
net/iodine/patches/010-cross-compile.patch View File

@ -0,0 +1,24 @@
--- iodine-0.7.0.orig/src/osflags
+++ iodine-0.7.0/src/osflags
@@ -16,12 +16,6 @@ link)
windows32)
echo '-lws2_32 -liphlpapi';
;;
- Linux)
- FLAGS="";
- [ -e /usr/include/selinux/selinux.h ] && FLAGS="$FLAGS -lselinux";
- [ -e /usr/include/systemd/sd-daemon.h ] && FLAGS="$FLAGS -lsystemd-daemon";
- echo $FLAGS;
- ;;
esac
;;
cflags)
@@ -34,8 +28,6 @@ cflags)
;;
Linux)
FLAGS="-D_GNU_SOURCE"
- [ -e /usr/include/selinux/selinux.h ] && FLAGS="$FLAGS -DHAVE_SETCON";
- [ -e /usr/include/systemd/sd-daemon.h ] && FLAGS="$FLAGS -DHAVE_SYSTEMD";
echo $FLAGS;
;;
esac

Loading…
Cancel
Save