Browse Source

softethervpn: update to 4.38-9760-rtm

Signed-off-by: Rosen Penev <rosenp@gmail.com>
lilik-openwrt-22.03
Rosen Penev 3 years ago
parent
commit
53b5695ea8
3 changed files with 10 additions and 11 deletions
  1. +3
    -4
      net/softethervpn/Makefile
  2. +6
    -6
      net/softethervpn/patches/120-openssl-deprecated.patch
  3. +1
    -1
      net/softethervpn/patches/130-iconv.patch

+ 3
- 4
net/softethervpn/Makefile View File

@ -9,14 +9,13 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=softethervpn
PKG_VERSION:=4.34-9745
PKG_VERSION:=4.38-9760
PKG_VERREL:=rtm
PKG_VERDATE:=2020.04.05
PKG_RELEASE:=1
PKG_SOURCE:=softether-src-v$(PKG_VERSION)-$(PKG_VERREL).tar.gz
PKG_SOURCE_URL:=http://www.softether-download.com/files/softether/v$(PKG_VERSION)-$(PKG_VERREL)-$(PKG_VERDATE)-tree/Source_Code/
PKG_HASH:=bf5547e2a190e8620fe02da9756b32d010e3b64cbc6317f172f7820394b4c036
PKG_SOURCE_URL:=https://github.com/SoftEtherVPN/SoftEtherVPN_Stable/releases/download/v$(PKG_VERSION)-$(PKG_VERREL)
PKG_HASH:=e68128b46171bd9f3f9ca38d10e60e8590a833bfc6488fa014674f9a22541f35
PKG_MAINTAINER:=Federico Di Marco <fededim@gmail.com>
PKG_LICENSE:=GPL-2.0-or-later


+ 6
- 6
net/softethervpn/patches/120-openssl-deprecated.patch View File

@ -99,7 +99,7 @@
if (!UINT64ToAsn1Time(t1, notBefore))
{
FreeX509(x509);
@@ -2697,6 +2707,43 @@ bool RsaCheckEx()
@@ -2698,6 +2708,43 @@ bool RsaCheckEx()
return false;
}
@ -143,7 +143,7 @@
bool RsaCheck()
{
RSA *rsa;
@@ -2710,12 +2757,11 @@ bool RsaCheck()
@@ -2711,12 +2758,11 @@ bool RsaCheck()
// Key generation
Lock(openssl_lock);
{
@ -157,7 +157,7 @@
return false;
}
@@ -2780,12 +2826,11 @@ bool RsaGen(K **priv, K **pub, UINT bit)
@@ -2781,12 +2827,11 @@ bool RsaGen(K **priv, K **pub, UINT bit)
// Key generation
Lock(openssl_lock);
{
@ -171,7 +171,7 @@
return false;
}
@@ -3895,7 +3940,7 @@ X *X509ToX(X509 *x509)
@@ -3896,7 +3941,7 @@ X *X509ToX(X509 *x509)
{
if (OBJ_obj2nid(ad->method) == NID_ad_ca_issuers && ad->location->type == GEN_URI)
{
@ -180,7 +180,7 @@
if (IsEmptyStr(uri) == false)
{
@@ -4108,7 +4153,9 @@ void Rand(void *buf, UINT size)
@@ -4109,7 +4154,9 @@ void Rand(void *buf, UINT size)
// Delete a thread-specific information that OpenSSL has holded
void FreeOpenSSLThreadState()
{
@ -190,7 +190,7 @@
}
// Release the Crypt library
@@ -4130,12 +4177,14 @@ void InitCryptLibrary()
@@ -4131,12 +4178,14 @@ void InitCryptLibrary()
CheckIfIntelAesNiSupportedInit();
// RAND_Init_For_SoftEther()
openssl_lock = NewLock();


+ 1
- 1
net/softethervpn/patches/130-iconv.patch View File

@ -1,6 +1,6 @@
--- a/src/Mayaqua/Mayaqua.h
+++ b/src/Mayaqua/Mayaqua.h
@@ -283,7 +283,7 @@ int PASCAL WinMain(HINSTANCE hInst, HINS
@@ -284,7 +284,7 @@ int PASCAL WinMain(HINSTANCE hInst, HINS
#include <ifaddrs.h>
#endif // MAYAQUA_SUPPORTS_GETIFADDRS


Loading…
Cancel
Save