Browse Source

Merge pull request #8900 from neheb/por

port-mirroring: Update to 1.4.4
lilik-openwrt-22.03
Rosen Penev 5 years ago
committed by GitHub
parent
commit
50fc3e27b3
No known key found for this signature in database GPG Key ID: 4AEE18F83AFDEB23
2 changed files with 21 additions and 1 deletions
  1. +1
    -1
      net/port-mirroring/Makefile
  2. +20
    -0
      net/port-mirroring/patches/010-snprintf-to-strncpy.patch

+ 1
- 1
net/port-mirroring/Makefile View File

@ -8,7 +8,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=port-mirroring
PKG_VERSION:=1.4.4
PKG_RELEASE:=1
PKG_RELEASE:=2
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
PKG_SOURCE_URL:=https://codeload.github.com/mmaraya/port-mirroring/tar.gz/v$(PKG_VERSION)?


+ 20
- 0
net/port-mirroring/patches/010-snprintf-to-strncpy.patch View File

@ -0,0 +1,20 @@
--- a/src/main.c
+++ b/src/main.c
@@ -90,7 +90,7 @@ int loadCfg(const char *fpath)
}
else
{
- snprintf(cfg.dst_if, IFNAMSIZ, "%s", value);
+ strncpy(cfg.dst_if, value, IFNAMSIZ);
cfg.flags |= PM_DST_IF;
}
}
@@ -104,7 +104,7 @@ int loadCfg(const char *fpath)
}
else if (strcmp(option, "filter") == 0)
{
- snprintf(cfg.pfe, PFE_MAX, "%s", value);
+ strncpy(cfg.pfe, value, PFE_MAX);
}
else if (strcmp(option, "promiscuous") == 0)
{

Loading…
Cancel
Save