Browse Source

dmx_usb_module: fix build against kernel 4.14

The change should also work fine with older kernels, as <linux/uaccess.h>
has existed for a long time, and it includes <asm/uaccess.h>.

Signed-off-by: Matthias Schiffer <mschiffer@universe-factory.net>
lilik-openwrt-22.03
Matthias Schiffer 7 years ago
parent
commit
50cd1f13a1
No known key found for this signature in database GPG Key ID: 16EF3F64CB201D9C
2 changed files with 12 additions and 1 deletions
  1. +1
    -1
      libs/dmx_usb_module/Makefile
  2. +11
    -0
      libs/dmx_usb_module/patches/002-fix-build-4.14.patch

+ 1
- 1
libs/dmx_usb_module/Makefile View File

@ -10,7 +10,7 @@ include $(INCLUDE_DIR)/kernel.mk
PKG_NAME:=dmx_usb_module PKG_NAME:=dmx_usb_module
PKG_VERSION:=0.1.20130818 PKG_VERSION:=0.1.20130818
PKG_RELEASE:=0.1
PKG_RELEASE:=2
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
PKG_SOURCE_SUBDIR:=$(PKG_NAME)-$(PKG_VERSION) PKG_SOURCE_SUBDIR:=$(PKG_NAME)-$(PKG_VERSION)


+ 11
- 0
libs/dmx_usb_module/patches/002-fix-build-4.14.patch View File

@ -0,0 +1,11 @@
--- a/dmx_usb.c
+++ b/dmx_usb.c
@@ -20,7 +20,7 @@
#include <linux/module.h>
#include <linux/spinlock.h>
#include <linux/completion.h>
-#include <asm/uaccess.h>
+#include <linux/uaccess.h>
#include <linux/usb.h>
#include <linux/version.h>

Loading…
Cancel
Save