|
@ -1,8 +1,8 @@ |
|
|
diff --git a/setup.py b/setup.py
|
|
|
diff --git a/setup.py b/setup.py
|
|
|
index d10f17d..d347d64 100755
|
|
|
|
|
|
|
|
|
index e21ef70..a4d9ee8 100755
|
|
|
--- a/setup.py
|
|
|
--- a/setup.py
|
|
|
+++ b/setup.py
|
|
|
+++ b/setup.py
|
|
|
@@ -40,11 +40,12 @@ def main(args):
|
|
|
|
|
|
|
|
|
@@ -55,13 +55,14 @@ def main(args):
|
|
|
setup_args = STATIC_PACKAGE_METADATA.copy() |
|
|
setup_args = STATIC_PACKAGE_METADATA.copy() |
|
|
|
|
|
|
|
|
setup_args.update(dict( |
|
|
setup_args.update(dict( |
|
@ -10,28 +10,32 @@ index d10f17d..d347d64 100755 |
|
|
+ packages=setuptools.find_packages(exclude=["*.test", "*.test.*"]),
|
|
|
+ packages=setuptools.find_packages(exclude=["*.test", "*.test.*"]),
|
|
|
install_requires=requirements, |
|
|
install_requires=requirements, |
|
|
conditionalExtensions=getExtensions(), |
|
|
conditionalExtensions=getExtensions(), |
|
|
scripts=getScripts(), |
|
|
|
|
|
|
|
|
entry_points={ |
|
|
|
|
|
'console_scripts': getConsoleScripts() |
|
|
|
|
|
}, |
|
|
include_package_data=True, |
|
|
include_package_data=True, |
|
|
+ exclude_package_data={'':['test/*']},
|
|
|
+ exclude_package_data={'':['test/*']},
|
|
|
zip_safe=False, |
|
|
zip_safe=False, |
|
|
extras_require=_EXTRAS_REQUIRE, |
|
|
extras_require=_EXTRAS_REQUIRE, |
|
|
)) |
|
|
)) |
|
|
diff --git a/twisted/python/dist.py b/twisted/python/dist.py
|
|
|
diff --git a/twisted/python/dist.py b/twisted/python/dist.py
|
|
|
index aac2756..5633f09 100644
|
|
|
|
|
|
|
|
|
index dfff9dc..a05b716 100644
|
|
|
--- a/twisted/python/dist.py
|
|
|
--- a/twisted/python/dist.py
|
|
|
+++ b/twisted/python/dist.py
|
|
|
+++ b/twisted/python/dist.py
|
|
|
@@ -182,10 +182,10 @@ def getExtensions():
|
|
|
|
|
|
|
|
|
@@ -191,11 +191,11 @@ def getExtensions():
|
|
|
Get the C extensions used for Twisted. |
|
|
Get the C extensions used for Twisted. |
|
|
""" |
|
|
""" |
|
|
extensions = [ |
|
|
extensions = [ |
|
|
- ConditionalExtension(
|
|
|
- ConditionalExtension(
|
|
|
- "twisted.test.raiser",
|
|
|
- "twisted.test.raiser",
|
|
|
- ["twisted/test/raiser.c"],
|
|
|
- ["twisted/test/raiser.c"],
|
|
|
- condition=lambda _: _isCPython),
|
|
|
|
|
|
|
|
|
- condition=lambda _: _isCPython
|
|
|
|
|
|
- ),
|
|
|
+ #ConditionalExtension(
|
|
|
+ #ConditionalExtension(
|
|
|
+ # "twisted.test.raiser",
|
|
|
+ # "twisted.test.raiser",
|
|
|
+ # ["twisted/test/raiser.c"],
|
|
|
+ # ["twisted/test/raiser.c"],
|
|
|
+ # condition=lambda _: _isCPython),
|
|
|
|
|
|
|
|
|
|
|
|
|
|
|
+ # condition=lambda _: _isCPython
|
|
|
|
|
|
+ #),
|
|
|
ConditionalExtension( |
|
|
ConditionalExtension( |
|
|
"twisted.internet.iocpreactor.iocpsupport", |
|
|
"twisted.internet.iocpreactor.iocpsupport", |
|
|
|
|
|
["twisted/internet/iocpreactor/iocpsupport/iocpsupport.c", |