Browse Source

Netopeer2: Update to 0.7-r2

Small cleanups.

Removed upstreamed patch.

Suffixed all patches with .patch

Signed-off-by: Rosen Penev <rosenp@gmail.com>
lilik-openwrt-22.03
Rosen Penev 5 years ago
parent
commit
4e23b0fcf6
4 changed files with 19 additions and 44 deletions
  1. +4
    -6
      net/Netopeer2/Makefile
  2. +12
    -19
      net/Netopeer2/patches/001-fix-for-cmake-build.patch
  3. +3
    -5
      net/Netopeer2/patches/002-fix-keystored-cross-compile.patch
  4. +0
    -14
      net/Netopeer2/patches/010-openssl-deprecated.patch

+ 4
- 6
net/Netopeer2/Makefile View File

@ -10,19 +10,19 @@
include $(TOPDIR)/rules.mk include $(TOPDIR)/rules.mk
PKG_NAME:=Netopeer2 PKG_NAME:=Netopeer2
PKG_VERSION:=0.7-r1
PKG_RELEASE:=3
PKG_VERSION:=0.7-r2
PKG_RELEASE:=1
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
PKG_SOURCE_URL:=https://codeload.github.com/CESNET/Netopeer2/tar.gz/v$(PKG_VERSION)? PKG_SOURCE_URL:=https://codeload.github.com/CESNET/Netopeer2/tar.gz/v$(PKG_VERSION)?
PKG_HASH:=040013d1e315c62c496b704475665165578c374ffb387cbbff422cf8898d3a12
PKG_HASH:=59688271be4fecbbee671fc7eb3dc0538b13b4baab53e923e26eaeb33e6f7ec0
PKG_MAINTAINER:=Mislav Novakovic <mislav.novakovic@sartura.hr> PKG_MAINTAINER:=Mislav Novakovic <mislav.novakovic@sartura.hr>
PKG_LICENSE:=BSD-3-Clause PKG_LICENSE:=BSD-3-Clause
PKG_LICENSE_FILES:=LICENSE PKG_LICENSE_FILES:=LICENSE
PKG_BUILD_PARALLEL:=1
CMAKE_INSTALL:=1 CMAKE_INSTALL:=1
PKG_BUILD_PARALLEL:=1
include $(INCLUDE_DIR)/package.mk include $(INCLUDE_DIR)/package.mk
include $(INCLUDE_DIR)/cmake.mk include $(INCLUDE_DIR)/cmake.mk
@ -65,8 +65,6 @@ define Package/netopeer2/description
endef endef
CMAKE_OPTIONS += \ CMAKE_OPTIONS += \
-DCMAKE_INSTALL_PREFIX:PATH=/usr \
-DCMAKE_BUILD_TYPE:STRING=Release \
-DKEYSTORED_KEYS_DIR:STRING=/etc/keystored/keys \ -DKEYSTORED_KEYS_DIR:STRING=/etc/keystored/keys \
-DENABLE_CONFIGURATION:BOOL=OFF \ -DENABLE_CONFIGURATION:BOOL=OFF \
-DMODEL_INSTALL:BOOL=OFF \ -DMODEL_INSTALL:BOOL=OFF \


net/Netopeer2/patches/001-fix-for-cmake-build → net/Netopeer2/patches/001-fix-for-cmake-build.patch View File


net/Netopeer2/patches/002-fix-keystored-cross-compile → net/Netopeer2/patches/002-fix-keystored-cross-compile.patch View File


+ 0
- 14
net/Netopeer2/patches/010-openssl-deprecated.patch View File

@ -1,14 +0,0 @@
--- a/cli/commands.c
+++ b/cli/commands.c
@@ -1659,7 +1659,11 @@ parse_cert(const char *name, const char *path)
BIO_printf(bio_out, "\n");
BIO_printf(bio_out, "Valid until: ");
+#if OPENSSL_VERSION_NUMBER < 0x10100000L // < 1.1.0
ASN1_TIME_print(bio_out, X509_get_notAfter(cert));
+#else
+ ASN1_TIME_print(bio_out, X509_get0_notAfter(cert));
+#endif
BIO_printf(bio_out, "\n");
has_san = 0;

Loading…
Cancel
Save