Browse Source

acme: Update to v1.4.

This updates to the latest git version of acme.sh and drops the patch to
disable timestamps from the output (since that is now supported
upstream).

Signed-off-by: Toke Høiland-Jørgensen <toke@toke.dk>
lilik-openwrt-22.03
Toke Høiland-Jørgensen 8 years ago
parent
commit
4cebee84ca
3 changed files with 3 additions and 16 deletions
  1. +2
    -2
      net/acme/Makefile
  2. +1
    -0
      net/acme/files/run.sh
  3. +0
    -14
      net/acme/patches/0001-remove-timestamp.patch

+ 2
- 2
net/acme/Makefile View File

@ -8,8 +8,8 @@
include $(TOPDIR)/rules.mk include $(TOPDIR)/rules.mk
PKG_NAME:=acme PKG_NAME:=acme
PKG_SOURCE_VERSION:=3c33cdfa3da68000a40b85304821705f0deea951
PKG_VERSION:=1.3
PKG_SOURCE_VERSION:=6d84da588b98733dd9c4f5b88440281ab1eb4989
PKG_VERSION:=1.4
PKG_RELEASE:=1 PKG_RELEASE:=1
PKG_LICENSE:=GPLv3 PKG_LICENSE:=GPLv3


+ 1
- 0
net/acme/files/run.sh View File

@ -11,6 +11,7 @@
CHECK_CRON=$1 CHECK_CRON=$1
ACME=/usr/lib/acme/acme.sh ACME=/usr/lib/acme/acme.sh
export SSL_CERT_DIR=/etc/ssl/certs export SSL_CERT_DIR=/etc/ssl/certs
export NO_TIMESTAMP=1
UHTTPD_LISTEN_HTTP= UHTTPD_LISTEN_HTTP=
STATE_DIR='/etc/acme' STATE_DIR='/etc/acme'


+ 0
- 14
net/acme/patches/0001-remove-timestamp.patch View File

@ -1,14 +0,0 @@
--- a/acme.sh
+++ b/acme.sh
@@ -84,9 +84,9 @@ __red() {
_printargs() {
if [ -z "$2" ] ; then
- printf -- "[$(date)] $1"
+ printf -- " $1"
else
- printf -- "[$(date)] $1='$2'"
+ printf -- " $1='$2'"
fi
printf "\n"
}

Loading…
Cancel
Save