Browse Source
Merge pull request #13078 from neheb/pls
pulseaudio: fix compilation without deprecated OpenSSL APIs
lilik-openwrt-22.03
Rosen Penev
4 years ago
committed by
GitHub
No known key found for this signature in database
GPG Key ID: 4AEE18F83AFDEB23
2 changed files with
11 additions and
1 deletions
-
sound/pulseaudio/Makefile
-
sound/pulseaudio/patches/020-openssl-deprecated.patch
|
@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk |
|
|
|
|
|
|
|
|
PKG_NAME:=pulseaudio |
|
|
PKG_NAME:=pulseaudio |
|
|
PKG_VERSION:=13.0 |
|
|
PKG_VERSION:=13.0 |
|
|
PKG_RELEASE:=5 |
|
|
|
|
|
|
|
|
PKG_RELEASE:=6 |
|
|
|
|
|
|
|
|
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz |
|
|
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz |
|
|
PKG_SOURCE_URL:=https://freedesktop.org/software/pulseaudio/releases |
|
|
PKG_SOURCE_URL:=https://freedesktop.org/software/pulseaudio/releases |
|
|
|
@ -0,0 +1,10 @@ |
|
|
|
|
|
--- a/src/modules/raop/raop-crypto.c
|
|
|
|
|
|
+++ b/src/modules/raop/raop-crypto.c
|
|
|
|
|
|
@@ -30,6 +30,7 @@
|
|
|
|
|
|
#include <openssl/err.h> |
|
|
|
|
|
#include <openssl/aes.h> |
|
|
|
|
|
#include <openssl/rsa.h> |
|
|
|
|
|
+#include <openssl/bn.h>
|
|
|
|
|
|
|
|
|
|
|
|
#include <pulse/xmalloc.h> |
|
|
|
|
|
|