Browse Source

Merge pull request #14036 from neheb/libroxml

libroxml: import from base
lilik-openwrt-22.03
Rosen Penev 4 years ago
committed by GitHub
parent
commit
4b4ac939cc
No known key found for this signature in database GPG Key ID: 4AEE18F83AFDEB23
2 changed files with 59 additions and 0 deletions
  1. +48
    -0
      libs/libroxml/Makefile
  2. +11
    -0
      libs/libroxml/patches/010-gcc10.patch

+ 48
- 0
libs/libroxml/Makefile View File

@ -0,0 +1,48 @@
#
# Copyright (C) 2014 OpenWrt.org
#
# This is free software, licensed under the GNU General Public License v2.
# See /LICENSE for more information.
#
include $(TOPDIR)/rules.mk
PKG_NAME:=libroxml
PKG_VERSION:=3.0.2
PKG_RELEASE:=2
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
PKG_SOURCE_URL:=http://download.libroxml.net/pool/v3.x
PKG_HASH:=ed6d68d1bceabf98e5e76907411e2e4d93b2dbd48479ab41dede851f59dad6a3
PKG_MAINTAINER:=Felix Fietkau <nbd@nbd.name>
PKG_LICENSE:=LGPL-2.1-or-later
PKG_LICENSE_FILES:=License.txt
CMAKE_INSTALL:=1
PKG_BUILD_PARALLEL:=1
include $(INCLUDE_DIR)/package.mk
include $(INCLUDE_DIR)/cmake.mk
define Package/libroxml
SECTION:=libs
CATEGORY:=Libraries
TITLE:=Minimum, easy-to-use, C implementation for xml file parsing
URL:=http://www.libroxml.net/
ABI_VERSION:=2
endef
CMAKE_OPTIONS += \
-DBUILD_TESTING=OFF \
-DCONFIG_XML_FILE=OFF \
-DCONFIG_XML_EDIT=OFF \
-DCONFIG_XML_COMMIT=OFF \
-DCONFIG_XML_XPATH=OFF
define Package/libroxml/install
$(INSTALL_DIR) $(1)/usr/lib
$(CP) $(PKG_INSTALL_DIR)/usr/lib/libroxml.so.* $(1)/usr/lib/
endef
$(eval $(call BuildPackage,libroxml))

+ 11
- 0
libs/libroxml/patches/010-gcc10.patch View File

@ -0,0 +1,11 @@
--- a/src/roxml_mem.h
+++ b/src/roxml_mem.h
@@ -14,7 +14,7 @@
#include "roxml_internal.h"
-memory_cell_t head_cell;
+extern memory_cell_t head_cell;
/** \brief alloc memory function
*

Loading…
Cancel
Save