isc-dhcp: update to 4.4.0lilik-openwrt-22.03
@ -1,30 +1,9 @@ | |||
diff --git a/bind/Makefile.in b/bind/Makefile.in | |||
index bd784c6..5950d19 100644 | |||
--- a/bind/Makefile.in | |||
+++ b/bind/Makefile.in | |||
@@ -85,13 +85,13 @@ bind2: | |||
echo Bind export libraries already installed ; \ | |||
else \ | |||
echo Building BIND Export libraries - this takes some time. ;\ | |||
- (cd ${bindsrcdir}/lib/export ; \ | |||
- echo building in `pwd` ; \ | |||
- MAKE=${GMAKE} ${GMAKE} >> ${binddir}/build.log) ; \ | |||
+ (cd ${bindsrcdir}/lib/export/dns ; \ | |||
+ echo building gen using ${BUILD_CC} in `pwd` ; \ | |||
+ $(MAKE) CC=${BUILD_CC} CFLAGS="-O2" LIBS="" gen) ; \ | |||
\ | |||
echo Installing BIND Export libraries to ${binddir}. ; \ | |||
(cd ${bindsrcdir}/lib/export ; \ | |||
- MAKE=${GMAKE} ${GMAKE} install > ${binddir}/install.log) ; \ | |||
+ $(MAKE) DESTDIR="" install > ${binddir}/build.log) ; \ | |||
fi | |||
clean: | |||
@@ -100,6 +100,7 @@ clean: | |||
@@ -116,5 +116,6 @@ uninstall-bind: all | |||
# Include the following so that this Makefile is happy when the parent | |||
# tries to use them. | |||
+install-exec: | |||
distdir: | |||
check distdir distclean dvi installcheck: |
@ -1,19 +1,16 @@ | |||
--- a/bind/Makefile.in | |||
+++ b/bind/Makefile.in | |||
@@ -63,8 +63,14 @@ | |||
else \ | |||
echo Configuring BIND Export libraries for DHCP. ; \ | |||
@@ -56,7 +56,12 @@ bind1: | |||
echo Configuring BIND libraries for DHCP. ; \ | |||
rm -rf ${cleandirs} ${cleanfiles} ; \ | |||
- (cd ${bindsrcdir} && \ | |||
(cd ${bindsrcdir} && \ | |||
- ./configure ${bindconfig} > ${binddir}/configure.log); \ | |||
+ (cd ${bindsrcdir} && export CC=${CROSS_CC} && \ | |||
+ ./configure --disable-atomic --disable-kqueue \ | |||
+ export CC=${CROSS_CC} && \ | |||
+ ./configure ${bindconfig} --disable-atomic \ | |||
+ --disable-kqueue --disable-epoll --disable-kqueue \ | |||
+ --disable-epoll --disable-devpoll --without-openssl \ | |||
+ --without-libxml2 --enable-exportlib \ | |||
+ --enable-threads=no \ | |||
+ --with-export-includedir=${binddir}/include \ | |||
+ --with-export-libdir=${binddir}/lib --with-gssapi=no \ | |||
+ --without-randomdev > ${binddir}/configure.log); \ | |||
+ --without-libxml2 --disable-threads --without-gssapi \ | |||
+ --without-randomdev > ${binddir}/configure.log); \ | |||
fi | |||
atf: |