Shorewall(6): add full packages.lilik-openwrt-22.03
@ -1,2 +1,2 @@ | |||
#!/bin/sh | |||
cat /proc/sys/kernel/hostname | |||
uci get system.@system[0].hostname |
@ -1,12 +1,13 @@ | |||
#!/bin/sh | |||
# should restart shorewall-lite when an interface comes up | |||
# should restart shorewall when an interface comes up | |||
[ ifup = "$ACTION" ] && { | |||
case "$ACTION" in | |||
ifup) | |||
/etc/init.d/shorewall-lite restart | |||
} | |||
[ ifdown = "$ACTION" ] && { | |||
;; | |||
ifdown) | |||
# might need to restore some routing | |||
/etc/init.d/shorewall-lite restart | |||
} | |||
;; | |||
esac |
@ -0,0 +1,32 @@ | |||
#!/bin/sh /etc/rc.common | |||
USE_PROCD=1 | |||
START=50 | |||
load_params () { | |||
. /usr/share/shorewall/shorewallrc | |||
} | |||
start_service() { | |||
load_params | |||
${SBINDIR}/shorewall -l $OPTIONS start $STARTOPTIONS | |||
} | |||
stop_service() { | |||
load_params | |||
${SBINDIR}/shorewall -l $OPTIONS stop $STOPOPTIONS | |||
} | |||
restart_service() { | |||
load_params | |||
${SBINDIR}/shorewall -l $OPTIONS restart $RESTARTOPTIONS | |||
} | |||
reload_service() { | |||
load_params | |||
${SBINDIR}/shorewall -l $OPTIONS reload $RESTARTOPTIONS | |||
} |
@ -1,11 +0,0 @@ | |||
--- a/shorewall-lite.conf 2012-08-08 16:29:23.000000000 +0200 | |||
+++ b/shorewall-lite.conf 2012-08-13 11:11:11.687938395 +0200 | |||
@@ -28,7 +28,7 @@ | |||
# L O G G I N G | |||
############################################################################### | |||
-LOGFILE= | |||
+LOGFILE=/dev/null | |||
############################################################################### | |||
# L O C A T I O N O F F I L E S A N D D I R E C T O R I E S |
@ -0,0 +1,13 @@ | |||
Index: shorewall-lite-5.1.7.2/shorewall-lite.conf | |||
=================================================================== | |||
--- shorewall-lite-5.1.7.2.orig/shorewall-lite.conf 2017-10-11 08:19:35.565847520 +0200 | |||
+++ shorewall-lite-5.1.7.2/shorewall-lite.conf 2017-10-11 08:19:35.561847733 +0200 | |||
@@ -28,7 +28,7 @@ | |||
# L O G G I N G | |||
############################################################################### | |||
-LOGFILE= | |||
+LOGFILE=/dev/null | |||
############################################################################### | |||
# L O C A T I O N O F F I L E S A N D D I R E C T O R I E S |
@ -0,0 +1,75 @@ | |||
# | |||
# Copyright (C) 2008-2012 OpenWrt.org | |||
# Copyright (C) 2017 Willem van den Akker <wvdakker@wilsoft.nl> | |||
# | |||
# This is free software, licensed under the GNU General Public License v2. | |||
# See /LICENSE for more information. | |||
# | |||
include $(TOPDIR)/rules.mk | |||
PKG_NAME:=shorewall | |||
PKG_VERSION:=5.1.8.1 | |||
PKG_DIRECTORY:=5.1 | |||
PKG_MAINVERSION:=5.1.8 | |||
PKG_RELEASE:=1 | |||
PKG_SOURCE_URL:=http://www.shorewall.net/pub/shorewall/$(PKG_DIRECTORY)/shorewall-$(PKG_MAINVERSION)/ | |||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2 | |||
PKG_HASH:=0ba4f22394d988a5714637444c248e542d5897e41ab5770907edf38e422fe2ff | |||
PKG_MAINTAINER:=Willem van den Akker <wvdakker@wilsoft.nl> | |||
PKG_LICENSE:=GPL-2.0+ | |||
PKG_LICENSE_FILES:=COPYING | |||
include $(INCLUDE_DIR)/package.mk | |||
define Package/shorewall | |||
SECTION:=devel | |||
CATEGORY:=Network | |||
DEPENDS:=+ip +iptables +kmod-ipt-hashlimit +kmod-ipt-raw +iptables-mod-hashlimit +shorewall-core \ | |||
+perl +perlbase-autoloader +perlbase-autouse +perlbase-dynaloader +perlbase-digest \ | |||
+perlbase-findbin +perlbase-getopt +perlbase-hash | |||
TITLE:=Shorewall Central Administration System | |||
URL:=http://www.shorewall.net/ | |||
SUBMENU:=Firewall | |||
endef | |||
define Package/shorewall/description | |||
The Shoreline Firewall, is high-level tool for configuring Netfilter. | |||
Shorewall allows for central administration of multiple IPv4 firewalls. | |||
This is the full Shorewall product which will compile Shorewall scripts. | |||
It is not recommended to run it on a low memory system. | |||
Note: This is the IPv4 implementation of Shorewall. | |||
This full Shorewal packages also installs Perl which can make the image big (about +2M). | |||
endef | |||
CONFIGURE_ARGS += \ | |||
vendor=openwrt | |||
define Build/Compile | |||
DESTDIR=$(PKG_INSTALL_DIR) $(PKG_BUILD_DIR)/install.sh | |||
endef | |||
define Package/shorewall/conffiles | |||
/etc/shorewall/ | |||
endef | |||
define Package/shorewall/install | |||
$(INSTALL_DIR) $(1)/etc/init.d/ | |||
$(INSTALL_DIR) $(1)/etc/hotplug.d/iface/ | |||
$(INSTALL_DIR) $(1)/etc/shorewall/ | |||
$(INSTALL_DIR) $(1)/usr/lib/shorewall/ | |||
$(INSTALL_DIR) $(1)/usr/sbin/ | |||
$(INSTALL_DIR) $(1)/usr/share/shorewall/ | |||
$(INSTALL_BIN) ./files/hotplug_iface $(1)/etc/hotplug.d/iface/05-shorewall | |||
$(INSTALL_BIN) ./files/hostname $(1)/etc/shorewall/ | |||
$(INSTALL_BIN) ./files/shorewall.init $(1)/etc/init.d/shorewall | |||
$(INSTALL_BIN) ./files/vardir $(1)/etc/shorewall/ | |||
$(CP) $(PKG_INSTALL_DIR)/etc/shorewall/. $(1)/etc/shorewall/ | |||
$(CP) $(PKG_INSTALL_DIR)/usr/lib/shorewall/. $(1)/usr/lib/shorewall/ | |||
$(CP) $(PKG_INSTALL_DIR)/usr/share/shorewall/. $(1)/usr/share/shorewall/ | |||
endef | |||
$(eval $(call BuildPackage,shorewall)) |
@ -0,0 +1,3 @@ | |||
#!/bin/sh | |||
uci get system.@system[0].hostname | |||
@ -0,0 +1,13 @@ | |||
#!/bin/sh | |||
# should restart shorewall when an interface comes up | |||
case "$ACTION" in | |||
ifup) | |||
/etc/init.d/shorewall restart | |||
;; | |||
ifdown) | |||
# might need to restore some routing | |||
/etc/init.d/shorewall restart | |||
;; | |||
esac |
@ -0,0 +1,32 @@ | |||
#!/bin/sh /etc/rc.common | |||
USE_PROCD=1 | |||
START=50 | |||
load_params () { | |||
. /usr/share/shorewall/shorewallrc | |||
} | |||
start_service() { | |||
load_params | |||
${SBINDIR}/shorewall $OPTIONS start $STARTOPTIONS | |||
} | |||
stop_service() { | |||
load_params | |||
${SBINDIR}/shorewall $OPTIONS stop $STOPOPTIONS | |||
} | |||
restart_service() { | |||
load_params | |||
${SBINDIR}/shorewall $OPTIONS restart $RESTARTOPTIONS | |||
} | |||
reload_service() { | |||
load_params | |||
${SBINDIR}/shorewall $OPTIONS reload $RESTARTOPTIONS | |||
} |
@ -0,0 +1,2 @@ | |||
VARDIR=/tmp/state | |||
@ -0,0 +1,23 @@ | |||
Index: shorewall-5.1.4.1/install.sh | |||
=================================================================== | |||
--- shorewall-5.1.4.1.orig/install.sh 2017-05-26 17:39:12.000000000 +0200 | |||
+++ shorewall-5.1.4.1/install.sh 2017-06-06 19:26:46.152686822 +0200 | |||
@@ -213,6 +213,8 @@ | |||
BUILD=suse | |||
elif [ -f /etc/arch-release ] ; then | |||
BUILD=archlinux | |||
+ elif [ -f ${CONFDIR}/openwrt_release ] ; then | |||
+ BUILD=openwrt | |||
else | |||
BUILD=linux | |||
fi | |||
@@ -264,6 +266,9 @@ | |||
archlinux) | |||
echo "Installing ArchLinux-specific configuration..." | |||
;; | |||
+ openwrt) | |||
+ echo "Installing OpenWRT-specific configuration..." | |||
+ ;; | |||
linux) | |||
;; | |||
*) |
@ -0,0 +1,22 @@ | |||
Index: shorewall-5.1.4.1/configfiles/shorewall.conf | |||
=================================================================== | |||
--- shorewall-5.1.4.1.orig/configfiles/shorewall.conf 2017-10-05 11:18:41.586275516 +0200 | |||
+++ shorewall-5.1.4.1/configfiles/shorewall.conf 2017-10-05 11:26:11.825609382 +0200 | |||
@@ -33,7 +33,7 @@ | |||
# L O G G I N G | |||
############################################################################### | |||
-LOG_LEVEL="info" | |||
+LOG_LEVEL="warn" | |||
BLACKLIST_LOG_LEVEL= | |||
@@ -101,7 +101,7 @@ | |||
SHOREWALL_SHELL=/bin/sh | |||
-SUBSYSLOCK=/var/lock/subsys/shorewall | |||
+SUBSYSLOCK=/var/lock/shorewall | |||
TC= | |||
@ -1,2 +1,2 @@ | |||
#!/bin/sh | |||
cat /proc/sys/kernel/hostname | |||
uci get system.@system[0].hostname |
@ -1,12 +1,13 @@ | |||
#!/bin/sh | |||
# should restart shorewall6-lite when an interface comes up | |||
# should restart shorewall when an interface comes up | |||
[ ifup = "$ACTION" ] && { | |||
case "$ACTION" in | |||
ifup) | |||
/etc/init.d/shorewall6-lite restart | |||
} | |||
[ ifdown = "$ACTION" ] && { | |||
;; | |||
ifdown) | |||
# might need to restore some routing | |||
/etc/init.d/shorewall6-lite restart | |||
} | |||
;; | |||
esac |
@ -0,0 +1,32 @@ | |||
#!/bin/sh /etc/rc.common | |||
USE_PROCD=1 | |||
START=50 | |||
load_params () { | |||
. /usr/share/shorewall/shorewallrc | |||
} | |||
start_service() { | |||
load_params | |||
${SBINDIR}/shorewall -6l $OPTIONS start $STARTOPTIONS | |||
} | |||
stop_service() { | |||
load_params | |||
${SBINDIR}/shorewall -6l $OPTIONS stop $STOPOPTIONS | |||
} | |||
restart_service() { | |||
load_params | |||
${SBINDIR}/shorewall -6l $OPTIONS restart $RESTARTOPTIONS | |||
} | |||
reload_service() { | |||
load_params | |||
${SBINDIR}/shorewall -6l $OPTIONS reload $RESTARTOPTIONS | |||
} |
@ -1,11 +0,0 @@ | |||
--- a/shorewall6-lite.conf 2012-08-08 16:29:23.000000000 +0200 | |||
+++ b/shorewall6-lite.conf 2012-08-13 11:11:11.687938395 +0200 | |||
@@ -28,7 +28,7 @@ | |||
# L O G G I N G | |||
############################################################################### | |||
-LOGFILE= | |||
+LOGFILE=/dev/null | |||
############################################################################### | |||
# L O C A T I O N O F F I L E S A N D D I R E C T O R I E S |
@ -0,0 +1,13 @@ | |||
Index: shorewall6-lite-5.1.7.2/shorewall6-lite.conf | |||
=================================================================== | |||
--- shorewall6-lite-5.1.7.2.orig/shorewall6-lite.conf 2017-10-11 15:36:41.037818015 +0200 | |||
+++ shorewall6-lite-5.1.7.2/shorewall6-lite.conf 2017-10-11 15:36:41.033818232 +0200 | |||
@@ -28,7 +28,7 @@ | |||
# L O G G I N G | |||
############################################################################### | |||
-LOGFILE= | |||
+LOGFILE=/dev/null | |||
############################################################################### | |||
# L O C A T I O N O F F I L E S A N D D I R E C T O R I E S |
@ -0,0 +1,74 @@ | |||
# | |||
# Copyright (C) 2008-2012 OpenWrt.org | |||
# Copyright (C) 2017 Willem van den Akker <wvdakker@wilsoft.nl> | |||
# | |||
# This is free software, licensed under the GNU General Public License v2. | |||
# See /LICENSE for more information. | |||
# | |||
include $(TOPDIR)/rules.mk | |||
PKG_NAME:=shorewall6 | |||
PKG_VERSION:=5.1.8.1 | |||
PKG_DIRECTORY:=5.1 | |||
PKG_MAINVERSION:=5.1.8 | |||
PKG_RELEASE:=1 | |||
PKG_SOURCE_URL:=http://www.shorewall.net/pub/shorewall/$(PKG_DIRECTORY)/shorewall-$(PKG_MAINVERSION)/ | |||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2 | |||
PKG_HASH:=fde5b7a9eb0d4241ef3dfb8392b93f86a974c76cec8b05bd946bc12f509aca8e | |||
PKG_MAINTAINER:=Willem van den Akker <wvdakker@wilsoft.nl> | |||
PKG_LICENSE:=GPL-2.0+ | |||
PKG_LICENSE_FILES:=COPYING | |||
include $(INCLUDE_DIR)/package.mk | |||
define Package/shorewall6 | |||
SECTION:=net | |||
CATEGORY:=Network | |||
DEPENDS:=+ip +ip6tables +kmod-ipt-hashlimit +kmod-ipt-raw6 +iptables-mod-hashlimit +shorewall-core \ | |||
+perl +perlbase-autoloader +perlbase-autouse +perlbase-dynaloader +perlbase-digest \ | |||
+perlbase-findbin +perlbase-getopt +perlbase-hash | |||
TITLE:=Shorewall6 Central Administration System | |||
URL:=http://www.shorewall.net/ | |||
SUBMENU:=Firewall | |||
endef | |||
define Package/shorewall6/description | |||
The Shoreline Firewall, is high-level tool for configuring Netfilter. | |||
Shorewall allows for central administration of multiple IPv6 firewalls. | |||
This is the full Shorewall product which will compile Shorewall scripts | |||
It is not recommended to run it on a low memory system. | |||
Note: This is the IPv6 implementation of Shorewall. | |||
This full Shorewal packages also installs Perl which can make the image big (about +2M). | |||
endef | |||
CONFIGURE_ARGS += \ | |||
vendor=openwrt | |||
define Package/shorewall6/conffiles | |||
/etc/shorewall6/ | |||
endef | |||
define Build/Compile | |||
DESTDIR=$(PKG_INSTALL_DIR) $(PKG_BUILD_DIR)/install.sh | |||
endef | |||
define Package/shorewall6/install | |||
$(INSTALL_DIR) $(1)/etc/hotplug.d/iface | |||
$(INSTALL_DIR) $(1)/etc/init.d/ | |||
$(INSTALL_DIR) $(1)/etc/shorewall6/ | |||
$(INSTALL_DIR) $(1)/usr/sbin/ | |||
$(INSTALL_DIR) $(1)/usr/share/shorewall6/ | |||
$(INSTALL_BIN) ./files/hostname $(1)/etc/shorewall6/ | |||
$(INSTALL_BIN) ./files/hotplug_iface $(1)/etc/hotplug.d/iface/05-shorewall6 | |||
$(INSTALL_BIN) ./files/shorewall6.init $(1)/etc/init.d/shorewall6 | |||
$(INSTALL_BIN) ./files/vardir $(1)/etc/shorewall6/ | |||
$(CP) $(PKG_INSTALL_DIR)/etc/shorewall6/. $(1)/etc/shorewall6/ | |||
$(CP) $(PKG_INSTALL_DIR)/usr/sbin/shorewall6 $(1)/usr/sbin/ | |||
$(CP) $(PKG_INSTALL_DIR)/usr/share/shorewall6/. $(1)/usr/share/shorewall6/ | |||
endef | |||
$(eval $(call BuildPackage,shorewall6)) |
@ -0,0 +1,3 @@ | |||
#!/bin/sh | |||
uci get system.@system[0].hostname | |||
@ -0,0 +1,13 @@ | |||
#!/bin/sh | |||
# should restart shorewall when an interface comes up | |||
case "$ACTION" in | |||
ifup) | |||
/etc/init.d/shorewall6 restart | |||
;; | |||
ifdown) | |||
# might need to restore some routing | |||
/etc/init.d/shorewall6 restart | |||
;; | |||
esac |
@ -0,0 +1,32 @@ | |||
#!/bin/sh /etc/rc.common | |||
USE_PROCD=1 | |||
START=50 | |||
load_params () { | |||
. /usr/share/shorewall/shorewallrc | |||
} | |||
start_service() { | |||
load_params | |||
${SBINDIR}/shorewall -6 $OPTIONS start $STARTOPTIONS | |||
} | |||
stop_service() { | |||
load_params | |||
${SBINDIR}/shorewall -6 $OPTIONS stop $STOPOPTIONS | |||
} | |||
restart_service() { | |||
load_params | |||
${SBINDIR}/shorewall -6 $OPTIONS restart $RESTARTOPTIONS | |||
} | |||
reload_service() { | |||
load_params | |||
${SBINDIR}/shorewall -6 $OPTIONS reload $RESTARTOPTIONS | |||
} |
@ -0,0 +1,2 @@ | |||
VARDIR=/tmp/state | |||
@ -0,0 +1,23 @@ | |||
Index: shorewall6-5.1.4.1/install.sh | |||
=================================================================== | |||
--- shorewall6-5.1.4.1.orig/install.sh 2017-05-26 17:39:12.000000000 +0200 | |||
+++ shorewall6-5.1.4.1/install.sh 2017-06-06 21:22:46.124285327 +0200 | |||
@@ -213,6 +213,8 @@ | |||
BUILD=suse | |||
elif [ -f /etc/arch-release ] ; then | |||
BUILD=archlinux | |||
+ elif [ -f ${CONFDIR}/openwrt_release ] ; then | |||
+ BUILD=openwrt | |||
else | |||
BUILD=linux | |||
fi | |||
@@ -264,6 +266,9 @@ | |||
archlinux) | |||
echo "Installing ArchLinux-specific configuration..." | |||
;; | |||
+ openwrt) | |||
+ echo "Installing OpenWRT-specific configuration..." | |||
+ ;; | |||
linux) | |||
;; | |||
*) |
@ -0,0 +1,22 @@ | |||
Index: shorewall6-5.1.4.1/configfiles/shorewall6.conf | |||
=================================================================== | |||
--- shorewall6-5.1.4.1.orig/configfiles/shorewall6.conf 2017-10-05 11:28:34.893849703 +0200 | |||
+++ shorewall6-5.1.4.1/configfiles/shorewall6.conf 2017-10-05 11:29:13.047785350 +0200 | |||
@@ -34,7 +34,7 @@ | |||
# L O G G I N G | |||
############################################################################### | |||
-LOG_LEVEL="info" | |||
+LOG_LEVEL="warn" | |||
BLACKLIST_LOG_LEVEL= | |||
@@ -98,7 +98,7 @@ | |||
SHOREWALL_SHELL=/bin/sh | |||
-SUBSYSLOCK=/var/lock/subsys/shorewall6 | |||
+SUBSYSLOCK=/var/lock/shorewall6 | |||
TC= | |||