Browse Source

Merge pull request #7370 from neheb/light

lighttpd: Fix Compilation with OpenSSL 1.1.x
lilik-openwrt-22.03
Hannu Nyman 6 years ago
committed by GitHub
parent
commit
49adfe3d32
No known key found for this signature in database GPG Key ID: 4AEE18F83AFDEB23
2 changed files with 15 additions and 1 deletions
  1. +1
    -1
      net/lighttpd/Makefile
  2. +14
    -0
      net/lighttpd/patches/010-openssl-deprecated.patch

+ 1
- 1
net/lighttpd/Makefile View File

@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=lighttpd
PKG_VERSION:=1.4.49
PKG_RELEASE:=2
PKG_RELEASE:=3
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
PKG_SOURCE_URL:=https://download.lighttpd.net/lighttpd/releases-1.4.x


+ 14
- 0
net/lighttpd/patches/010-openssl-deprecated.patch View File

@ -0,0 +1,14 @@
diff --git a/src/rand.c b/src/rand.c
index 10cd025..63fbb0d 100644
--- a/src/rand.c
+++ b/src/rand.c
@@ -226,7 +226,9 @@ int li_rand_bytes (unsigned char *buf, int num)
void li_rand_cleanup (void)
{
#ifdef USE_OPENSSL_CRYPTO
+ #if OPENSSL_VERSION_NUMBER < 0x10100000L
RAND_cleanup();
+ #endif
#endif
safe_memclear(xsubi, sizeof(xsubi));
}

Loading…
Cancel
Save