Browse Source

getdns: fix compilation without deprecated OpenSSL APIs

Signed-off-by: Rosen Penev <rosenp@gmail.com>
lilik-openwrt-22.03
Rosen Penev 4 years ago
parent
commit
490a4eff19
No known key found for this signature in database GPG Key ID: 36D31CFA845F0E3B
2 changed files with 58 additions and 1 deletions
  1. +1
    -1
      libs/getdns/Makefile
  2. +57
    -0
      libs/getdns/patches/020-openssl-no-dynamic.patch

+ 1
- 1
libs/getdns/Makefile View File

@ -6,7 +6,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=getdns
PKG_VERSION:=1.6.0
PKG_RELEASE:=2
PKG_RELEASE:=3
PKG_LICENSE:=BSD-3-Clause
PKG_LICENSE_FILES:=LICENSE


+ 57
- 0
libs/getdns/patches/020-openssl-no-dynamic.patch View File

@ -0,0 +1,57 @@
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -334,6 +334,9 @@ check_include_file(openssl/err.h HAVE_OPENSSL_ERR_H)
check_include_file(openssl/rand.h HAVE_OPENSSL_RAND_H)
check_include_file(openssl/conf.h HAVE_OPENSSL_CONF_H)
check_include_file(openssl/engine.h HAVE_OPENSSL_ENGINE_H)
+check_include_file(openssl/bn.h HAVE_OPENSSL_BN_H)
+check_include_file(openssl/dsa.h HAVE_OPENSSL_DSA_H)
+check_include_file(openssl/rsa.h HAVE_OPENSSL_RSA_H)
set(CMAKE_REQUIRED_LIBRARIES ${OPENSSL_LIBRARIES})
check_function_exists(DSA_SIG_set0 HAVE_DSA_SIG_SET0)
--- a/cmake/include/cmakeconfig.h.in
+++ b/cmake/include/cmakeconfig.h.in
@@ -58,6 +58,9 @@
#cmakedefine HAVE_OPENSSL_RAND_H 1
#cmakedefine HAVE_OPENSSL_CONF_H 1
#cmakedefine HAVE_OPENSSL_ENGINE_H 1
+#cmakedefine HAVE_OPENSSL_BN_H 1
+#cmakedefine HAVE_OPENSSL_DSA_H 1
+#cmakedefine HAVE_OPENSSL_RSA_H 1
#cmakedefine HAVE_DSA_SIG_SET0 1
#cmakedefine HAVE_DSA_SET0_PQG 1
--- a/src/openssl/keyraw-internal.c
+++ b/src/openssl/keyraw-internal.c
@@ -21,10 +21,10 @@
#include <openssl/err.h>
#include <openssl/md5.h>
#ifdef HAVE_OPENSSL_CONF_H
-# include <openssl/conf.h>
+#include <openssl/conf.h>
#endif
#ifdef HAVE_OPENSSL_ENGINE_H
-# include <openssl/engine.h>
+#include <openssl/engine.h>
#endif
#ifdef HAVE_OPENSSL_BN_H
#include <openssl/bn.h>
@@ -35,6 +35,9 @@
#ifdef HAVE_OPENSSL_DSA_H
#include <openssl/dsa.h>
#endif
+#ifdef HAVE_OPENSSL_RSA_H
+#include <openssl/rsa.h>
+#endif
#endif /* HAVE_SSL */
#ifdef HAVE_SSL
@@ -74,7 +77,6 @@ gldns_key_EVP_load_gost_id(void)
if(!e) {
/* load it ourself, in case statically linked */
ENGINE_load_builtin_engines();
- ENGINE_load_dynamic();
e = ENGINE_by_id("gost");
}
if(!e) {

Loading…
Cancel
Save