Browse Source

glib2: revert intl change

This was causing massive buildbot failure.

The intent was to fix uClibc-ng and CONFIG_BUILD_NLS, but that ended up
breaking everything.

Signed-off-by: Rosen Penev <rosenp@gmail.com>
lilik-openwrt-22.03
Rosen Penev 4 years ago
parent
commit
48870aac0c
2 changed files with 3 additions and 14 deletions
  1. +3
    -3
      libs/glib2/Makefile
  2. +0
    -11
      libs/glib2/patches/005-intl-fix.patch

+ 3
- 3
libs/glib2/Makefile View File

@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=glib2
PKG_VERSION:=2.65.0
PKG_RELEASE:=2
PKG_RELEASE:=3
PKG_SOURCE:=glib-$(PKG_VERSION).tar.xz
PKG_SOURCE_URL:=@GNOME/glib/2.65
@ -43,9 +43,9 @@ define Package/glib2/description
The GLib library of C routines
endef
HOST_LDFLAGS += -Wl,-rpath=$(STAGING_DIR_HOSTPKG)/lib
HOST_LDFLAGS += -liconv -Wl,-rpath,$(STAGING_DIR_HOSTPKG)/lib
TARGET_CFLAGS += -ffunction-sections -fdata-sections
TARGET_LDFLAGS += -Wl,--gc-sections
TARGET_LDFLAGS += -Wl,--gc-sections -liconv
COMP_ARGS= \
-Diconv=external \


+ 0
- 11
libs/glib2/patches/005-intl-fix.patch View File

@ -1,11 +0,0 @@
--- a/meson.build
+++ b/meson.build
@@ -1955,7 +1955,7 @@ endif
# FIXME: glib-gettext.m4 has much more checks to detect broken/uncompatible
# implementations. This could be extended if issues are found in some platforms.
libintl_deps = []
-if cc.has_function('ngettext')
+if false
have_bind_textdomain_codeset = cc.has_function('bind_textdomain_codeset')
else
# First just find the bare library.

Loading…
Cancel
Save