Browse Source

hfsprogs: Fix compilation with uClibc-ng

Replaced deprecated and unsupported valloc with posix_memalign.

Signed-off-by: Rosen Penev <rosenp@gmail.com>
lilik-openwrt-22.03
Rosen Penev 5 years ago
parent
commit
4639e208b3
No known key found for this signature in database GPG Key ID: 36D31CFA845F0E3B
2 changed files with 21 additions and 1 deletions
  1. +1
    -1
      utils/hfsprogs/Makefile
  2. +20
    -0
      utils/hfsprogs/patches/010-valloc-to-memalign.patch

+ 1
- 1
utils/hfsprogs/Makefile View File

@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=hfsprogs
PKG_VERSION:=332.25
PKG_RELEASE:=1
PKG_RELEASE:=2
PKG_LICENSE:=GPL-3.0+
PKG_LICENSE_FILES:=COPYING


+ 20
- 0
utils/hfsprogs/patches/010-valloc-to-memalign.patch View File

@ -0,0 +1,20 @@
--- a/newfs_hfs.tproj/makehfs.c
+++ b/newfs_hfs.tproj/makehfs.c
@@ -376,7 +376,7 @@ make_hfsplus(const DriveInfo *driveInfo, hfsparams_t *defaults)
if ( (temp & 0x01FF) != 0 )
temp = (temp + kBytesPerSector) & 0xFFFFFE00;
- nodeBuffer = valloc((size_t)temp);
+ (void)posix_memalign(&nodeBuffer, sysconf(_SC_PAGESIZE), (size_t)temp);
if (nodeBuffer == NULL)
err(1, NULL);
@@ -1814,7 +1814,7 @@ ClearDisk(const DriveInfo *driveInfo, UInt64 startingSector, UInt32 numberOfSect
bufferSize = bufferSizeInSectors << kLog2SectorSize;
- tempBuffer = valloc((size_t)bufferSize);
+ (void)posix_memalign(&tempBuffer, sysconf(_SC_PAGESIZE), (size_t)bufferSize);
if (tempBuffer == NULL)
err(1, NULL);

Loading…
Cancel
Save