Browse Source

Merge pull request #7008 from TDT-AG/pr/20180912-keepalived-enable-ipvs

net/keepalived: update to version 2.0.7 and enable ipvs support
lilik-openwrt-22.03
Dirk Brenken 6 years ago
committed by GitHub
parent
commit
4560c17c60
No known key found for this signature in database GPG Key ID: 4AEE18F83AFDEB23
2 changed files with 32 additions and 5 deletions
  1. +7
    -5
      net/keepalived/Makefile
  2. +25
    -0
      net/keepalived/patches/0001-Include-stdbool.h-in-process.c.patch

+ 7
- 5
net/keepalived/Makefile View File

@ -8,12 +8,12 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=keepalived
PKG_VERSION:=1.4.4
PKG_VERSION:=2.0.7
PKG_RELEASE:=1
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
PKG_SOURCE_URL:=http://www.keepalived.org/software
PKG_HASH:=147c2b3b782223128551fd0a1564eaa30ed84a94b68c50ec5087747941314704
PKG_HASH:=bce45d6d5cf3620bfd88472ec839a75b5a14a54fda12d09e890670244873b8ab
PKG_LICENSE:=GPL-2.0+
PKG_LICENSE_FILES:=COPYING
@ -36,7 +36,11 @@ define Package/keepalived
+libip4tc \
+IPV6:libip6tc \
+libxtables \
+kmod-macvlan
+kmod-macvlan \
+libmagic \
+libnl-route \
+libnfnetlink \
+kmod-nf-ipvs
endef
define Package/keepalived/description
@ -51,8 +55,6 @@ endef
CONFIGURE_ARGS+= \
--enable-sha1 \
--disable-lvs \
--disable-lvs-syncd \
--disable-snmp \
--with-kernel-dir="$(LINUX_DIR)/$(LINUX_UAPI_DIR)"


+ 25
- 0
net/keepalived/patches/0001-Include-stdbool.h-in-process.c.patch View File

@ -0,0 +1,25 @@
From 6c7a281473083f7ac47b426b2127a8c8e76caca5 Mon Sep 17 00:00:00 2001
From: Quentin Armitage <quentin@armitage.org.uk>
Date: Sat, 25 Aug 2018 11:36:11 +0100
Subject: [PATCH] Include stdbool.h in process.c
Signed-off-by: Quentin Armitage <quentin@armitage.org.uk>
---
keepalived/core/process.c | 1 +
1 file changed, 1 insertion(+)
diff --git a/keepalived/core/process.c b/keepalived/core/process.c
index f11c32a3..22bcf254 100644
--- a/keepalived/core/process.c
+++ b/keepalived/core/process.c
@@ -30,6 +30,7 @@
#ifdef _HAVE_SCHED_RT_
#include <sched.h>
#endif
+#include <stdbool.h>
#include "process.h"
#include "logger.h"
--
2.11.0

Loading…
Cancel
Save