Browse Source

net/mosquitto: Upgrade 1.4.1 to 1.4.2

Bugfix release.  Full changelog available at:
http://mosquitto.org/2015/05/version-1-4-2-released/

Drops a patch now included upstream.

Signed-off-by: Karl Palsson <karlp@remake.is>
lilik-openwrt-22.03
Karl Palsson 9 years ago
parent
commit
453152b874
2 changed files with 2 additions and 14 deletions
  1. +2
    -2
      net/mosquitto/Makefile
  2. +0
    -12
      net/mosquitto/patches/101-qos2-inflight.patch

+ 2
- 2
net/mosquitto/Makefile View File

@ -9,14 +9,14 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=mosquitto
PKG_VERSION:=1.4.1
PKG_VERSION:=1.4.2
PKG_RELEASE:=2
PKG_LICENSE:=BSD-3-Clause
PKG_LICENSE_FILES:=LICENSE.txt
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
PKG_SOURCE_URL:=http://mosquitto.org/files/source/
PKG_MD5SUM:=46008028563eb750c6aa93281ab2e181
PKG_MD5SUM:=2c3b19686c04849ed4b183c63149bfe1
PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(BUILD_VARIANT)/$(PKG_NAME)-$(PKG_VERSION)
include $(INCLUDE_DIR)/package.mk


+ 0
- 12
net/mosquitto/patches/101-qos2-inflight.patch View File

@ -1,12 +0,0 @@
diff --git a/lib/mosquitto.c b/lib/mosquitto.c
index bd9dbd3..7314248 100644
--- a/lib/mosquitto.c
+++ b/lib/mosquitto.c
@@ -594,7 +594,6 @@ int mosquitto_publish(struct mosquitto *mosq, int *mid, const char *topic, int p
pthread_mutex_lock(&mosq->out_message_mutex);
_mosquitto_message_queue(mosq, message, mosq_md_out);
if(mosq->max_inflight_messages == 0 || mosq->inflight_messages < mosq->max_inflight_messages){
- mosq->inflight_messages++;
if(qos == 1){
message->state = mosq_ms_wait_for_puback;
}else if(qos == 2){

Loading…
Cancel
Save