Browse Source

zile: fix gcc5 build issues

Signed-off-by: Ted Hess <thess@kitschensync.net>
lilik-openwrt-22.03
Ted Hess 9 years ago
parent
commit
43a71474f6
2 changed files with 18 additions and 2 deletions
  1. +7
    -2
      utils/zile/Makefile
  2. +11
    -0
      utils/zile/patches/010-remove_gets_definition_warning.patch

+ 7
- 2
utils/zile/Makefile View File

@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=zile PKG_NAME:=zile
PKG_VERSION:=2.3.24 PKG_VERSION:=2.3.24
PKG_RELEASE:=1
PKG_RELEASE:=2
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
PKG_SOURCE_URL:=@GNU/zile PKG_SOURCE_URL:=@GNU/zile
@ -19,8 +19,11 @@ PKG_MAINTAINER:=Ted Hess <thess@kitschensync.net>
PKG_LICENSE:=GPL-3.0+ PKG_LICENSE:=GPL-3.0+
PKG_LICENSE_FILES:=COPYING PKG_LICENSE_FILES:=COPYING
PKG_FIXUP:=autoreconf
PKG_INSTALL:=1 PKG_INSTALL:=1
PKG_BUILD_DEPENDS += libncurses
include $(INCLUDE_DIR)/package.mk include $(INCLUDE_DIR)/package.mk
define Package/zile define Package/zile
@ -39,7 +42,9 @@ define Package/zile/description
endef endef
CONFIGURE_VARS += \ CONFIGURE_VARS += \
gl_cv_func_getopt_gnu=yes
gl_cv_func_getopt_gnu=yes \
gl_cv_warn__Wmudflap=no \
gl_cv_warn__fmudflap=no
define Package/zile/install define Package/zile/install
$(INSTALL_DIR) $(1)/usr/bin $(INSTALL_DIR) $(1)/usr/bin


+ 11
- 0
utils/zile/patches/010-remove_gets_definition_warning.patch View File

@ -0,0 +1,11 @@
--- a/lib/stdio.in.h
+++ b/lib/stdio.in.h
@@ -733,7 +733,7 @@ _GL_CXXALIASWARN (gets);
/* It is very rare that the developer ever has full control of stdin,
so any use of gets warrants an unconditional warning. Assume it is
always declared, since it is required by C89. */
-_GL_WARN_ON_USE (gets, "gets is a security hole - use fgets instead");
+#define gets(a) fgets( a, sizeof(*(a)), stdin)
#endif

Loading…
Cancel
Save