Browse Source

Merge pull request #14658 from mhei/php8-fix-x86_64-build

php8: fix cross-compiling for x86_64
lilik-openwrt-22.03
Michael Heimpold 3 years ago
committed by GitHub
parent
commit
43140d77ee
No known key found for this signature in database GPG Key ID: 4AEE18F83AFDEB23
2 changed files with 28 additions and 0 deletions
  1. +3
    -0
      lang/php8/Makefile
  2. +25
    -0
      lang/php8/patches/1010-Fix-opcache-jit-minilua-compiling.patch

+ 3
- 0
lang/php8/Makefile View File

@ -466,6 +466,9 @@ CONFIGURE_VARS+= \
ac_cv_u8t_decompose=yes \
ac_cv_have_pcre2_jit=no
MAKE_VARS+= \
HOSTCC="$(HOSTCC)"
define Package/php8/conffiles
/etc/php.ini
/etc/php8/


+ 25
- 0
lang/php8/patches/1010-Fix-opcache-jit-minilua-compiling.patch View File

@ -0,0 +1,25 @@
From 73ea1d44c1e6b063bfa02e12919ec8a9de3709d8 Mon Sep 17 00:00:00 2001
From: Michael Heimpold <mhei@heimpold.de>
Date: Wed, 3 Feb 2021 22:51:34 +0100
Subject: [PATCH] Fix opcache jit minilua compiling
Signed-off-by: Michael Heimpold <mhei@heimpold.de>
---
ext/opcache/jit/Makefile.frag | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/ext/opcache/jit/Makefile.frag b/ext/opcache/jit/Makefile.frag
index d4f97de..7421897 100644
--- a/ext/opcache/jit/Makefile.frag
+++ b/ext/opcache/jit/Makefile.frag
@@ -1,6 +1,6 @@
$(builddir)/minilua: $(srcdir)/jit/dynasm/minilua.c
- $(CC) $(srcdir)/jit/dynasm/minilua.c -lm -o $@
+ $(HOSTCC) $(srcdir)/jit/dynasm/minilua.c -lm -o $@
$(builddir)/jit/zend_jit_x86.c: $(srcdir)/jit/zend_jit_x86.dasc $(srcdir)/jit/dynasm/*.lua $(builddir)/minilua
$(builddir)/minilua $(srcdir)/jit/dynasm/dynasm.lua $(DASM_FLAGS) -o $@ $(srcdir)/jit/zend_jit_x86.dasc
--
2.17.1

Loading…
Cancel
Save