Browse Source
netsniff-ng: add missing header
Needed for ssize_t.
Signed-off-by: Rosen Penev <rosenp@gmail.com>
lilik-openwrt-22.03
Rosen Penev
4 years ago
No known key found for this signature in database
GPG Key ID: 36D31CFA845F0E3B
2 changed files with
11 additions and
1 deletions
-
net/netsniff-ng/Makefile
-
net/netsniff-ng/patches/010-uclibc.patch
|
@ -2,7 +2,7 @@ include $(TOPDIR)/rules.mk |
|
|
|
|
|
|
|
|
PKG_NAME:=netsniff-ng |
|
|
PKG_NAME:=netsniff-ng |
|
|
PKG_VERSION:=0.6.7 |
|
|
PKG_VERSION:=0.6.7 |
|
|
PKG_RELEASE:=1 |
|
|
|
|
|
|
|
|
PKG_RELEASE:=2 |
|
|
|
|
|
|
|
|
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz |
|
|
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz |
|
|
PKG_SOURCE_URL:=https://codeload.github.com/netsniff-ng/netsniff-ng/tar.gz/v$(PKG_VERSION)? |
|
|
PKG_SOURCE_URL:=https://codeload.github.com/netsniff-ng/netsniff-ng/tar.gz/v$(PKG_VERSION)? |
|
|
|
@ -0,0 +1,10 @@ |
|
|
|
|
|
--- a/cookie.c
|
|
|
|
|
|
+++ b/cookie.c
|
|
|
|
|
|
@@ -2,6 +2,7 @@
|
|
|
|
|
|
#include <stdio.h> |
|
|
|
|
|
#include <string.h> |
|
|
|
|
|
#include <syslog.h> |
|
|
|
|
|
+#include <sys/types.h>
|
|
|
|
|
|
|
|
|
|
|
|
#include "cookie.h" |
|
|
|
|
|
|