Browse Source

Merge pull request #9529 from neheb/inl

perl updates
lilik-openwrt-22.03
Rosen Penev 5 years ago
committed by GitHub
parent
commit
423584875a
No known key found for this signature in database GPG Key ID: 4AEE18F83AFDEB23
6 changed files with 20 additions and 19 deletions
  1. +3
    -3
      lang/perl-device-usb/Makefile
  2. +6
    -6
      lang/perl-device-usb/patches/140-avoid-libusb-name-conflicts.patch
  3. +6
    -5
      lang/perl-inline-c/Makefile
  4. +1
    -1
      lang/perl-inline-c/patches/100-inline_c-no_compile_hack.patch
  5. +1
    -1
      lang/perl-inline-c/patches/110-inline_c-make_system_typemap_overridable.patch
  6. +3
    -3
      lang/perl-inline/Makefile

+ 3
- 3
lang/perl-device-usb/Makefile View File

@ -8,15 +8,15 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=perl-device-usb
PKG_VERSION:=0.37
PKG_VERSION:=0.38
PKG_RELEASE:=1
PKG_SOURCE_URL:=https://www.cpan.org/authors/id/G/GW/GWADEJ/
PKG_SOURCE:=Device-USB-$(PKG_VERSION).tar.gz
PKG_HASH:=0dd58d9c627b3c539d07263a7b96e1de2adea3a4ddb118cdd45aa638f8702e49
PKG_HASH:=f0c36379db4913406dc9bd546a6cfd4da20d58f7c2cc085893a2fe67a43465dc
PKG_LICENSE:=GPL-1.0+ Artistic-1.0-Perl
PKG_MAINTAINER:=Marcel Denia <naoir@gmx.net>
PKG_LICENSE:=GPL-1.0-or-later Artistic-1.0-Perl
PKG_BUILD_DIR:=$(BUILD_DIR)/perl/Device-USB-$(PKG_VERSION)
PKG_BUILD_DEPENDS:=perl-inline-c/host


+ 6
- 6
lang/perl-device-usb/patches/140-avoid-libusb-name-conflicts.patch View File

@ -3,12 +3,12 @@
@@ -15,6 +15,7 @@ use Inline (
($ENV{LIBUSB_INCDIR} ? ( INC => "-I\"$ENV{LIBUSB_INCDIR}\"" ) : () ),
NAME => 'Device::USB',
VERSION => '0.37',
VERSION => '0.38',
+ PREFIX => 'deviceusb_',
);
Inline->init();
@@ -540,74 +541,74 @@ unsigned DeviceUSBDebugLevel()
@@ -657,74 +658,74 @@ unsigned DeviceUSBDebugLevel()
return debugLevel;
}
@ -98,7 +98,7 @@
}
#if LIBUSB_HAS_GET_DRIVER_NP
ret = usb_get_driver_np((usb_dev_handle *)dev, interface, name, namelen);
@@ -618,11 +619,11 @@ int libusb_get_driver_np(void *dev, int
@@ -735,11 +736,11 @@ int libusb_get_driver_np(void *dev, int interface, char *name, unsigned int name
#endif
}
@ -112,7 +112,7 @@
}
#if LIBUSB_HAS_DETACH_KERNEL_DRIVER_NP
return usb_detach_kernel_driver_np((usb_dev_handle *)dev, interface);
@@ -631,25 +632,25 @@ int libusb_detach_kernel_driver_np(void
@@ -748,25 +749,25 @@ int libusb_detach_kernel_driver_np(void *dev, int interface)
#endif
}
@ -143,7 +143,7 @@
{
int i = 0;
int retval = 0;
@@ -658,7 +659,7 @@ void libusb_control_msg(void *dev, int r
@@ -775,7 +776,7 @@ void libusb_control_msg(void *dev, int requesttype, int request, int value, int
if(DeviceUSBDebugLevel())
{
@ -152,7 +152,7 @@
requesttype, request, value, index, bytes, size, timeout
);
/* maybe need to add support for printing the bytes string. */
@@ -691,54 +692,54 @@ void libusb_control_msg(void *dev, int r
@@ -808,54 +809,54 @@ void libusb_control_msg(void *dev, int requesttype, int request, int value, int
Inline_Stack_Done;
}


+ 6
- 5
lang/perl-inline-c/Makefile View File

@ -8,15 +8,16 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=perl-inline-c
PKG_VERSION:=0.78
PKG_VERSION:=0.81
PKG_RELEASE:=1
PKG_SOURCE_URL:=http://www.cpan.org/authors/id/T/TI/TINITA
PKG_SOURCE:=Inline-C-$(PKG_VERSION).tar.gz
PKG_HASH:=9a7804d85c01a386073d2176582b0262b6374c5c0341049da3ef84c6f53efbc7
PKG_SOURCE_URL:=https://www.cpan.org/authors/id/T/TI/TINITA
PKG_HASH:=f185258d9050d7f79b4f00f12625cc469c2f700ff62d3e831cb18d80d2c87aac
PKG_LICENSE:=GPL-1.0+ Artistic-1.0-Perl
PKG_MAINTAINER:=Marcel Denia <naoir@gmx.net>
PKG_LICENSE:=GPL-1.0-or-later Artistic-1.0-Perl
PKG_LICENSE_FILES:=LICENSE
HOST_BUILD_DIR:=$(BUILD_DIR_HOST)/perl/Inline-C-$(PKG_VERSION)
HOST_BUILD_DEPENDS:=perl/host perl-inline/host perl-parse-recdescent/host perl-file-sharedir-install/host
@ -32,7 +33,7 @@ define Package/perl-inline-c
SECTION:=lang
CATEGORY:=Languages
TITLE:=C Language Support for Inline
URL:=http://search.cpan.org/dist/Inline-C/
URL:=https://search.cpan.org/dist/Inline-C/
DEPENDS:=perl +perl-inline +perl-parse-recdescent +perlbase-config +perlbase-cwd +perlbase-data +perlbase-essential +perlbase-file +perlbase-if
endef


+ 1
- 1
lang/perl-inline-c/patches/100-inline_c-no_compile_hack.patch View File

@ -1,6 +1,6 @@
--- a/lib/Inline/C.pm
+++ b/lib/Inline/C.pm
@@ -361,7 +361,7 @@ sub build {
@@ -380,7 +380,7 @@ sub build {
$o->call('write_XS', 'Build Glue 1');
$o->call('write_Inline_headers', 'Build Glue 2');
$o->call('write_Makefile_PL', 'Build Glue 3');


+ 1
- 1
lang/perl-inline-c/patches/110-inline_c-make_system_typemap_overridable.patch View File

@ -1,6 +1,6 @@
--- a/lib/Inline/C.pm
+++ b/lib/Inline/C.pm
@@ -438,22 +438,28 @@ sub get_maps {
@@ -457,22 +457,28 @@ sub get_maps {
print STDERR "get_maps Stage\n" if $o->{CONFIG}{BUILD_NOISY};
my $typemap = '';
my $file;


+ 3
- 3
lang/perl-inline/Makefile View File

@ -8,15 +8,15 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=perl-inline
PKG_VERSION:=0.82
PKG_VERSION:=0.83
PKG_RELEASE:=1
PKG_SOURCE:=Inline-$(PKG_VERSION).tar.gz
PKG_SOURCE_URL:=https://cpan.metacpan.org/authors/id/T/TI/TINITA
PKG_HASH:=1af94a8e95e4ba4545592341c47d8d1dc45b01822b877f7d3095a438566e874b
PKG_HASH:=171a8e5f66faf88fe5ef4de7126267cd8fb2503483432eabc3b88ac7d5be4239
PKG_MAINTAINER:=Marcel Denia <naoir@gmx.net>
PKG_LICENSE:=GPL-1.0+ Artistic-1.0-Perl
PKG_LICENSE:=GPL-1.0-or-later Artistic-1.0-Perl
PKG_LICENSE_FILES:=LICENSE
PKG_BUILD_DIR:=$(BUILD_DIR)/perl/Inline-$(PKG_VERSION)


Loading…
Cancel
Save