perl-*: Import from oldpackages, update to latest upstream, fix, add myself as maintainerlilik-openwrt-22.03
@ -0,0 +1,48 @@ | |||
# | |||
# Copyright (C) 2014 OpenWrt.org | |||
# | |||
# This is free software, licensed under the GNU General Public License v2. | |||
# See /LICENSE for more information. | |||
# | |||
include $(TOPDIR)/rules.mk | |||
PKG_NAME:=perl-compress-bzip2 | |||
PKG_VERSION:=2.17 | |||
PKG_RELEASE:=1 | |||
PKG_SOURCE_URL:=http://www.cpan.org/authors/id/R/RU/RURBAN/ | |||
PKG_SOURCE:=Compress-Bzip2-$(PKG_VERSION).tar.gz | |||
PKG_MD5SUM:=d8b809f6efe3edb33f81d608c932b2ef | |||
PKG_LICENSE:=GPLv1+ ARTISTIC | |||
PKG_MAINTAINER:=Marcel Denia <naoir@gmx.net> | |||
PKG_BUILD_DIR:=$(BUILD_DIR)/perl/Compress-Bzip2-$(PKG_VERSION) | |||
include $(INCLUDE_DIR)/package.mk | |||
include ../perl/perlmod.mk | |||
define Package/perl-compress-bzip2 | |||
SUBMENU:=Perl | |||
SECTION:=lang | |||
CATEGORY:=Languages | |||
TITLE:=Perl interface to bzip2 compression library | |||
URL:=http://search.cpan.org/dist/Compress-Bzip2/ | |||
DEPENDS:=perl +libbz2 | |||
endef | |||
define Build/Configure | |||
$(call perlmod/Configure,,BUILD_BZLIB=0) | |||
endef | |||
define Build/Compile | |||
$(call perlmod/Compile,,) | |||
endef | |||
define Package/perl-compress-bzip2/install | |||
$(call perlmod/Install,$(1),Compress auto/Compress) | |||
endef | |||
$(eval $(call BuildPackage,perl-compress-bzip2)) |
@ -0,0 +1,48 @@ | |||
# | |||
# Copyright (C) 2014 OpenWrt.org | |||
# | |||
# This is free software, licensed under the GNU General Public License v2. | |||
# See /LICENSE for more information. | |||
# | |||
include $(TOPDIR)/rules.mk | |||
PKG_NAME:=perl-dbi | |||
PKG_VERSION:=1.631 | |||
PKG_RELEASE:=1 | |||
PKG_SOURCE_URL:=http://www.cpan.org/authors/id/T/TI/TIMB/ | |||
PKG_SOURCE:=DBI-$(PKG_VERSION).tar.gz | |||
PKG_MD5SUM:=444d3c305e86597e11092b517794a840 | |||
PKG_LICENSE:=GPLv1+ ARTISTIC | |||
PKG_MAINTAINER:=Marcel Denia <naoir@gmx.net> | |||
PKG_BUILD_DIR:=$(BUILD_DIR)/perl/DBI-$(PKG_VERSION) | |||
include $(INCLUDE_DIR)/package.mk | |||
include ../perl/perlmod.mk | |||
define Package/perl-dbi | |||
SUBMENU:=Perl | |||
SECTION:=lang | |||
CATEGORY:=Languages | |||
TITLE:=Database independent interface for Perl | |||
URL:=http://search.cpan.org/dist/DBI/ | |||
DEPENDS:=perl +perlbase-essential | |||
endef | |||
define Build/Configure | |||
$(call perlmod/Configure,,) | |||
endef | |||
define Build/Compile | |||
$(call perlmod/Compile,,) | |||
endef | |||
define Package/perl-dbi/install | |||
$(call perlmod/Install,$(1),DB* auto/DBI,DBI/W32ODBC.pm auto/DBI/*.h) | |||
endef | |||
$(eval $(call BuildPackage,perl-dbi)) |
@ -0,0 +1,48 @@ | |||
# | |||
# Copyright (C) 2014 OpenWrt.org | |||
# | |||
# This is free software, licensed under the GNU General Public License v2. | |||
# See /LICENSE for more information. | |||
# | |||
include $(TOPDIR)/rules.mk | |||
PKG_NAME:=perl-html-parser | |||
PKG_VERSION:=3.71 | |||
PKG_RELEASE:=1 | |||
PKG_SOURCE_URL:=http://www.cpan.org/authors/id/G/GA/GAAS/ | |||
PKG_SOURCE:=HTML-Parser-$(PKG_VERSION).tar.gz | |||
PKG_MD5SUM:=9128a45893097dfa3bf03301b19c5efe | |||
PKG_LICENSE:=GPLv1+ ARTISTIC | |||
PKG_MAINTAINER:=Marcel Denia <naoir@gmx.net> | |||
PKG_BUILD_DIR:=$(BUILD_DIR)/perl/HTML-Parser-$(PKG_VERSION) | |||
include $(INCLUDE_DIR)/package.mk | |||
include ../perl/perlmod.mk | |||
define Package/perl-html-parser | |||
SUBMENU:=Perl | |||
SECTION:=lang | |||
CATEGORY:=Languages | |||
TITLE:=A collection of modules that parse HTML text documents | |||
URL:=http://search.cpan.org/dist/HTML-Parser/ | |||
DEPENDS:=perl +perl-html-tagset +perl-uri | |||
endef | |||
define Build/Configure | |||
$(call perlmod/Configure,,) | |||
endef | |||
define Build/Compile | |||
$(call perlmod/Compile,,) | |||
endef | |||
define Package/perl-html-parser/install | |||
$(call perlmod/Install,$(1),HTML auto/HTML) | |||
endef | |||
$(eval $(call BuildPackage,perl-html-parser)) |
@ -0,0 +1,48 @@ | |||
# | |||
# Copyright (C) 2014 OpenWrt.org | |||
# | |||
# This is free software, licensed under the GNU General Public License v2. | |||
# See /LICENSE for more information. | |||
# | |||
include $(TOPDIR)/rules.mk | |||
PKG_NAME:=perl-html-tagset | |||
PKG_VERSION:=3.20 | |||
PKG_RELEASE:=1 | |||
PKG_SOURCE_URL:=http://www.cpan.org/authors/id/P/PE/PETDANCE/ | |||
PKG_SOURCE:=HTML-Tagset-$(PKG_VERSION).tar.gz | |||
PKG_MD5SUM:=d2bfa18fe1904df7f683e96611e87437 | |||
PKG_LICENSE:=GPLv1+ ARTISTIC | |||
PKG_MAINTAINER:=Marcel Denia <naoir@gmx.net> | |||
PKG_BUILD_DIR:=$(BUILD_DIR)/perl/HTML-Tagset-$(PKG_VERSION) | |||
include $(INCLUDE_DIR)/package.mk | |||
include ../perl/perlmod.mk | |||
define Package/perl-html-tagset | |||
SUBMENU:=Perl | |||
SECTION:=lang | |||
CATEGORY:=Languages | |||
TITLE:=Data tables pertaining to HTML | |||
URL:=http://search.cpan.org/dist/HTML-Tagset/ | |||
DEPENDS:=perl | |||
endef | |||
define Build/Configure | |||
$(call perlmod/Configure,,) | |||
endef | |||
define Build/Compile | |||
$(call perlmod/Compile,,) | |||
endef | |||
define Package/perl-html-tagset/install | |||
$(call perlmod/Install,$(1),HTML) | |||
endef | |||
$(eval $(call BuildPackage,perl-html-tagset)) |
@ -0,0 +1,49 @@ | |||
# | |||
# Copyright (C) 2014 OpenWrt.org | |||
# | |||
# This is free software, licensed under the GNU General Public License v2. | |||
# See /LICENSE for more information. | |||
# | |||
include $(TOPDIR)/rules.mk | |||
PKG_NAME:=perl-html-tree | |||
PKG_VERSION:=3.23 | |||
PKG_RELEASE:=2 | |||
PKG_MD5SUM:=6352f50be402301f79b580dd235d7762 | |||
PKG_SOURCE_URL:=http://www.cpan.org/authors/id/P/PE/PETEK/ | |||
PKG_SOURCE:=HTML-Tree-$(PKG_VERSION).tar.gz | |||
PKG_MD5SUM:=6352f50be402301f79b580dd235d7762 | |||
PKG_LICENSE:=GPLv1+ ARTISTIC | |||
PKG_MAINTAINER:=Marcel Denia <naoir@gmx.net> | |||
PKG_BUILD_DIR:=$(BUILD_DIR)/perl/HTML-Tree-$(PKG_VERSION) | |||
include $(INCLUDE_DIR)/package.mk | |||
include ../perl/perlmod.mk | |||
define Package/perl-html-tree | |||
SUBMENU:=Perl | |||
SECTION:=lang | |||
CATEGORY:=Languages | |||
TITLE:=represent and create HTML syntax trees | |||
URL:=http://search.cpan.org/dist/HTML-Tree/ | |||
DEPENDS:=perl +perl-html-parser +perl-html-tagset | |||
endef | |||
define Build/Configure | |||
$(call perlmod/Configure,,) | |||
endef | |||
define Build/Compile | |||
$(call perlmod/Compile,,) | |||
endef | |||
define Package/perl-html-tree/install | |||
$(call perlmod/Install,$(1),HTML) | |||
endef | |||
$(eval $(call BuildPackage,perl-html-tree)) |
@ -0,0 +1,48 @@ | |||
# | |||
# Copyright (C) 2014 OpenWrt.org | |||
# | |||
# This is free software, licensed under the GNU General Public License v2. | |||
# See /LICENSE for more information. | |||
# | |||
include $(TOPDIR)/rules.mk | |||
PKG_NAME:=perl-lockfile-simple | |||
PKG_VERSION:=0.208 | |||
PKG_RELEASE:=1 | |||
PKG_SOURCE_URL:=http://www.cpan.org/authors/id/S/SC/SCHWIGON/lockfile-simple/ | |||
PKG_SOURCE:=LockFile-Simple-$(PKG_VERSION).tar.gz | |||
PKG_MD5SUM:=4421283b4f32549e5299963734170044 | |||
PKG_LICENSE:=GPLv2+ ARTISTIC | |||
PKG_MAINTAINER:=Marcel Denia <naoir@gmx.net> | |||
PKG_BUILD_DIR:=$(BUILD_DIR)/perl/LockFile-Simple-$(PKG_VERSION) | |||
include $(INCLUDE_DIR)/package.mk | |||
include ../perl/perlmod.mk | |||
define Package/perl-lockfile-simple | |||
SUBMENU:=Perl | |||
SECTION:=lang | |||
CATEGORY:=Languages | |||
TITLE:=Simple advisory file locking | |||
URL:=http://search.cpan.org/dist/LockFile-Simple/ | |||
DEPENDS:=perl | |||
endef | |||
define Build/Configure | |||
$(call perlmod/Configure,,) | |||
endef | |||
define Build/Compile | |||
$(call perlmod/Compile,,) | |||
endef | |||
define Package/perl-lockfile-simple/install | |||
$(call perlmod/Install,$(1),LockFile auto/LockFile) | |||
endef | |||
$(eval $(call BuildPackage,perl-lockfile-simple)) |
@ -0,0 +1,48 @@ | |||
# | |||
# Copyright (C) 2011-2014 OpenWrt.org | |||
# | |||
# This is free software, licensed under the GNU General Public License v2. | |||
# See /LICENSE for more information. | |||
# | |||
include $(TOPDIR)/rules.mk | |||
PKG_NAME:=perl-net-telnet | |||
PKG_VERSION:=3.04 | |||
PKG_RELEASE:=1 | |||
PKG_SOURCE_URL:=http://www.cpan.org/authors/id/J/JR/JROGERS/ | |||
PKG_SOURCE:=Net-Telnet-$(PKG_VERSION).tar.gz | |||
PKG_MD5SUM:=d2514080116c1b0fa5f96295c84538e3 | |||
PKG_LICENSE:=GPLv1+ ARTISTIC | |||
PKG_MAINTAINER:=Marcel Denia <naoir@gmx.net> | |||
PKG_BUILD_DIR:=$(BUILD_DIR)/perl/Net-Telnet-$(PKG_VERSION) | |||
include $(INCLUDE_DIR)/package.mk | |||
include ../perl/perlmod.mk | |||
define Package/perl-net-telnet | |||
SUBMENU:=Perl | |||
SECTION:=lang | |||
CATEGORY:=Languages | |||
TITLE:=Telnet client | |||
URL:=http://search.cpan.org/dist/Net-Telnet/ | |||
DEPENDS:=perl | |||
endef | |||
define Build/Configure | |||
$(call perlmod/Configure,,) | |||
endef | |||
define Build/Compile | |||
$(call perlmod/Compile,,) | |||
endef | |||
define Package/perl-net-telnet/install | |||
$(call perlmod/Install,$(1),Net auto/Net) | |||
endef | |||
$(eval $(call BuildPackage,perl-net-telnet)) |
@ -0,0 +1,48 @@ | |||
# | |||
# Copyright (C) 2014 OpenWrt.org | |||
# | |||
# This is free software, licensed under the GNU General Public License v2. | |||
# See /LICENSE for more information. | |||
# | |||
include $(TOPDIR)/rules.mk | |||
PKG_NAME:=perl-test-harness | |||
PKG_VERSION:=3.32 | |||
PKG_RELEASE:=1 | |||
PKG_SOURCE_URL:=http://www.cpan.org/authors/id/L/LE/LEONT/ | |||
PKG_SOURCE:=Test-Harness-$(PKG_VERSION).tar.gz | |||
PKG_MD5SUM:=a1241b628dc80f5271ed9235c211e55c | |||
PKG_LICENSE:=GPLv1+ ARTISTIC | |||
PKG_MAINTAINER:=Marcel Denia <naoir@gmx.net> | |||
PKG_BUILD_DIR:=$(BUILD_DIR)/perl/Test-Harness-$(PKG_VERSION) | |||
include $(INCLUDE_DIR)/package.mk | |||
include ../perl/perlmod.mk | |||
define Package/perl-test-harness | |||
SUBMENU:=Perl | |||
SECTION:=lang | |||
CATEGORY:=Languages | |||
TITLE:=Perl Test Harness | |||
URL:=http://search.cpan.org/dist/Test-Harness/ | |||
DEPENDS:=perl | |||
endef | |||
define Build/Configure | |||
$(call perlmod/Configure,,) | |||
endef | |||
define Build/Compile | |||
$(call perlmod/Compile,,) | |||
endef | |||
define Package/perl-test-harness/install | |||
$(call perlmod/Install,$(1),App auto/Test TAP Test) | |||
endef | |||
$(eval $(call BuildPackage,perl-test-harness)) |
@ -0,0 +1,48 @@ | |||
# | |||
# Copyright (C) 2014 OpenWrt.org | |||
# | |||
# This is free software, licensed under the GNU General Public License v2. | |||
# See /LICENSE for more information. | |||
# | |||
include $(TOPDIR)/rules.mk | |||
PKG_NAME:=perl-uri | |||
PKG_VERSION:=1.64 | |||
PKG_RELEASE:=1 | |||
PKG_SOURCE_URL:=http://www.cpan.org/authors/id/E/ET/ETHER/ | |||
PKG_SOURCE:=URI-$(PKG_VERSION).tar.gz | |||
PKG_MD5SUM:=975b2282bc8f0fd72a6dae5cefc33824 | |||
PKG_LICENSE:=GPLv1+ ARTISTIC | |||
PKG_MAINTAINER:=Marcel Denia <naoir@gmx.net> | |||
PKG_BUILD_DIR:=$(BUILD_DIR)/perl/URI-$(PKG_VERSION) | |||
include $(INCLUDE_DIR)/package.mk | |||
include ../perl/perlmod.mk | |||
define Package/perl-uri | |||
SUBMENU:=Perl | |||
SECTION:=lang | |||
CATEGORY:=Languages | |||
TITLE:=Manipulates and accesses URI strings | |||
URL:=http://search.cpan.org/dist/URI/ | |||
DEPENDS:=perl | |||
endef | |||
define Build/Configure | |||
$(call perlmod/Configure,,) | |||
endef | |||
define Build/Compile | |||
$(call perlmod/Compile,,) | |||
endef | |||
define Package/perl-uri/install | |||
$(call perlmod/Install,$(1),URI URI.pm) | |||
endef | |||
$(eval $(call BuildPackage,perl-uri)) |
@ -0,0 +1,49 @@ | |||
# | |||
# Copyright (C) 2014 OpenWrt.org | |||
# | |||
# This is free software, licensed under the GNU General Public License v2. | |||
# See /LICENSE for more information. | |||
# | |||
include $(TOPDIR)/rules.mk | |||
PKG_NAME:=perl-www-curl | |||
PKG_VERSION:=4.17 | |||
PKG_RELEASE:=1 | |||
PKG_SOURCE_URL:=http://www.cpan.org/authors/id/S/SZ/SZBALINT/ | |||
PKG_SOURCE:=WWW-Curl-$(PKG_VERSION).tar.gz | |||
PKG_MD5SUM:=997ac81cd6b03b30b36f7cd930474845 | |||
PKG_LICENSE:=GPLv1+ ARTISTIC | |||
PKG_LICENSE_FILES:=LICENSE | |||
PKG_MAINTAINER:=Marcel Denia <naoir@gmx.net> | |||
PKG_BUILD_DIR:=$(BUILD_DIR)/perl/WWW-Curl-$(PKG_VERSION) | |||
include $(INCLUDE_DIR)/package.mk | |||
include ../perl/perlmod.mk | |||
define Package/perl-www-curl | |||
SUBMENU:=Perl | |||
SECTION:=lang | |||
CATEGORY:=Languages | |||
TITLE:=Perl bindings to libcurl | |||
URL:=http://search.cpan.org/dist/WWW-Curl/ | |||
DEPENDS:=perl +libcurl | |||
endef | |||
define Build/Configure | |||
$(call perlmod/Configure,$(STAGING_DIR)/usr/include,) | |||
endef | |||
define Build/Compile | |||
$(call perlmod/Compile,,) | |||
endef | |||
define Package/perl-www-curl/install | |||
$(call perlmod/Install,$(1),WWW/Curl WWW/Curl.pm auto/WWW/Curl) | |||
endef | |||
$(eval $(call BuildPackage,perl-www-curl)) |
@ -0,0 +1,74 @@ | |||
--- a/Makefile.PL | |||
+++ b/Makefile.PL | |||
@@ -12,31 +12,31 @@ no_index directory => 'template'; | |||
repository 'http://github.com/szbalint/WWW--Curl'; | |||
# This is a hack. If you have libcurl installed, just specify curl.h below | |||
# and comment out this line. | |||
-if ($^O ne 'MSWin32') { | |||
- if (!$ENV{CURL_CONFIG}) { | |||
- requires_external_bin 'curl-config'; | |||
- } | |||
-} else { | |||
- print "Sorry, no automated install is available on Windows,\n". | |||
- "please see the README.Win32 file on instructions for a manual install.\n"; | |||
- exit(0); | |||
-} | |||
- | |||
-my $curl_config = $ENV{CURL_CONFIG} || 'curl-config'; | |||
- | |||
-my $vernum = `${curl_config} --vernum`; chomp $vernum; | |||
-my $version = `${curl_config} --version`; chomp $version; | |||
- | |||
-my $minimum_ver = hex("070a08"); | |||
- | |||
-if ($vernum && hex($vernum) <= $minimum_ver) { | |||
- print "Your currently installed libcurl version - $version - is too old.\n". | |||
- "This module doesn't seek compatibility with versions older than 7.10.8\n". | |||
- "Proceed manually if you know what you're doing.\n"; | |||
- exit(0); | |||
-} | |||
- | |||
-print "The version is $version\n"; | |||
+#if ($^O ne 'MSWin32') { | |||
+# if (!$ENV{CURL_CONFIG}) { | |||
+# requires_external_bin 'curl-config'; | |||
+# } | |||
+#} else { | |||
+# print "Sorry, no automated install is available on Windows,\n". | |||
+# "please see the README.Win32 file on instructions for a manual install.\n"; | |||
+# exit(0); | |||
+#} | |||
+# | |||
+#my $curl_config = $ENV{CURL_CONFIG} || 'curl-config'; | |||
+# | |||
+#my $vernum = `${curl_config} --vernum`; chomp $vernum; | |||
+#my $version = `${curl_config} --version`; chomp $version; | |||
+# | |||
+#my $minimum_ver = hex("070a08"); | |||
+# | |||
+#if ($vernum && hex($vernum) <= $minimum_ver) { | |||
+# print "Your currently installed libcurl version - $version - is too old.\n". | |||
+# "This module doesn't seek compatibility with versions older than 7.10.8\n". | |||
+# "Proceed manually if you know what you're doing.\n"; | |||
+# exit(0); | |||
+#} | |||
+# | |||
+#print "The version is $version\n"; | |||
my @includes = qw(); | |||
my ($cflags,$lflags, $ldflags) = ('','',''); | |||
@@ -58,10 +58,10 @@ if ($^O ne 'MSWin32') { | |||
# Get curl to tell us where it is, if we can. | |||
# | |||
-if ($^O ne 'MSWin32') { | |||
- $cflags = `${curl_config} --cflags`; | |||
- $lflags = `${curl_config} --libs`; | |||
-} | |||
+#if ($^O ne 'MSWin32') { | |||
+# $cflags = `${curl_config} --cflags`; | |||
+# $lflags = `${curl_config} --libs`; | |||
+#} | |||
# can't find link flags, make some guesses | |||
if (!defined($lflags)) { |
@ -0,0 +1,11 @@ | |||
--- a/Makefile.PL | |||
+++ b/Makefile.PL | |||
@@ -39,7 +39,7 @@ repository 'http://github.com/szbalint/ | |||
#print "The version is $version\n"; | |||
my @includes = qw(); | |||
-my ($cflags,$lflags, $ldflags) = ('','',''); | |||
+my ($cflags,$lflags, $ldflags) = ('','-lcurl',''); | |||
# You may need to specify where to find curl.h on your platform | |||
# These are guesses only, in case curl-config is not telling us. |
@ -0,0 +1,48 @@ | |||
# | |||
# Copyright (C) 2010-2014 OpenWrt.org | |||
# | |||
# This is free software, licensed under the GNU General Public License v2. | |||
# See /LICENSE for more information. | |||
# | |||
include $(TOPDIR)/rules.mk | |||
PKG_NAME:=perl-www-mechanize | |||
PKG_VERSION:=1.73 | |||
PKG_RELEASE:=1 | |||
PKG_SOURCE:=WWW-Mechanize-$(PKG_VERSION).tar.gz | |||
PKG_SOURCE_URL:=http://www.cpan.org/authors/id/E/ET/ETHER/ | |||
PKG_MD5SUM:=de0a9c528c12793c881151301bc14d1a | |||
PKG_LICENSE:=GPLv1+ ARTISTIC | |||
PKG_MAINTAINER:=Marcel Denia <naoir@gmx.net> | |||
PKG_BUILD_DIR:=$(BUILD_DIR)/perl/WWW-Mechanize-$(PKG_VERSION) | |||
include $(INCLUDE_DIR)/package.mk | |||
include ../perl/perlmod.mk | |||
define Package/perl-www-mechanize | |||
SUBMENU:=Perl | |||
SECTION:=lang | |||
CATEGORY:=Languages | |||
TITLE:=Perl WWW Mechanize | |||
URL:=http://search.cpan.org/dist/WWW-Mechanize/ | |||
DEPENDS:=perl +perl-www | |||
endef | |||
define Build/Configure | |||
$(call perlmod/Configure,$(STAGING_DIR)/usr/include,) | |||
endef | |||
define Build/Compile | |||
$(call perlmod/Compile,,) | |||
endef | |||
define Package/perl-www-mechanize/install | |||
$(call perlmod/Install,$(1),WWW/Mechanize WWW/Mechanize.pm) | |||
endef | |||
$(eval $(call BuildPackage,perl-www-mechanize)) |
@ -0,0 +1,48 @@ | |||
# | |||
# Copyright (C) 2013-2014 OpenWrt.org | |||
# | |||
# This is free software, licensed under the GNU General Public License v2. | |||
# See /LICENSE for more information. | |||
# | |||
include $(TOPDIR)/rules.mk | |||
PKG_NAME:=perl-www | |||
PKG_VERSION:=5.837 | |||
PKG_RELEASE:=1 | |||
PKG_SOURCE_URL:=http://www.cpan.org/authors/id/G/GA/GAAS/ | |||
PKG_SOURCE:=libwww-perl-$(PKG_VERSION).tar.gz | |||
PKG_MD5SUM:=9bbf1bce482b0bac98bb4f04253c03d0 | |||
PKG_LICENSE:=GPLv1+ ARTISTIC | |||
PKG_MAINTAINER:=Marcel Denia <naoir@gmx.net> | |||
PKG_BUILD_DIR:=$(BUILD_DIR)/perl/libwww-perl-$(PKG_VERSION) | |||
include $(INCLUDE_DIR)/package.mk | |||
include ../perl/perlmod.mk | |||
define Package/perl-www | |||
SUBMENU:=Perl | |||
SECTION:=lang | |||
CATEGORY:=Languages | |||
TITLE:=WWW client/server library for Perl (aka LWP) | |||
URL:=http://search.cpan.org/dist/libwww-perl/ | |||
DEPENDS:=perl +perl-html-parser +perl-html-tagset +perl-uri | |||
endef | |||
define Build/Configure | |||
$(call perlmod/Configure,-n,) | |||
endef | |||
define Build/Compile | |||
$(call perlmod/Compile,,) | |||
endef | |||
define Package/perl-www/install | |||
$(call perlmod/Install,$(1),File HTML HTTP LWP LWP.pm Net WWW) | |||
endef | |||
$(eval $(call BuildPackage,perl-www)) |