Browse Source

open-isns: fix compilation without deprecated signal API

Upstream backport.

Signed-off-by: Rosen Penev <rosenp@gmail.com>
lilik-openwrt-22.03
Rosen Penev 4 years ago
parent
commit
40b71e324b
No known key found for this signature in database GPG Key ID: 36D31CFA845F0E3B
2 changed files with 42 additions and 1 deletions
  1. +1
    -1
      net/open-isns/Makefile
  2. +41
    -0
      net/open-isns/patches/20-signals.patch

+ 1
- 1
net/open-isns/Makefile View File

@ -5,7 +5,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=open-isns
PKG_VERSION:=0.100
PKG_RELEASE:=1
PKG_RELEASE:=2
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
PKG_SOURCE_URL:=https://codeload.github.com/open-iscsi/open-isns/tar.gz/v$(PKG_VERSION)?


+ 41
- 0
net/open-isns/patches/20-signals.patch View File

@ -0,0 +1,41 @@
From e7dac76ce61039fefa58985c955afccb60dabe87 Mon Sep 17 00:00:00 2001
From: Rosen Penev <rosenp@gmail.com>
Date: Wed, 29 Apr 2020 15:55:55 -0700
Subject: [PATCH] libisns: remove sighold and sigrelse
The man page says that these are deprecated. Use sugprocmask as a replacement.
---
include/libisns/util.h | 16 ++++++++++++----
1 file changed, 12 insertions(+), 4 deletions(-)
diff --git a/include/libisns/util.h b/include/libisns/util.h
index e5ed037..f1b97f0 100644
--- a/include/libisns/util.h
+++ b/include/libisns/util.h
@@ -41,14 +41,22 @@ char * print_size(unsigned long);
*/
static inline void signals_hold(void)
{
- sighold(SIGTERM);
- sighold(SIGINT);
+ sigset_t s;
+
+ sigemptyset(&s);
+ sigaddset(&s, SIGTERM);
+ sigaddset(&s, SIGINT);
+ sigprocmask(SIG_BLOCK, &s, 0);
}
static inline void signals_release(void)
{
- sigrelse(SIGTERM);
- sigrelse(SIGINT);
+ sigset_t s;
+
+ sigemptyset(&s);
+ sigaddset(&s, SIGTERM);
+ sigaddset(&s, SIGINT);
+ sigprocmask(SIG_UNBLOCK, &s, 0);
}
/*

Loading…
Cancel
Save