Browse Source

Merge pull request #9843 from cshoredaniel/pr-fix-uwsgi-cgi-python

uwsgi-cgi: use python3 hostpkg not system python3
lilik-openwrt-22.03
Rosen Penev 5 years ago
committed by GitHub
parent
commit
3ebb643494
No known key found for this signature in database GPG Key ID: 4AEE18F83AFDEB23
2 changed files with 14 additions and 1 deletions
  1. +4
    -1
      net/uwsgi-cgi/Makefile
  2. +10
    -0
      net/uwsgi-cgi/patches/020-uwsgiconfig-system-python3.patch

+ 4
- 1
net/uwsgi-cgi/Makefile View File

@ -15,6 +15,8 @@ PKG_LICENSE:=GPL-2.0-or-later
PKG_LICENSE_FILES:=LICENSE
PKG_MAINTAINER:=Ansuel Smith <ansuelsmth@gmail.com>
PKG_BUILD_DEPENDS:=python3/host
include $(INCLUDE_DIR)/package.mk
define Package/uwsgi-cgi
@ -39,7 +41,8 @@ define Package/uwsgi-cgi/description
endef
MAKE_VARS+=\
CPP=$(TARGET_CROSS)cpp
CPP=$(TARGET_CROSS)cpp \
PYTHON=$(STAGING_DIR_HOSTPKG)/bin/python3
define Build/Compile
$(call Build/Compile/Default,PROFILE=cgi)


+ 10
- 0
net/uwsgi-cgi/patches/020-uwsgiconfig-system-python3.patch View File

@ -0,0 +1,10 @@
Index: uwsgi-2.0.18/Makefile
===================================================================
--- uwsgi-2.0.18.orig/Makefile
+++ uwsgi-2.0.18/Makefile
@@ -1,4 +1,4 @@
-PYTHON := python
+PYTHON ?= python3
all:
$(PYTHON) uwsgiconfig.py --build $(PROFILE)

Loading…
Cancel
Save