Browse Source
Merge pull request #13204 from nxhack/upm_node_v12
libupm: support node.js v12
lilik-openwrt-22.03
Rosen Penev
4 years ago
committed by
GitHub
No known key found for this signature in database
GPG Key ID: 4AEE18F83AFDEB23
2 changed files with
12 additions and
1 deletions
-
libs/libupm/Makefile
-
libs/libupm/patches/005-support_v12.patch
|
|
@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk |
|
|
|
|
|
|
|
PKG_NAME:=libupm |
|
|
|
PKG_VERSION:=2.0.0 |
|
|
|
PKG_RELEASE:=1 |
|
|
|
PKG_RELEASE:=2 |
|
|
|
|
|
|
|
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz |
|
|
|
PKG_SOURCE_URL:=https://codeload.github.com/intel-iot-devkit/upm/tar.gz/v$(PKG_VERSION)? |
|
|
|
|
|
@ -0,0 +1,11 @@ |
|
|
|
--- a/src/carrays_uint32_t.i
|
|
|
|
+++ b/src/carrays_uint32_t.i
|
|
|
|
@@ -24,7 +24,7 @@
|
|
|
|
%typemap(in) uint32_t { |
|
|
|
int ecode2 = 0 ; |
|
|
|
if (($input)->IsInt32()) |
|
|
|
- $1 = ($input)->Uint32Value();
|
|
|
|
+ $1 = ($input)->Uint32Value(SWIGV8_CURRENT_CONTEXT()).FromJust();
|
|
|
|
else |
|
|
|
SWIG_exception_fail(SWIG_ArgError(ecode2), "failed to convert uint32"); |
|
|
|
} |