Remove getline patch. It seems to be for uClibc, which is no longer in the tree. Remove commands patch. Issue was fixed upstream. Same with the tests patch. Remove gpg patch. It's an upstream backport. Refreshed others. Signed-off-by: Rosen Penev <rosenp@gmail.com>lilik-openwrt-22.03
@ -1,15 +0,0 @@ | |||||
--- a/src/lxc/utils.h | |||||
+++ b/src/lxc/utils.h | |||||
@@ -36,11 +36,7 @@ __hidden extern int mkdir_p(const char * | |||||
__hidden extern char *get_rundir(void); | |||||
/* Define getline() if missing from the C library */ | |||||
-#ifndef HAVE_GETLINE | |||||
-#ifdef HAVE_FGETLN | |||||
-#include <../include/getline.h> | |||||
-#endif | |||||
-#endif | |||||
+#include "../include/getline.h" | |||||
static inline int lxc_set_cloexec(int fd) | |||||
{ |
@ -1,34 +0,0 @@ | |||||
From a342b11fedb3010630de4909ca707ebdc0862060 Mon Sep 17 00:00:00 2001 | |||||
From: Eneas U de Queiroz <cotequeiroz@gmail.com> | |||||
Date: Fri, 25 Dec 2020 13:54:14 -0300 | |||||
Subject: [PATCH 1/2] commands: fix check for seccomp notify support | |||||
Use HAVE_SECCOMP_NOTIFY instead of HAVE_DECL_SECCOMP_NOTIFY_FD. | |||||
Currently the latter will be true if the declaration is found by | |||||
configure, even if 'configure --disable-seccomp' is used. | |||||
HAVE_SECCOMP_NOTIFY is defined in lxcseccomp.h if both HAVE_SECCOMP and | |||||
HAVE_DECL_SECCOMP_NOTIFY_FD are true, which is the correct behavior. | |||||
Signed-off-by: Eneas U de Queiroz <cotequeiroz@gmail.com> | |||||
--- a/src/lxc/commands.c | |||||
+++ b/src/lxc/commands.c | |||||
@@ -498,7 +498,7 @@ static int lxc_cmd_get_devpts_fd_callbac | |||||
int lxc_cmd_get_seccomp_notify_fd(const char *name, const char *lxcpath) | |||||
{ | |||||
-#if HAVE_DECL_SECCOMP_NOTIFY_FD | |||||
+#ifdef HAVE_SECCOMP_NOTIFY | |||||
int ret, stopped; | |||||
struct lxc_cmd_rr cmd = { | |||||
.req = { | |||||
@@ -523,7 +523,7 @@ static int lxc_cmd_get_seccomp_notify_fd | |||||
struct lxc_handler *handler, | |||||
struct lxc_epoll_descr *descr) | |||||
{ | |||||
-#if HAVE_DECL_SECCOMP_NOTIFY_FD | |||||
+#ifdef HAVE_SECCOMP_NOTIFY | |||||
struct lxc_cmd_rsp rsp = { | |||||
.ret = 0, | |||||
}; |
@ -1,43 +0,0 @@ | |||||
From 67cd8bde2d46983df8fa9f647e9fc0b96370ec29 Mon Sep 17 00:00:00 2001 | |||||
From: Eneas U de Queiroz <cotequeiroz@gmail.com> | |||||
Date: Sat, 16 Jan 2021 13:54:07 -0300 | |||||
Subject: [PATCH 2/2] configure: skip libseccomp tests if it is disabled | |||||
Move the block checking for libseccomp api compatibility inside | |||||
AM_COND_IF([ENABLE_SECCOMP] ... ). | |||||
Signed-off-by: Eneas U de Queiroz <cotequeiroz@gmail.com> | |||||
--- a/configure.ac | |||||
+++ b/configure.ac | |||||
@@ -284,6 +284,14 @@ AM_COND_IF([ENABLE_SECCOMP], | |||||
AC_CHECK_LIB([seccomp], [seccomp_init],[],[AC_MSG_ERROR([You must install the seccomp development package in order to compile lxc])]) | |||||
AC_SUBST([SECCOMP_LIBS], [-lseccomp]) | |||||
]) | |||||
+ # HAVE_SCMP_FILTER_CTX=1 will tell us we have libseccomp api >= 1.0.0 | |||||
+ OLD_CFLAGS="$CFLAGS" | |||||
+ CFLAGS="$CFLAGS $SECCOMP_CFLAGS" | |||||
+ AC_CHECK_TYPES([scmp_filter_ctx], [], [], [[#include <seccomp.h>]]) | |||||
+ AC_CHECK_DECLS([seccomp_notify_fd], [], [], [[#include <seccomp.h>]]) | |||||
+ AC_CHECK_TYPES([struct seccomp_notif_sizes], [], [], [[#include <seccomp.h>]]) | |||||
+ AC_CHECK_DECLS([seccomp_syscall_resolve_name_arch], [], [], [[#include <seccomp.h>]]) | |||||
+ CFLAGS="$OLD_CFLAGS" | |||||
]) | |||||
AC_MSG_CHECKING(for static libcap) | |||||
@@ -331,15 +339,6 @@ AM_COND_IF([ENABLE_CAP], | |||||
AC_CHECK_LIB(cap,cap_get_file, AC_DEFINE(LIBCAP_SUPPORTS_FILE_CAPABILITIES,1,[Have cap_get_file]),[],[]) | |||||
AC_SUBST([CAP_LIBS], [-lcap])]) | |||||
-# HAVE_SCMP_FILTER_CTX=1 will tell us we have libseccomp api >= 1.0.0 | |||||
-OLD_CFLAGS="$CFLAGS" | |||||
-CFLAGS="$CFLAGS $SECCOMP_CFLAGS" | |||||
-AC_CHECK_TYPES([scmp_filter_ctx], [], [], [[#include <seccomp.h>]]) | |||||
-AC_CHECK_DECLS([seccomp_notify_fd], [], [], [[#include <seccomp.h>]]) | |||||
-AC_CHECK_TYPES([struct seccomp_notif_sizes], [], [], [[#include <seccomp.h>]]) | |||||
-AC_CHECK_DECLS([seccomp_syscall_resolve_name_arch], [], [], [[#include <seccomp.h>]]) | |||||
-CFLAGS="$OLD_CFLAGS" | |||||
- | |||||
AC_CHECK_HEADERS([linux/bpf.h], [ | |||||
AC_CHECK_TYPES([struct bpf_cgroup_dev_ctx], [], [], [[#include <linux/bpf.h>]]) | |||||
], [], []) |
@ -1,29 +0,0 @@ | |||||
From 3efa0cf3455cbe330b4e79a647a57ad8e9cf3476 Mon Sep 17 00:00:00 2001 | |||||
From: =?UTF-8?q?St=C3=A9phane=20Graber?= <stgraber@ubuntu.com> | |||||
Date: Sun, 27 Jun 2021 23:42:52 -0400 | |||||
Subject: [PATCH] lxc-download: Switch GPG server | |||||
MIME-Version: 1.0 | |||||
Content-Type: text/plain; charset=UTF-8 | |||||
Content-Transfer-Encoding: 8bit | |||||
Signed-off-by: Stéphane Graber <stgraber@ubuntu.com> | |||||
--- | |||||
templates/lxc-download.in | 4 ++-- | |||||
1 file changed, 2 insertions(+), 2 deletions(-) | |||||
--- a/templates/lxc-download.in | |||||
+++ b/templates/lxc-download.in | |||||
@@ -55,11 +55,11 @@ LXC_PATH= | |||||
LXC_ROOTFS= | |||||
if [ -z "${DOWNLOAD_KEYSERVER:-}" ]; then | |||||
- DOWNLOAD_KEYSERVER="hkp://pool.sks-keyservers.net" | |||||
+ DOWNLOAD_KEYSERVER="hkp://keyserver.ubuntu.com" | |||||
# Deal with GPG over http proxy | |||||
if [ -n "${http_proxy:-}" ]; then | |||||
- DOWNLOAD_KEYSERVER="hkp://p80.pool.sks-keyservers.net:80" | |||||
+ DOWNLOAD_KEYSERVER="hkp://keyserver.ubuntu.com:80" | |||||
DOWNLOAD_GPG_PROXY="--keyserver-options http-proxy=\"${http_proxy}\"" | |||||
fi | |||||
fi |