Browse Source

atop: fix build error

Some Makefile targets did not honor CFLAGS.
This can lead to a SIGSEGV atop exeuctable.

Signed-off-by: Toni Uhlig <matzeton@googlemail.com>
lilik-openwrt-22.03
Toni Uhlig 6 years ago
parent
commit
3cdf09f705
No known key found for this signature in database GPG Key ID: 22C5333D922537D2
1 changed files with 22 additions and 0 deletions
  1. +22
    -0
      admin/atop/patches/010-makefile-missing-cflags.patch

+ 22
- 0
admin/atop/patches/010-makefile-missing-cflags.patch View File

@ -0,0 +1,22 @@
diff --git a/Makefile b/Makefile
index 3bf5929..e065577 100644
--- a/Makefile
+++ b/Makefile
@@ -32,7 +32,7 @@ VERS = $(shell ./atop -V 2>/dev/null| sed -e 's/^[^ ]* //' -e 's/ .*//')
all: atop atopsar atopacctd atopconvert
atop: atop.o $(ALLMODS) Makefile
- $(CC) -c version.c
+ $(CC) $(CFLAGS) -c version.c
$(CC) atop.o $(ALLMODS) -o atop -lncurses -lz -lm -lrt $(LDFLAGS)
atopsar: atop
@@ -45,7 +45,7 @@ atopconvert: atopconvert.o
$(CC) atopconvert.o -o atopconvert -lz $(LDFLAGS)
netlink.o: netlink.c
- $(CC) -I. -Wall -c netlink.c
+ $(CC) $(CFLAGS) -I. -Wall -c netlink.c
clean:
rm -f *.o atop atopacctd atopconvert

Loading…
Cancel
Save