Browse Source
mosh: Fix compilation with libcxx
Partial backport of upstream patch.``
Signed-off-by: Rosen Penev <rosenp@gmail.com>
lilik-openwrt-22.03
Rosen Penev
5 years ago
No known key found for this signature in database
GPG Key ID: 36D31CFA845F0E3B
2 changed files with
11 additions and
1 deletions
-
net/mosh/Makefile
-
net/mosh/patches/020-std.patch
|
@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk |
|
|
|
|
|
|
|
|
PKG_NAME:=mosh |
|
|
PKG_NAME:=mosh |
|
|
PKG_VERSION:=1.3.2 |
|
|
PKG_VERSION:=1.3.2 |
|
|
PKG_RELEASE:=1 |
|
|
|
|
|
|
|
|
PKG_RELEASE:=2 |
|
|
|
|
|
|
|
|
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz |
|
|
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz |
|
|
PKG_SOURCE_URL:=https://mosh.org/ |
|
|
PKG_SOURCE_URL:=https://mosh.org/ |
|
|
|
@ -0,0 +1,10 @@ |
|
|
|
|
|
--- a/src/network/network.cc
|
|
|
|
|
|
+++ b/src/network/network.cc
|
|
|
|
|
|
@@ -60,7 +60,6 @@
|
|
|
|
|
|
#define AI_NUMERICSERV 0 |
|
|
|
|
|
#endif |
|
|
|
|
|
|
|
|
|
|
|
-using namespace std;
|
|
|
|
|
|
using namespace Network; |
|
|
|
|
|
using namespace Crypto; |
|
|
|
|
|
|