Browse Source

Merge pull request #8645 from sartura/protobuf-c-x86-build-fail-fix

protobuf-c: fix x86 build fail
lilik-openwrt-22.03
Rosen Penev 5 years ago
committed by GitHub
parent
commit
3bd227ab21
No known key found for this signature in database GPG Key ID: 4AEE18F83AFDEB23
2 changed files with 14 additions and 1 deletions
  1. +1
    -1
      libs/protobuf-c/Makefile
  2. +13
    -0
      libs/protobuf-c/patches/001-t-generated-code2-cxx-generate-packed-data-fix.patch

+ 1
- 1
libs/protobuf-c/Makefile View File

@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=libprotobuf-c
PKG_VERSION:=1.3.1
PKG_RELEASE:=1
PKG_RELEASE:=2
PKG_SOURCE:=protobuf-c-$(PKG_VERSION).tar.gz
PKG_SOURCE_URL:=https://github.com/protobuf-c/protobuf-c/releases/download/v$(PKG_VERSION)


+ 13
- 0
libs/protobuf-c/patches/001-t-generated-code2-cxx-generate-packed-data-fix.patch View File

@ -0,0 +1,13 @@
Index: protobuf-c-1.3.1/t/generated-code2/cxx-generate-packed-data.cc
===================================================================
--- protobuf-c-1.3.1.orig/t/generated-code2/cxx-generate-packed-data.cc
+++ protobuf-c-1.3.1/t/generated-code2/cxx-generate-packed-data.cc
@@ -998,7 +998,7 @@ static void dump_test_packed_repeated_en
static void dump_test_unknown_fields (void)
{
EmptyMess mess;
- const google::protobuf::Message::Reflection *reflection = mess.GetReflection();
+ const google::protobuf::Reflection *reflection = mess.GetReflection();
google::protobuf::UnknownFieldSet *fs = reflection->MutableUnknownFields(&mess);
#if GOOGLE_PROTOBUF_VERSION >= 2001000

Loading…
Cancel
Save