Browse Source

Merge pull request #7531 from neheb/loud

loudmouth: Disable debug and fix no deprecated API compilation
lilik-openwrt-22.03
Hannu Nyman 6 years ago
committed by GitHub
parent
commit
3aa4a11ba4
No known key found for this signature in database GPG Key ID: 4AEE18F83AFDEB23
2 changed files with 20 additions and 1 deletions
  1. +6
    -1
      libs/loudmouth/Makefile
  2. +14
    -0
      libs/loudmouth/patches/020-openssl-deprecated.patch

+ 6
- 1
libs/loudmouth/Makefile View File

@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=loudmouth
PKG_VERSION:=1.5.3
PKG_RELEASE:=2
PKG_RELEASE:=3
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
PKG_SOURCE_URL:=https://codeload.github.com/mcabber/loudmouth/tar.gz/$(PKG_VERSION)?
@ -38,10 +38,15 @@ define Package/loudmouth/description
endef
CONFIGURE_ARGS += \
--disable-debug \
--without-compile-warnings \
--without-idn \
--with-ssl=openssl
CONFIGURE_VARS += \
ac_cv_lib_crypto_BIO_f_base64=yes \
ac_cv_lib_ssl_SSL_new=yes
define Build/InstallDev
$(INSTALL_DIR) $(1)/usr/include/
$(CP) \


+ 14
- 0
libs/loudmouth/patches/020-openssl-deprecated.patch View File

@ -0,0 +1,14 @@
--- a/loudmouth/lm-ssl-openssl.c
+++ b/loudmouth/lm-ssl-openssl.c
@@ -345,9 +345,11 @@ _lm_ssl_initialize (LmSSL *ssl)
/*const char *cert_file = NULL;*/
if (!initialized) {
+#if OPENSSL_VERSION_NUMBER < 0x10100000L
SSL_library_init();
/* FIXME: Is this needed when we are not in debug? */
SSL_load_error_strings();
+#endif
initialized = TRUE;
}

Loading…
Cancel
Save