Browse Source

socat: update to 1.7.4.1

Remove upstreamed patch.

Signed-off-by: Chukun Pan <amadeus@jmu.edu.cn>
lilik-openwrt-22.03
Chukun Pan 3 years ago
committed by Rosen Penev
parent
commit
373053a1e4
2 changed files with 3 additions and 21 deletions
  1. +3
    -3
      net/socat/Makefile
  2. +0
    -18
      net/socat/patches/100-usleep.patch

+ 3
- 3
net/socat/Makefile View File

@ -6,12 +6,12 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=socat
PKG_VERSION:=1.7.3.4
PKG_RELEASE:=3
PKG_VERSION:=1.7.4.1
PKG_RELEASE:=1
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
PKG_SOURCE_URL:=http://www.dest-unreach.org/socat/download
PKG_HASH:=972374ca86f65498e23e3259c2ee1b8f9dbeb04d12c2a78c0c9b5d1cb97dfdfc
PKG_HASH:=3faca25614e89123dff5045680549ecef519d02e331aaf3c4f5a8f6837c675e9
PKG_MAINTAINER:=Ted Hess <thess@kitschensync.net>
PKG_LICENSE:=GPL-2.0-or-later OpenSSL


+ 0
- 18
net/socat/patches/100-usleep.patch View File

@ -1,18 +0,0 @@
--- a/sycls.c
+++ b/sycls.c
@@ -1329,6 +1329,7 @@ unsigned int Sleep(unsigned int seconds)
return retval;
}
+#if 0
/* obsolete by POSIX.1-2001 */
void Usleep(unsigned long usec) {
Debug1("usleep(%lu)", usec);
@@ -1336,6 +1337,7 @@ void Usleep(unsigned long usec) {
Debug("usleep() ->");
return;
}
+#endif
#if HAVE_NANOSLEEP
unsigned int Nanosleep(const struct timespec *req, struct timespec *rem) {

Loading…
Cancel
Save