Browse Source

Merge pull request #11944 from jefferyto/python3-pip-pep517-pyc-fix

python3-pip: Fix error when installing packages that require compilation
lilik-openwrt-22.03
Hannu Nyman 4 years ago
committed by GitHub
parent
commit
368a072c8a
No known key found for this signature in database GPG Key ID: 4AEE18F83AFDEB23
2 changed files with 14 additions and 1 deletions
  1. +1
    -1
      lang/python/python3-version.mk
  2. +13
    -0
      lang/python/python3/patches-pip/001-pep517-pyc-fix.patch

+ 1
- 1
lang/python/python3-version.mk View File

@ -13,7 +13,7 @@ PYTHON3_VERSION_MICRO:=2
PYTHON3_VERSION:=$(PYTHON3_VERSION_MAJOR).$(PYTHON3_VERSION_MINOR)
PYTHON3_SETUPTOOLS_PKG_RELEASE:=1
PYTHON3_PIP_PKG_RELEASE:=2
PYTHON3_PIP_PKG_RELEASE:=3
PYTHON3_SETUPTOOLS_VERSION:=41.2.0
PYTHON3_PIP_VERSION:=19.2.3

+ 13
- 0
lang/python/python3/patches-pip/001-pep517-pyc-fix.patch View File

@ -0,0 +1,13 @@
diff -Nurp a/pip/_vendor/pep517/wrappers.py b/pip/_vendor/pep517/wrappers.py
--- a/pip/_vendor/pep517/wrappers.py 2019-07-30 20:02:13.000000000 +0800
+++ b/pip/_vendor/pep517/wrappers.py 2020-04-24 17:23:35.764905235 +0800
@@ -10,6 +10,9 @@ from . import compat
_in_proc_script = pjoin(dirname(abspath(__file__)), '_in_process.py')
+if not os.path.isfile(_in_proc_script):
+ _in_proc_script = pjoin(dirname(abspath(__file__)), '_in_process.pyc')
+
@contextmanager
def tempdir():

Loading…
Cancel
Save