Browse Source

zerotier: update to version 1.2.4

Zerotier now needs to have libstd, libminiupnpc and libnatpmp.

Signed-off-by: Moritz Warning <moritzwarning@web.de>
lilik-openwrt-22.03
Moritz Warning 7 years ago
parent
commit
350cc48049
5 changed files with 59 additions and 87 deletions
  1. +1
    -11
      net/zerotier/Config.in
  2. +9
    -14
      net/zerotier/Makefile
  3. +0
    -28
      net/zerotier/patches/0001-prevent-D_FORTIFY_SOURCE-from-being-defined-twice.patch
  4. +25
    -34
      net/zerotier/patches/0001-use-external-libminiupnpc-and-libnatpmp.patch
  5. +24
    -0
      net/zerotier/patches/0002-pin-target-to-linux.patch

+ 1
- 11
net/zerotier/Config.in View File

@ -6,18 +6,8 @@ config ZEROTIER_ENABLE_DEBUG
depends on PACKAGE_zerotier
default n
config ZEROTIER_ENABLE_PORTMAPPING
bool "Build with MiniUPnPc and NAT-PMP support"
depends on PACKAGE_zerotier
default n
config ZEROTIER_ENABLE_CLUSTER
bool "Build with cluster support"
depends on PACKAGE_zerotier
default n
config ZEROTIER_ENABLE_SELFTEST
bool "Build self test program"
bool "Build a self test program"
depends on PACKAGE_zerotier
default n


+ 9
- 14
net/zerotier/Makefile View File

@ -6,17 +6,17 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=zerotier
PKG_VERSION:=1.2.2
PKG_RELEASE:=4
PKG_VERSION:=1.2.4
PKG_RELEASE:=1
PKG_LICENSE:=GPL-3.0
PKG_SOURCE_PROTO:=git
PKG_SOURCE_URL:=https://github.com/zerotier/ZeroTierOne
PKG_SOURCE_SUBDIR:=ZeroTierOne-$(PKG_VERSION)
PKG_SOURCE_VERSION:=cfe0d0971f3ce5972d955250dc1ff6ec7a30e3f7
PKG_SOURCE_VERSION:=fe5257df81c4ec4b5d48f707eb794de0748b7ac0
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
PKG_MIRROR_MD5SUM:=c8c3219c995a59161832d580a194f6280de7a4eef75cebece6f38400b64f003e
PKG_MIRROR_HASH:=131436529d26f8eb975a0a8705b489cc22a1139c323755895c1776db579003bc
PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_SOURCE_SUBDIR)
PKG_BUILD_PARALLEL:=1
@ -25,7 +25,7 @@ include $(INCLUDE_DIR)/package.mk
define Package/zerotier
SECTION:=net
CATEGORY:=Network
DEPENDS:=+libpthread +kmod-tun +ip +libstdcpp +ZEROTIER_ENABLE_PORTMAPPING:libminiupnpc +ZEROTIER_ENABLE_PORTMAPPING:libnatpmp
DEPENDS:=+libpthread +libstdcpp +kmod-tun +ip +libminiupnpc +libnatpmp
TITLE:=Create flat virtual Ethernet networks of almost unlimited size
URL:=https://www.zerotier.com
SUBMENU:=VPN
@ -40,18 +40,13 @@ define Package/zerotier/config
source "$(SOURCE)/Config.in"
endef
ifeq ($(CONFIG_ZEROTIER_ENABLE_CLUSTER),y)
MAKE_FLAGS += ZT_ENABLE_CLUSTER=1
endif
ifeq ($(CONFIG_ZEROTIER_ENABLE_PORTMAPPING),y)
MAKE_FLAGS += ZT_ENABLE_PORTMAPPING=1
endif
ifeq ($(CONFIG_ZEROTIER_ENABLE_DEBUG),y)
TARGET_CXXFLAGS += -DZT_TRACE -ggdb3
MAKE_FLAGS += ZT_DEBUG=1
endif
MAKE_FLAGS += \
DEFS="" \
define Build/Compile
$(call Build/Compile/Default,one)
ifeq ($(CONFIG_ZEROTIER_ENABLE_SELFTEST),y)


+ 0
- 28
net/zerotier/patches/0001-prevent-D_FORTIFY_SOURCE-from-being-defined-twice.patch View File

@ -1,28 +0,0 @@
From 4fd495fca8417a8fd4405951d1eee80f345eaf9b Mon Sep 17 00:00:00 2001
From: Moritz Warning <moritzwarning@web.de>
Date: Sun, 19 Mar 2017 01:13:14 +0100
Subject: [PATCH 1/2] prevent D_FORTIFY_SOURCE from being defined twice
---
make-linux.mk | 3 ++-
1 file changed, 2 insertions(+), 1 deletion(-)
diff --git a/make-linux.mk b/make-linux.mk
index 7c77f58f..508d8c42 100644
--- a/make-linux.mk
+++ b/make-linux.mk
@@ -8,9 +8,10 @@ ifeq ($(origin CXX),default)
endif
INCLUDES?=
-DEFS?=-D_FORTIFY_SOURCE=2
+DEFS?=
LDLIBS?=
DESTDIR?=
+ZT_ENABLE_PORTMAPPING?=0
include objects.mk
--
2.12.0

net/zerotier/patches/0002-make-natpmp-miniupnpc-configurable.patch → net/zerotier/patches/0001-use-external-libminiupnpc-and-libnatpmp.patch View File


+ 24
- 0
net/zerotier/patches/0002-pin-target-to-linux.patch View File

@ -0,0 +1,24 @@
From b8a0598002fd08618d20cd1bbfb03559435241a8 Mon Sep 17 00:00:00 2001
From: Moritz Warning <moritzwarning@web.de>
Date: Thu, 4 May 2017 22:35:58 +0200
Subject: [PATCH 2/2] pin target to linux
---
Makefile | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/Makefile b/Makefile
index 9511862..d5b0dfc 100644
--- a/Makefile
+++ b/Makefile
@@ -1,6 +1,6 @@
# Common makefile -- loads make rules for each platform
-OSTYPE=$(shell uname -s)
+OSTYPE=Linux
ifeq ($(OSTYPE),Darwin)
include make-mac.mk
--
2.1.4

Loading…
Cancel
Save