Added a few lua modules (lpeg, md5, cjson, copas, coxpcall, lzlib, rings...lilik-openwrt-22.03
@ -0,0 +1,48 @@ | |||||
# | |||||
# Copyright (C) 2015 OpenWrt.org | |||||
# | |||||
# This is free software, licensed under the GNU General Public License v2. | |||||
# See /LICENSE for more information. | |||||
# | |||||
include $(TOPDIR)/rules.mk | |||||
PKG_NAME:=lpeg | |||||
PKG_VERSION:=0.12.2 | |||||
PKG_RELEASE:=1 | |||||
PKG_MAINTAINER:=Dirk Chang <dirk@kooiot.com> | |||||
PKG_LICENSE:=MIT | |||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz | |||||
PKG_SOURCE_URL:=http://www.inf.puc-rio.br/~roberto/lpeg/ | |||||
PKG_MD5SUM:=fabb614eb46e370d4f6b8fd82d17ca7e | |||||
PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION) | |||||
include $(INCLUDE_DIR)/package.mk | |||||
define Package/lpeg | |||||
SUBMENU:=Lua | |||||
SECTION:=lang | |||||
CATEGORY:=Languages | |||||
TITLE:=LPeg | |||||
URL:=http://www.inf.puc-rio.br/~roberto/lpeg/ | |||||
DEPENDS:=+lua | |||||
endef | |||||
define Package/lpeg/description | |||||
LPeg is a new pattern-matching library for Lua, based on Parsing Expression Grammars (PEGs) | |||||
endef | |||||
define Build/Configure | |||||
endef | |||||
# add make variable overrides here | |||||
MAKE_FLAGS += | |||||
define Package/lpeg/install | |||||
$(INSTALL_DIR) $(1)/usr/lib/lua | |||||
$(INSTALL_BIN) $(PKG_BUILD_DIR)/lpeg.so $(1)/usr/lib/lua | |||||
endef | |||||
$(eval $(call BuildPackage,lpeg)) |
@ -0,0 +1,50 @@ | |||||
# | |||||
# Copyright (C) 2015 OpenWrt.org | |||||
# | |||||
# This is free software, licensed under the GNU General Public License v2. | |||||
# See /LICENSE for more information. | |||||
# | |||||
include $(TOPDIR)/rules.mk | |||||
PKG_NAME:=lua-cjson | |||||
PKG_VERSION:=2.1.0 | |||||
PKG_RELEASE:=1 | |||||
PKG_MAINTAINER:=Dirk Chang <dirk@kooiot.com> | |||||
PKG_LICENSE:=MIT | |||||
PKG_LICENSE_FILES:=LICENSE | |||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz | |||||
PKG_SOURCE_URL:=http://www.kyne.com.au/~mark/software/download/ | |||||
PKG_MD5SUM:=24f270663e9f6ca8ba2a02cef19f7963 | |||||
PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION) | |||||
include $(INCLUDE_DIR)/package.mk | |||||
include $(INCLUDE_DIR)/cmake.mk | |||||
define Package/lua-cjson | |||||
SUBMENU:=Lua | |||||
SECTION:=lang | |||||
CATEGORY:=Languages | |||||
TITLE:=Lua CJSON parser | |||||
URL:=https://github.com/mpx/lua-cjson | |||||
DEPENDS:= +lua +libzmq | |||||
endef | |||||
define Package/lua-cjson/description | |||||
Lua CJSON is a fast JSON encoding/parsing module for Lua. | |||||
endef | |||||
CMAKE_OPTIONS += \ | |||||
-DUSE_LUA=ON | |||||
define Package/lua-cjson/install | |||||
$(INSTALL_DIR) $(1)/usr/lib/lua | |||||
$(INSTALL_BIN) $(PKG_BUILD_DIR)/cjson.so $(1)/usr/lib/lua/ | |||||
$(INSTALL_DIR) $(1)/usr/lib/lua/cjson | |||||
$(INSTALL_DATA) $(PKG_BUILD_DIR)/lua/cjson/util.lua $(1)/usr/lib/lua/cjson | |||||
endef | |||||
$(eval $(call BuildPackage,lua-cjson)) |
@ -0,0 +1,62 @@ | |||||
# | |||||
# Copyright (C) 2009-2013 OpenWrt.org | |||||
# | |||||
# This is free software, licensed under the GNU General Public License v2. | |||||
# See /LICENSE for more information. | |||||
# | |||||
include $(TOPDIR)/rules.mk | |||||
PKG_NAME:=lua-copas | |||||
PKG_VERSION:=2.0.0 | |||||
PKG_RELEASE:=1 | |||||
PKG_MAINTAINER:=Dirk Chang <dirk@kooiot.com> | |||||
PKG_LICENSE:=MIT | |||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz | |||||
PKG_SOURCE_URL:=https://github.com/keplerproject/copas.git | |||||
PKG_SOURCE_PROTO:=git | |||||
PKG_SOURCE_VERSION:=f39a80add9f7c010ac979297652bbaaea0360a27 | |||||
PKG_SOURCE_SUBDIR:=$(PKG_NAME)-$(PKG_VERSION) | |||||
PKG_INSTALL:=1 | |||||
include $(INCLUDE_DIR)/package.mk | |||||
define Package/lua-copas | |||||
SUBMENU:=Lua | |||||
SECTION:=lang | |||||
CATEGORY:=Languages | |||||
TITLE:=Lua-Copas | |||||
URL:=https://github.com/keplerproject/copas | |||||
DEPENDS:=+lua | |||||
endef | |||||
define Package/lua-copas/description | |||||
Copas is a dispatcher based on coroutines that can be used by TCP/IP servers. | |||||
endef | |||||
define Build/Configure | |||||
endef | |||||
define Build/Compile | |||||
$(MAKE) -C $(PKG_BUILD_DIR) \ | |||||
T="$(BUILD_VARIANT)" \ | |||||
PREFIX="$(PKG_INSTALL_DIR)/usr" \ | |||||
install | |||||
endef | |||||
# add make variable overrides here | |||||
MAKE_FLAGS += | |||||
define Package/lua-copas/install | |||||
$(INSTALL_DIR) $(1)/usr/lib/lua | |||||
$(INSTALL_DIR) $(1)/usr/lib/lua/copas | |||||
$(INSTALL_DATA) $(PKG_BUILD_DIR)/src/copas.lua $(1)/usr/lib/lua | |||||
$(INSTALL_DATA) $(PKG_BUILD_DIR)/src/copas/ftp.lua $(1)/usr/lib/lua/copas | |||||
$(INSTALL_DATA) $(PKG_BUILD_DIR)/src/copas/smtp.lua $(1)/usr/lib/lua/copas | |||||
$(INSTALL_DATA) $(PKG_BUILD_DIR)/src/copas/http.lua $(1)/usr/lib/lua/copas | |||||
$(INSTALL_DATA) $(PKG_BUILD_DIR)/src/copas/limit.lua $(1)/usr/lib/lua/copas | |||||
endef | |||||
$(eval $(call BuildPackage,lua-copas)) |
@ -0,0 +1,15 @@ | |||||
--- lua-copas-1.2.1_org/Makefile 2014-06-04 16:39:17.451563827 +0800 | |||||
+++ lua-copas-1.2.1/Makefile 2014-06-04 16:39:41.115563309 +0800 | |||||
@@ -1,10 +1,10 @@ | |||||
# $Id: Makefile,v 1.3 2007/10/29 22:50:16 carregal Exp $ | |||||
# Default prefix | |||||
-PREFIX = /usr/local | |||||
+PREFIX ?= $(DESTDIR)/usr | |||||
# System's lua directory (where Lua libraries are installed) | |||||
-LUA_DIR= $(PREFIX)/share/lua/5.1 | |||||
+LUA_DIR= $(PREFIX)/lib/lua | |||||
install: | |||||
mkdir -p $(LUA_DIR)/copas |
@ -0,0 +1,59 @@ | |||||
# | |||||
# Copyright (C) 2009-2013 OpenWrt.org | |||||
# | |||||
# This is free software, licensed under the GNU General Public License v2. | |||||
# See /LICENSE for more information. | |||||
# | |||||
include $(TOPDIR)/rules.mk | |||||
PKG_NAME:=lua-coxpcall | |||||
PKG_VERSION:=1.15.0 | |||||
PKG_RELEASE:=1 | |||||
PKG_MAINTAINER:=Dirk Chang <dirk@kooiot.com> | |||||
PKG_LICENSE:=MIT | |||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz | |||||
PKG_SOURCE_URL:=https://github.com/keplerproject/coxpcall.git | |||||
PKG_SOURCE_PROTO:=git | |||||
PKG_SOURCE_VERSION:=979257892884816c97391dfd7b0a7b30dcc8f479 | |||||
PKG_SOURCE_SUBDIR:=$(PKG_NAME)-$(PKG_VERSION) | |||||
PKG_INSTALL:=1 | |||||
include $(INCLUDE_DIR)/package.mk | |||||
define Package/lua-coxpcall | |||||
SUBMENU:=Lua | |||||
SECTION:=lang | |||||
CATEGORY:=Languages | |||||
TITLE:=Lua-Coxpcall | |||||
URL:=https://github.com/keplerproject/coxpcall | |||||
DEPENDS:=+lua | |||||
endef | |||||
define Package/lua-coxpcall/description | |||||
Coxpcall encapsulates the protected calls with a coroutine based loop, | |||||
so errors can be dealed without the usual pcall/xpcall issues with coroutines. | |||||
endef | |||||
TARGET_CFLAGS += $(FPIC) | |||||
# add make variable overrides here | |||||
MAKE_FLAGS += | |||||
define Build/Configure | |||||
endef | |||||
define Build/Compile | |||||
$(MAKE) -C $(PKG_BUILD_DIR) \ | |||||
T="$(BUILD_VARIANT)" \ | |||||
LUA_DIR="$(PKG_INSTALL_DIR)/usr/lib/lua" \ | |||||
install | |||||
endef | |||||
define Package/lua-coxpcall/install | |||||
$(INSTALL_DIR) $(1)/usr/lib/lua | |||||
$(INSTALL_DATA) $(PKG_BUILD_DIR)/src/coxpcall.lua $(1)/usr/lib/lua | |||||
endef | |||||
$(eval $(call BuildPackage,lua-coxpcall)) |
@ -0,0 +1,4 @@ | |||||
--- lua-coxpcall-1.15.0_org/config 1970-01-01 08:00:00.000000000 +0800 | |||||
+++ lua-coxpcall-1.15.0/config 2014-06-04 16:51:55.487547258 +0800 | |||||
@@ -0,0 +1 @@ | |||||
+LUA_DIR ?=$(DESTDIR)/usr/lib/lua |
@ -0,0 +1,49 @@ | |||||
# | |||||
# Copyright (C) 2015 OpenWrt.org | |||||
# | |||||
# This is free software, licensed under the GNU General Public License v2. | |||||
# See /LICENSE for more information. | |||||
# | |||||
include $(TOPDIR)/rules.mk | |||||
PKG_NAME:=lua-lzlib | |||||
PKG_VERSION:=0.4.1 | |||||
PKG_RELEASE:=1 | |||||
PKG_MAINTAINER:=Dirk Chang <dirk@kooiot.com> | |||||
PKG_LICENSE:=MIT | |||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz | |||||
PKG_SOURCE_URL:=https://github.com/LuaDist/lzlib.git | |||||
PKG_SOURCE_PROTO:=git | |||||
PKG_SOURCE_VERSION:=9fa3993bb4504fbbc10511cde141e1c6a48c072d | |||||
PKG_SOURCE_SUBDIR:=$(PKG_NAME)-$(PKG_VERSION) | |||||
PKG_INSTALL:=1 | |||||
include $(INCLUDE_DIR)/package.mk | |||||
define Package/lua-lzlib | |||||
SUBMENU:=Lua | |||||
SECTION:=lang | |||||
CATEGORY:=Languages | |||||
TITLE:=Lua zlib binding | |||||
URL:=http://github.com/LuaDist/lzlib | |||||
DEPENDS:= +lua +zlib | |||||
endef | |||||
define Package/lua-lzlib/description | |||||
A library to access zlib library functions and also to read/write gzip files using an interface similar to the base io package. | |||||
endef | |||||
define Build/Install | |||||
endef | |||||
define Package/lua-lzlib/install | |||||
$(INSTALL_DIR) $(1)/usr/lib/lua | |||||
$(INSTALL_BIN) $(PKG_BUILD_DIR)/zlib.so $(1)/usr/lib/lua/ | |||||
$(INSTALL_DATA) $(PKG_BUILD_DIR)/gzip.lua $(1)/usr/lib/lua/ | |||||
endef | |||||
$(eval $(call BuildPackage,lua-lzlib)) |
@ -0,0 +1,75 @@ | |||||
# | |||||
# Copyright (C) 2015 OpenWrt.org | |||||
# | |||||
# This is free software, licensed under the GNU General Public License v2. | |||||
# See /LICENSE for more information. | |||||
# | |||||
include $(TOPDIR)/rules.mk | |||||
PKG_NAME:=lua-md5 | |||||
PKG_VERSION:=1.2 | |||||
PKG_RELEASE:=1 | |||||
PKG_MAINTAINER:=Dirk Chang <dirk@kooiot.com> | |||||
PKG_LICENSE:=MIT | |||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz | |||||
PKG_SOURCE_URL:=https://github.com/keplerproject/md5.git | |||||
PKG_SOURCE_PROTO:=git | |||||
PKG_SOURCE_VERSION:=024b65738b4434860777fc43d7cacaefea29ec60 | |||||
PKG_SOURCE_SUBDIR:=$(PKG_NAME)-$(PKG_VERSION) | |||||
PKG_INSTALL:=1 | |||||
include $(INCLUDE_DIR)/package.mk | |||||
define Package/lua-md5 | |||||
SUBMENU:=Lua | |||||
SECTION:=lang | |||||
CATEGORY:=Languages | |||||
TITLE:=Lua-MD5 | |||||
URL:=https://github.com/keplerproject/md5 | |||||
DEPENDS:=+lua | |||||
endef | |||||
define Package/lua-md5/description | |||||
MD5 offers basic cryptographic facilities for Lua | |||||
endef | |||||
TARGET_CFLAGS += $(FPIC) | |||||
# add make variable overrides here | |||||
MAKE_FLAGS += | |||||
define Build/Configure | |||||
endef | |||||
define Build/Compile | |||||
$(MAKE) -C $(PKG_BUILD_DIR) \ | |||||
PREFIX="$(STAGING_DIR)/usr" \ | |||||
LUA_LIBDIR="$(STAGING_DIR)/usr/lib/lua" \ | |||||
clean | |||||
$(MAKE) -C $(PKG_BUILD_DIR) \ | |||||
PREFIX="$(STAGING_DIR)/usr" \ | |||||
LUA_LIBDIR="$(STAGING_DIR)/usr/lib/lua" \ | |||||
LIB_OPTION="-shared" \ | |||||
CC="$(TARGET_CROSS)gcc" \ | |||||
CFLAGS="$(TARGET_CFLAGS) $(TARGET_CPPFLAGS)" \ | |||||
all | |||||
endef | |||||
define Build/Install | |||||
$(MAKE) -C $(PKG_BUILD_DIR) \ | |||||
LUA_LIBDIR="$(PKG_INSTALL_DIR)/usr/lib/lua" \ | |||||
LUA_DIR="$(PKG_INSTALL_DIR)/usr/lib/lua" \ | |||||
install | |||||
endef | |||||
define Package/lua-md5/install | |||||
$(INSTALL_DIR) $(1)/usr/lib/lua | |||||
$(INSTALL_DATA) $(PKG_BUILD_DIR)/src/md5.lua $(1)/usr/lib/lua | |||||
$(INSTALL_DIR) $(1)/usr/lib/lua/md5 | |||||
$(INSTALL_BIN) $(PKG_BUILD_DIR)/src/core.so $(1)/usr/lib/lua/md5/core.so | |||||
endef | |||||
$(eval $(call BuildPackage,lua-md5)) |
@ -0,0 +1,19 @@ | |||||
--- lua-md5-1.2/config 2014-06-04 16:55:50.000000000 +0800 | |||||
+++ lua-md5-1.2_new/config 2014-06-04 16:57:54.223539416 +0800 | |||||
@@ -1,13 +1,13 @@ | |||||
# Installation directories | |||||
# Default prefix | |||||
-PREFIX = /usr/local | |||||
+PREFIX = /usr | |||||
# System's libraries directory (where binary libraries are installed) | |||||
-LUA_LIBDIR= $(PREFIX)/lib/lua/5.1 | |||||
+LUA_LIBDIR= $(PREFIX)/lib/lua | |||||
# System's lua directory (where Lua libraries are installed) | |||||
-LUA_DIR= $(PREFIX)/share/lua/5.1 | |||||
+LUA_DIR= $(PREFIX)/lib/lua | |||||
# Lua includes directory | |||||
LUA_INC= $(PREFIX)/include |
@ -0,0 +1,10 @@ | |||||
--- a/Makefile.orig 2014-06-04 17:16:40.083514808 +0800 | |||||
+++ b/Makefile 2014-06-04 17:17:27.111513780 +0800 | |||||
@@ -1,6 +1,6 @@ | |||||
# $Id: Makefile,v 1.7 2007/10/11 00:02:56 carregal Exp $ | |||||
-CONFIG= ./config | |||||
+CFLAGS+= -fPIC | |||||
include $(CONFIG) | |||||
@ -0,0 +1,56 @@ | |||||
# | |||||
# Copyright (C) 2015 OpenWrt.org | |||||
# | |||||
# This is free software, licensed under the GNU General Public License v2. | |||||
# See /LICENSE for more information. | |||||
# | |||||
include $(TOPDIR)/rules.mk | |||||
PKG_NAME:=lua-mobdebug | |||||
PKG_VERSION:=0.61 | |||||
PKG_RELEASE:=1 | |||||
PKG_MAINTAINER:=Dirk Chang <dirk@kooiot.com> | |||||
PKG_LICENSE:=MIT | |||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz | |||||
PKG_SOURCE_URL:=https://github.com/pkulchenko/MobDebug.git | |||||
PKG_SOURCE_PROTO:=git | |||||
PKG_SOURCE_VERSION:=9a03aa59696647ba3b7f9ae2f29a9f28532a4feb | |||||
PKG_SOURCE_SUBDIR:=$(PKG_NAME)-$(PKG_VERSION) | |||||
PKG_INSTALL:=1 | |||||
include $(INCLUDE_DIR)/package.mk | |||||
define Package/lua-mobdebug | |||||
SUBMENU:=Lua | |||||
SECTION:=lang | |||||
CATEGORY:=Languages | |||||
TITLE:=Lua-MobDebug | |||||
URL:=https://github.com/pkulchenko/MobDebug | |||||
DEPENDS:=+lua | |||||
endef | |||||
define Package/lua-mobdebug/description | |||||
MobDebug is a remote debugger for Lua (including Lua 5.1, Lua 5.2, Lua 5.3, and LuaJIT 2.x). | |||||
endef | |||||
define Build/Configure | |||||
endef | |||||
define Build/Compile | |||||
endef | |||||
define Build/Install | |||||
endef | |||||
# add make variable overrides here | |||||
MAKE_FLAGS += | |||||
define Package/lua-mobdebug/install | |||||
$(INSTALL_DIR) $(1)/usr/lib/lua | |||||
$(INSTALL_DATA) $(PKG_BUILD_DIR)/src/mobdebug.lua $(1)/usr/lib/lua | |||||
endef | |||||
$(eval $(call BuildPackage,lua-mobdebug)) |
@ -0,0 +1,54 @@ | |||||
# | |||||
# Copyright (C) 2015 OpenWrt.org | |||||
# | |||||
# This is free software, licensed under the GNU General Public License v2. | |||||
# See /LICENSE for more information. | |||||
# | |||||
include $(TOPDIR)/rules.mk | |||||
PKG_NAME:=lua-rings | |||||
PKG_VERSION:=1.3.0 | |||||
PKG_RELEASE:=1 | |||||
PKG_MAINTAINER:=Dirk Chang <dirk@kooiot.com> | |||||
PKG_LICENSE:=MIT | |||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz | |||||
PKG_SOURCE_URL:=https://github.com/keplerproject/rings.git | |||||
PKG_SOURCE_PROTO:=git | |||||
PKG_SOURCE_VERSION:=2b8a900f8b9dbde304859a3ac9d437795c3fdde3 | |||||
PKG_SOURCE_SUBDIR:=$(PKG_NAME)-$(PKG_VERSION) | |||||
PKG_FIXUP:=autoreconf | |||||
PKG_INSTALL:=1 | |||||
include $(INCLUDE_DIR)/package.mk | |||||
define Package/lua-rings | |||||
SUBMENU:=Lua | |||||
SECTION:=lang | |||||
CATEGORY:=Languages | |||||
TITLE:=Lua-Rings | |||||
URL:=http://www.inf.puc-rio.br/~roberto/lua-rings/ | |||||
DEPENDS:=+lua | |||||
endef | |||||
define Package/lua-rings/description | |||||
Rings is a library which provides a way to create new Lua states from within Lua. | |||||
endef | |||||
TARGET_CFLAGS += $(FPIC) | |||||
# add make variable overrides here | |||||
MAKE_FLAGS += | |||||
define Build/Configure | |||||
endef | |||||
define Package/lua-rings/install | |||||
$(INSTALL_DIR) $(1)/usr/lib/lua | |||||
$(INSTALL_BIN) $(PKG_BUILD_DIR)/src/rings.so $(1)/usr/lib/lua | |||||
$(INSTALL_DATA) $(PKG_BUILD_DIR)/src/stable.lua $(1)/usr/lib/lua | |||||
endef | |||||
$(eval $(call BuildPackage,lua-rings)) |
@ -0,0 +1,28 @@ | |||||
--- lua-rings-1.3.0_org/config 2014-06-04 15:24:24.223662038 +0800 | |||||
+++ lua-rings-1.3.0/config 2014-06-04 16:16:15.183594040 +0800 | |||||
@@ -1,15 +1,15 @@ | |||||
# Installation directories | |||||
# Default prefix | |||||
-PREFIX ?= /usr/local | |||||
+PREFIX ?= /usr | |||||
DESTDIR ?= / | |||||
# System's libraries directory (where binary libraries are installed) | |||||
-LUA_LIBDIR ?= $(PREFIX)/lib/lua/5.1 | |||||
+LUA_LIBDIR ?= $(PREFIX)/lib/lua | |||||
# System's lua directory (where Lua libraries are installed) | |||||
-LUA_DIR ?= $(PREFIX)/share/lua/5.1 | |||||
+LUA_DIR ?= $(PREFIX)/lib/lua | |||||
# Lua includes directory | |||||
LUA_INC ?= $(PREFIX)/include | |||||
@@ -24,6 +24,5 @@ | |||||
WARN ?= -O2 -Wall -fPIC -W -Waggregate-return -Wcast-align -Wmissing-prototypes -Wnested-externs -Wshadow -Wwrite-strings -Wpointer-arith -pedantic | |||||
INCS ?= -I$(LUA_INC) | |||||
CFLAGS ?= $(WARN) $(INCS) | |||||
-CC ?= gcc | |||||
# $Id: config,v 1.7 2007/10/29 22:51:39 carregal Exp $ |
@ -0,0 +1,11 @@ | |||||
--- lua-rings-1.3.0_org/Makefile 2014-06-04 15:24:37.583661746 +0800 | |||||
+++ lua-rings-1.3.0/Makefile 2014-06-04 15:23:41.611662970 +0800 | |||||
@@ -3,6 +3,8 @@ | |||||
T= rings | |||||
CONFIG= ./config | |||||
+CFLAGS+= -fPIC | |||||
+ | |||||
include $(CONFIG) | |||||
SRCS= src/rings.c |
@ -0,0 +1,62 @@ | |||||
# | |||||
# Copyright (C) 2015 OpenWrt.org | |||||
# | |||||
# This is free software, licensed under the GNU General Public License v2. | |||||
# See /LICENSE for more information. | |||||
# | |||||
include $(TOPDIR)/rules.mk | |||||
PKG_NAME:=lua-rs232 | |||||
PKG_VERSION:=1.0.3 | |||||
PKG_RELEASE:=1 | |||||
PKG_MAINTAINER:=Dirk Chang <dirk@kooiot.com> | |||||
PKG_LICENSE:=MIT | |||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz | |||||
PKG_SOURCE_URL:=https://github.com/srdgame/librs232.git | |||||
PKG_SOURCE_PROTO:=git | |||||
PKG_SOURCE_VERSION:=a9d463181e7f7034fe6a55bc38e845fb04fa93ba | |||||
PKG_SOURCE_SUBDIR:=$(PKG_NAME)-$(PKG_VERSION) | |||||
PKG_INSTALL:=1 | |||||
include $(INCLUDE_DIR)/package.mk | |||||
define Package/lua-rs232 | |||||
SUBMENU:=Lua | |||||
SECTION:=lang | |||||
CATEGORY:=Languages | |||||
TITLE:=Lua Serial Library | |||||
URL:=https://github.com/srdgame/librs232 | |||||
DEPENDS:= +lua | |||||
endef | |||||
define Package/lua-rs232/description | |||||
multiplatform library for serial communications over RS-232 | |||||
endef | |||||
CONFIGURE_ARGS += \ | |||||
--with-lua-inc=$(STAGING_DIR)/usr/include \ | |||||
--with-lua-lib=$(STAGING_DIR)/usr/lib | |||||
#define Build/Configure | |||||
# ( cd "$(PKG_BUILD_DIR)"; ./autogen.sh ) | |||||
# $(call Build/Configure/Default) | |||||
#endef | |||||
define Build/Configure | |||||
endef | |||||
define Build/Compile | |||||
(cd "$(PKG_BUILD_DIR)"; $(TARGET_CC) src/rs232.c src/rs232_posix.c bindings/lua/luars232.c -DLUAROCKS_HACK -std=gnu99 -I./include -I$(STAGING_DIR)/usr/include -L$(STAGING_DIR)/usr/lib -fPIC -shared -o luars232.so) | |||||
endef | |||||
define Build/Install | |||||
endef | |||||
define Package/lua-rs232/install | |||||
$(INSTALL_DIR) $(1)/usr/lib/lua | |||||
$(INSTALL_BIN) $(PKG_BUILD_DIR)/luars232.so $(1)/usr/lib/lua/ | |||||
endef | |||||
$(eval $(call BuildPackage,lua-rs232)) |
@ -0,0 +1,95 @@ | |||||
# | |||||
# Copyright (C) 2015 OpenWrt.org | |||||
# | |||||
# This is free software, licensed under the GNU General Public License v2. | |||||
# See /LICENSE for more information. | |||||
# | |||||
include $(TOPDIR)/rules.mk | |||||
PKG_NAME:=lua-wsapi | |||||
PKG_VERSION:=1.6.1 | |||||
PKG_RELEASE:=1 | |||||
PKG_MAINTAINER:=Dirk Chang <dirk@kooiot.com> | |||||
PKG_LICENSE:=MIT | |||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz | |||||
PKG_SOURCE_URL:=https://github.com/keplerproject/wsapi.git | |||||
PKG_SOURCE_PROTO:=git | |||||
PKG_SOURCE_VERSION:=eed8338401196cc155e59280adbe58d78933ead0 | |||||
PKG_SOURCE_SUBDIR:=$(PKG_NAME)-$(PKG_VERSION) | |||||
PKG_INSTALL:=1 | |||||
include $(INCLUDE_DIR)/package.mk | |||||
define Package/lua-wsapi/Default | |||||
SUBMENU:=Lua | |||||
SECTION:=lang | |||||
CATEGORY:=Languages | |||||
TITLE:=Lua WSAPI | |||||
URL:=http://www.keplerproject.org/wsapi | |||||
DEPENDS:= +lua | |||||
endef | |||||
define Package/lua-wsapi/Default/description | |||||
WSAPI is an API that abstracts the web server from Lua web applications | |||||
endef | |||||
define Package/lua-wsapi-base | |||||
$(call Package/lua-wsapi/Default) | |||||
TITLE+= base | |||||
DEPENDS+= +luafilesystem | |||||
VARIANT:=base | |||||
endef | |||||
define Package/lua-wsapi-base/description | |||||
$(call Package/lua-wsapi/Default/description) | |||||
. | |||||
This package contains the basic stuff. | |||||
endef | |||||
define Package/lua-wsapi-xavante | |||||
$(call Package/lua-wsapi/Default) | |||||
TITLE+= xavante | |||||
DEPENDS+= +lua-wsapi-base +lua-xavante | |||||
VARIANT:=xavante | |||||
endef | |||||
define Package/lua-wsapi-xavante/description | |||||
$(call Package/lua-wsapi/Default/description) | |||||
. | |||||
This package contains the Xavante stuff. | |||||
endef | |||||
define Build/Configure | |||||
endef | |||||
define Build/Compile | |||||
endef | |||||
define Build/Install | |||||
endef | |||||
define Package/lua-wsapi-base/install | |||||
$(INSTALL_DIR) $(1)/usr/lib/lua | |||||
$(INSTALL_DATA) $(PKG_BUILD_DIR)/src/wsapi.lua $(1)/usr/lib/lua | |||||
$(INSTALL_DIR) $(1)/usr/bin | |||||
$(INSTALL_BIN) $(PKG_BUILD_DIR)/src/launcher/wsapi.cgi $(1)/usr/bin | |||||
$(INSTALL_DIR) $(1)/usr/lib/lua/wsapi | |||||
$(INSTALL_DATA) $(PKG_BUILD_DIR)/src/wsapi/{common,request,response,util,cgi,sapi,ringer,mock}.lua $(1)/usr/lib/lua/wsapi | |||||
endef | |||||
define Package/lua-wsapi-xavante/install | |||||
$(INSTALL_DIR) $(1)/usr/bin | |||||
$(INSTALL_BIN) $(PKG_BUILD_DIR)/src/launcher/wsapi $(1)/usr/bin | |||||
$(INSTALL_DIR) $(1)/usr/lib/lua/wsapi | |||||
$(INSTALL_DATA) $(PKG_BUILD_DIR)/src/wsapi/xavante.lua $(1)/usr/lib/lua/wsapi | |||||
endef | |||||
$(eval $(call BuildPackage,lua-wsapi-base)) | |||||
$(eval $(call BuildPackage,lua-wsapi-xavante)) |
@ -0,0 +1,58 @@ | |||||
# | |||||
# Copyright (C) 2015 OpenWrt.org | |||||
# | |||||
# This is free software, licensed under the GNU General Public License v2. | |||||
# See /LICENSE for more information. | |||||
# | |||||
include $(TOPDIR)/rules.mk | |||||
PKG_NAME:=lua-xavante | |||||
PKG_VERSION:=2.3.0 | |||||
PKG_RELEASE:=1 | |||||
PKG_MAINTAINER:=Dirk Chang <dirk@kooiot.com> | |||||
PKG_LICENSE:=MIT | |||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz | |||||
PKG_SOURCE_URL:=https://github.com/keplerproject/xavante.git | |||||
PKG_SOURCE_PROTO:=git | |||||
PKG_SOURCE_VERSION:=9825b905133e14d37a4c179f2d02367ab93f1ef6 | |||||
PKG_SOURCE_SUBDIR:=$(PKG_NAME)-$(PKG_VERSION) | |||||
PKG_INSTALL:=1 | |||||
include $(INCLUDE_DIR)/package.mk | |||||
define Package/lua-xavante | |||||
SUBMENU:=Lua | |||||
SECTION:=lang | |||||
CATEGORY:=Languages | |||||
TITLE:=Xavante Web Server | |||||
URL:=http://www.keplerproject.org/xavante | |||||
DEPENDS:= +lua | |||||
endef | |||||
define Package/lua-xavante/description | |||||
Xavante is a Lua HTTP 1.1 Web server that uses a modular architecture based on URI mapped handlers. | |||||
endef | |||||
define Build/Configure | |||||
endef | |||||
define Build/Compile | |||||
endef | |||||
define Build/Install | |||||
endef | |||||
define Package/lua-xavante/install | |||||
$(INSTALL_DIR) $(1)/usr/lib/lua | |||||
$(INSTALL_DATA) $(PKG_BUILD_DIR)/src/sajax/sajax.lua $(1)/usr/lib/lua | |||||
$(INSTALL_DATA) $(PKG_BUILD_DIR)/src/xavante/xavante.lua $(1)/usr/lib/lua | |||||
$(INSTALL_DIR) $(1)/usr/lib/lua/xavante | |||||
$(INSTALL_DATA) $(PKG_BUILD_DIR)/src/xavante/{cgiluahandler,encoding,filehandler,httpd,mime,patternhandler,redirecthandler,vhostshandler,indexhandler,urlhandler,ruleshandler}.lua $(1)/usr/lib/lua/xavante | |||||
endef | |||||
$(eval $(call BuildPackage,lua-xavante)) |
@ -0,0 +1,48 @@ | |||||
# | |||||
# Copyright (C) 2015 OpenWrt.org | |||||
# | |||||
# This is free software, licensed under the GNU General Public License v2. | |||||
# See /LICENSE for more information. | |||||
# | |||||
include $(TOPDIR)/rules.mk | |||||
PKG_NAME:=lzmq | |||||
PKG_VERSION:=0.4.2 | |||||
PKG_RELEASE:=1 | |||||
PKG_MAINTAINER:=Dirk Chang <dirk@kooiot.com> | |||||
PKG_LICENSE:=MIT | |||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).zip | |||||
PKG_SOURCE_URL:=https://codeload.github.com/zeromq/lzmq/zip/v0.4.2? | |||||
PKG_MD5SUM:=6789895c925e7eb9036e526181ec1a33 | |||||
include $(INCLUDE_DIR)/package.mk | |||||
include $(INCLUDE_DIR)/cmake.mk | |||||
define Package/lzmq | |||||
SUBMENU:=Lua | |||||
SECTION:=lang | |||||
CATEGORY:=Languages | |||||
TITLE:=Lua ZeroMQ binding | |||||
URL:=https://github.com/moteus/lzmq/ | |||||
DEPENDS:= +lua +libzmq | |||||
endef | |||||
define Package/lzmq/description | |||||
LZMQ is a Lua binding to ZeroMQ. | |||||
endef | |||||
CMAKE_OPTIONS += \ | |||||
-DUSE_LUA=ON | |||||
define Package/lzmq/install | |||||
$(INSTALL_DIR) $(1)/usr/lib/lua | |||||
$(INSTALL_BIN) $(PKG_BUILD_DIR)/lzmq.so $(1)/usr/lib/lua/ | |||||
$(INSTALL_DIR) $(1)/usr/lib/lua/lzmq | |||||
$(INSTALL_BIN) $(PKG_BUILD_DIR)/lzmq/timer.so $(1)/usr/lib/lua/lzmq | |||||
$(CP) -R $(PKG_BUILD_DIR)/src/lua/lzmq/* $(1)/usr/lib/lua/lzmq | |||||
endef | |||||
$(eval $(call BuildPackage,lzmq)) |
@ -0,0 +1,81 @@ | |||||
# | |||||
# Copyright (C) 2015 OpenWrt.org | |||||
# | |||||
# This is free software, licensed under the GNU General Public License v2. | |||||
# See /LICENSE for more information. | |||||
# | |||||
# This Makefile for ZeroMQ | |||||
# | |||||
include $(TOPDIR)/rules.mk | |||||
PKG_NAME:=zeromq | |||||
PKG_VERSION:=4.0.5 | |||||
PKG_RELEASE:=1 | |||||
PKG_MAINTAINER:=Dirk Chang <dirk@kooiot.com> | |||||
PKG_LICENSE:=GPL-3.0+ | |||||
PKG_LICENSE_FILES:=LICENCE.txt | |||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz | |||||
PKG_SOURCE_URL:= http://download.zeromq.org | |||||
PKG_MD5SUM:=73c39f5eb01b9d7eaf74a5d899f1d03d | |||||
PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION) | |||||
PKG_BUILD_DEPENDS:=libuuid | |||||
PKG_FIXUP:=autoreconf | |||||
PKG_INSTALL:=1 | |||||
include $(INCLUDE_DIR)/uclibc++.mk | |||||
include $(INCLUDE_DIR)/package.mk | |||||
define Package/libzmq/Default | |||||
TITLE:=ZeroMQ - Code Connected | |||||
URL:=http://www.zeromq.org/ | |||||
endef | |||||
define Package/libzmq/Default/description | |||||
A replacment for raw socket developing library | |||||
endef | |||||
define Package/libzmq | |||||
$(call Package/libzmq/Default) | |||||
SECTION:=libs | |||||
CATEGORY:=Libraries | |||||
DEPENDS:=+libuuid +libpthread +librt $(CXX_DEPENDS) | |||||
TITLE+= (library) | |||||
URL:= | |||||
endef | |||||
define Package/libzmq/description | |||||
$(call Package/libzmq/Default/description) | |||||
This package contains the ZeroMQ shared library, used by other | |||||
programs. | |||||
endef | |||||
# add extra configure flags here | |||||
CONFIGURE_ARGS += \ | |||||
--enable-static \ | |||||
--enable-shared | |||||
# add make variable overrides here | |||||
MAKE_FLAGS += | |||||
define Build/InstallDev | |||||
$(INSTALL_DIR) $(1)/usr/include | |||||
$(CP) $(PKG_INSTALL_DIR)/usr/include/zmq.h $(1)/usr/include | |||||
$(CP) $(PKG_INSTALL_DIR)/usr/include/zmq_utils.h $(1)/usr/include | |||||
$(INSTALL_DIR) $(1)/usr/lib | |||||
$(CP) $(PKG_INSTALL_DIR)/usr/lib/libzmq.{a,so*} $(1)/usr/lib/ | |||||
$(INSTALL_DIR) $(1)/usr/lib/pkgconfig | |||||
$(CP) $(PKG_INSTALL_DIR)/usr/lib/pkgconfig/libzmq.pc $(1)/usr/lib/pkgconfig/ | |||||
endef | |||||
define Package/libzmq/install | |||||
$(INSTALL_DIR) $(1)/usr/lib | |||||
$(CP) $(PKG_INSTALL_DIR)/usr/lib/libzmq.so.* $(1)/usr/lib/ | |||||
endef | |||||
$(eval $(call BuildPackage,libzmq)) |
@ -0,0 +1,14 @@ | |||||
--- zeromq-4.0.4_org/configure.ac 2014-06-04 10:19:35.140061796 +0800 | |||||
+++ zeromq-4.0.4/configure.ac 2014-06-04 11:08:17.231997926 +0800 | |||||
@@ -127,8 +127,10 @@ | |||||
*linux*) | |||||
# Define on Linux to enable all library features. Define if using a gnu compiler | |||||
if test "x$GXX" = "xyes"; then | |||||
- CPPFLAGS="-D_GNU_SOURCE $CPPFLAGS" | |||||
+ CPPFLAGS="-D_GNU_SOURCE $CPPFLAGS -Wno-long-long" | |||||
fi | |||||
+ libzmq_pedantic="no" | |||||
+ libzmq_werror="no" | |||||
AC_DEFINE(ZMQ_HAVE_LINUX, 1, [Have Linux OS]) | |||||
libzmq_on_linux="yes" | |||||
@ -0,0 +1,10 @@ | |||||
--- zeromq-4.0.4_org/src/blob.hpp 2014-06-04 10:19:12.680062287 +0800 | |||||
+++ zeromq-4.0.4/src/blob.hpp 2014-06-04 10:30:31.168047457 +0800 | |||||
@@ -21,6 +21,7 @@ | |||||
#define __ZMQ_BLOB_HPP_INCLUDED__ | |||||
#include <string> | |||||
+#include <ios> | |||||
#include <string.h> | |||||
// Borrowed from id3lib_strings.h: |
@ -0,0 +1,10 @@ | |||||
diff -ruNa zeromq-4.0.4_org/tools/Makefile.am zeromq-4.0.4/tools/Makefile.am | |||||
--- zeromq-4.0.4_org/tools/Makefile.am 2014-06-03 20:01:12.392379933 +0800 | |||||
+++ zeromq-4.0.4/tools/Makefile.am 2014-06-03 19:59:18.616382420 +0800 | |||||
@@ -1,5 +1,5 @@ | |||||
EXTRA_DIST = curve_keygen.c | |||||
+CFLAGS += -std=c99 | |||||
- | |||||
INCLUDES = -I$(top_srcdir)/include | |||||
bin_PROGRAMS = curve_keygen |