Browse Source

Merge pull request #13020 from rittere/master

tayga: Added 64:ff9b:1::/48 as well-known prefix for NAT64 (RFC 8215)
lilik-openwrt-22.03
Rosen Penev 4 years ago
committed by GitHub
parent
commit
34215c958e
No known key found for this signature in database GPG Key ID: 4AEE18F83AFDEB23
2 changed files with 15 additions and 1 deletions
  1. +1
    -1
      ipv6/tayga/Makefile
  2. +14
    -0
      ipv6/tayga/patches/003-RFC8215.patch

+ 1
- 1
ipv6/tayga/Makefile View File

@ -4,7 +4,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=tayga
PKG_VERSION:=0.9.2
PKG_RELEASE:=2
PKG_RELEASE:=3
PKG_SOURCE:=tayga-$(PKG_VERSION).tar.bz2
PKG_SOURCE_URL:=http://www.litech.org/tayga/


+ 14
- 0
ipv6/tayga/patches/003-RFC8215.patch View File

@ -0,0 +1,14 @@
diff -Naur tayga-0.9.2.orig/addrmap.c tayga-0.9.2/addrmap.c
--- tayga-0.9.2.orig/addrmap.c 2011-05-25 15:11:30.000000000 +0100
+++ tayga-0.9.2/addrmap.c 2020-07-04 16:24:23.397081572 +0100
@@ -44,7 +44,9 @@
int validate_ip6_addr(const struct in6_addr *a)
{
/* Well-known prefix for NAT64 */
- if (a->s6_addr32[0] == WKPF && !a->s6_addr32[1] && !a->s6_addr32[2])
+ if (a->s6_addr32[0] == WKPF &&
+ (!a->s6_addr32[1] || (a->s6_addr16[2] == htonl(0x0001)))
+ && !a->s6_addr32[2])
return 0;
/* Reserved per RFC 2373 */

Loading…
Cancel
Save